• Latests updates broke deepin settings panel, login and power screen


    After latest updates - some dd packages and GTK, settings panel is nearly empty, only little top-left part of it is visible (avatar and time partially). Login screen shows only power button and avatar and power screen (shutdown, reboot etc) screen shows only “Start system monitor”. Everything is working when clicked or typed in blindly.

  • I cannot edit my post, here are those updates:

    [2018-02-16 00:01] [ALPM] transaction started
    [2018-02-16 00:01] [ALPM] upgraded gtk-update-icon-cache (3.22.27-1 -> 3.22.28-1)
    [2018-02-16 00:01] [ALPM] upgraded gtk3 (3.22.27-1 -> 3.22.28-1)
    [2018-02-16 00:01] [ALPM] upgraded vala (0.38.7-1 -> 0.38.8-1)
    [2018-02-16 00:01] [ALPM] transaction completed
    [2018-02-16 00:01] [ALPM] running 'glib-compile-schemas.hook'...
    [2018-02-16 00:01] [ALPM] running 'gtk-query-immodules-3.0.hook'...
    [2018-02-16 00:01] [ALPM] running 'gtk-update-icon-cache.hook'...
    [2018-02-16 00:01] [ALPM] running 'systemd-update.hook'...
    [2018-02-16 00:01] [ALPM] running 'update-desktop-database.hook'...
    [2018-02-16 23:53] [PAMAC] synchronizing package lists
    [2018-02-16 23:59] [ALPM] transaction started
    [2018-02-16 23:59] [ALPM] upgraded qt5-base (5.10.0-4 -> 5.10.1-1)
    [2018-02-16 23:59] [ALPM] upgraded qt5-svg (5.10.0-1 -> 5.10.1-1)
    [2018-02-16 23:59] [ALPM] upgraded qt5-multimedia (5.10.0-1 -> 5.10.1-1)
    [2018-02-16 23:59] [ALPM] upgraded qt5-x11extras (5.10.0-1 -> 5.10.1-1)
    [2018-02-16 23:59] [ALPM] upgraded qt5-xmlpatterns (5.10.0-1 -> 5.10.1-1)
    [2018-02-16 23:59] [ALPM] upgraded qt5-declarative (5.10.0-1 -> 5.10.1-1)
    [2018-02-16 23:59] [ALPM] upgraded dtkwidget (2.0.6.1-1 -> 2.0.6.1-2)
    [2018-02-16 23:59] [ALPM] upgraded libqtxdg (3.1.0-3 -> 3.1.0-4)
    [2018-02-16 23:59] [ALPM] upgraded qt5-styleplugins (5.0.0.20170311-4 -> 5.0.0.20170311-5)
    [2018-02-16 23:59] [ALPM] upgraded deepin-qt5dxcb-plugin (1.1.6-1 -> 1.1.8-2)
    [2018-02-16 23:59] [ALPM] upgraded deepin-qt5integration (0.2.8.3-2 -> 0.2.8.3-3)
    [2018-02-16 23:59] [ALPM] upgraded pyqt5-common (5.10-2 -> 5.10-3)
    [2018-02-16 23:59] [ALPM] upgraded python2-pyqt5 (5.10-2 -> 5.10-3)
    [2018-02-16 23:59] [ALPM] upgraded v4l-utils (1.14.1-1 -> 1.14.2-1)
    [2018-02-16 23:59] [ALPM] upgraded deepin-dock (4.5.12-1 -> 4.5.12-2)
    [2018-02-16 23:59] [ALPM] upgraded python-pyqt5 (5.10-2 -> 5.10-3)
    [2018-02-16 23:59] [ALPM] upgraded qt5-graphicaleffects (5.10.0-1 -> 5.10.1-1)
    [2018-02-16 23:59] [ALPM] upgraded qt5-location (5.10.0-1 -> 5.10.1-1)
    [2018-02-16 23:59] [ALPM] upgraded qt5-sensors (5.10.0-1 -> 5.10.1-1)
    [2018-02-16 23:59] [ALPM] upgraded qt5-webchannel (5.10.0-1 -> 5.10.1-1)
    [2018-02-16 23:59] [ALPM] upgraded qt5-webkit (5.212.0alpha2-11 -> 5.212.0alpha2-12)
    [2018-02-16 23:59] [ALPM] upgraded deepin-file-manager (1:4.4.7-3 -> 1:4.4.7-4)
    [2018-02-16 23:59] [ALPM] upgraded dtkwm (2.0.6-1 -> 2.0.6-2)
    
  • @luke_d my pc has the same problem, after the update stayed like this.

    0_1518916738283_DeepinScreenshot_20180217230935.png

    0_1518916747562_DeepinScreenshot_20180217231006.jpg

  • I have the exact same problem. Anyone managed to get a fix for this? I do not want to go back to using cinnamon 🙂

  • there are some troubles with latest updates on deeping packages, i will have a look into it on VM now!

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @mrfsb Exactly like that, plus power screen! What have you used for taking screenshots?

  • @luke_d the Print Screen key automatically triggers Deepin Screenshot tool

    You can still display the settings menu by clicking on the left of the clock, then back arrow.

    to add to the screenshots, the eerily empty power menu :

  • can someone provide journalctl -b -1 | grep dde | curl -F [email protected] https://ptpb.pw/?u=1

    ???

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Hi there everyone!

    I’ve been busy and so haven’t seen this thread until now - but if you guys are interested, there’s a whole long thread about it over on the Reborn OS forum. This issue was reported soon enough over there to warn most people (including me) not to update Deepin, and so I have not updated it personally. As such, I don’t exactly know everything about this Deepin issue; however, a long-time Deepin user over there has done extensive reasearch into it and has a ton of info posted about it. Including which package is causing all of these problems. If you would like to see his posts about it, please follow this link:

    https://rebornos.freeforums.net/thread/231/warning-update-deepin-login-disappeared

    Thanks!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

  • i just install new deepin wm and do not have the issue persistend…
    If i open config sidebar and click on it it appears… when i rightclick on powericon i can choose poweroff and it does …

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @keegan nice to see you around here 🙂

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • but it looks like there is not a real solution and also no workaround jet?

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • sumup of errors/warnings:

    dde-polkit-agent[837]: QXcbConnection: XCB error: 151 (Unknown), sequence: 2338, resource id: 0, major code: 143 (Unknown), minor code: 2
    ---
    com.deepin.dde.ControlCenter[601]: 2018-02-18, 09:01:55.058 [Warning] [                                                         0] QCoreApplication::postEvent: Unexpected null receiver
    Feb 18 09:06:55 spectre com.deepin.dde.ControlCenter[601]: 2018-02-18, 09:06:55.641 [Debug  ] [settingswidget.cpp   SettingsWidget::SettingsWidget      72] SettingsWidget::SettingsWidget(Frame*) I'm born!!!!
    Feb 18 09:06:55 spectre com.deepin.dde.ControlCenter[601]: 2018-02-18, 09:06:55.687 [Warning] [                                                         0] QPixmap::scaled: Pixmap is a null pixmap
    ---
    
    com.deepin.dde.Launcher[601]: dde-launcher: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
    ---
    
    Feb 17 22:01:33 spectre com.deepin.daemon.Accounts[311]: <warning> subrecorder.go:169: SubRecorder.loadStatusFromFile failed open /var/lib/dde-daemon/apps/launched-8c12ab9bb7dd4cfd256863eb53e45bc4.csv: no such file or directory
    Feb 17 22:01:33 spectre daemon/apps[653]: subrecorder.go:169: SubRecorder.loadStatusFromFile failed open /var/lib/dde-daemon/apps/launched-8c12ab9bb7dd4cfd256863eb53e45bc4.csv: no such file or directory
    ---
    Feb 17 22:01:33 spectre startdde[596]: switcher.go:124: Failed to load config: Failed to found config: /etc/deepin-wm-switcher/config.json
    Feb 17 22:01:33 spectre com.deepin.daemon.Display[596]: config_version.go:47: Failed to delete config: remove /home/wamari/.config/deepin/startdde/display.json: no such file or directory
    Feb 17 22:01:33 spectre dbus-daemon[311]: [system] Activating service name='com.deepin.daemon.helper.Backlight' requested by ':1.34' (uid=1000 pid=596 comm="/usr/bin/startdde ") (using servicehelper)
    Feb 17 22:01:33 spectre startdde[596]: switcher.go:145: Failed to set sogou skin: open /home/wamari/.config/sogou-qimpanel/main.conf: no such file or directory
    Feb 17 22:01:33 spectre startdde[596]: startmanager.go:89: open /usr/lib/UIAppSched.hooks/launched: no such file or directory
    Feb 17 22:01:34 spectre startdde[596]: session_procese.go:73: /usr/lib/deepin-daemon/dde-session-initializer StartDuration: 194.428779ms
    Feb 17 22:01:34 spectre com.deepin.daemon.Accounts[311]: <warning> subrecorder.go:169: SubRecorder.loadStatusFromFile failed open /home/wamari/.config/deepin/dde-daemon/apps/launched-4ab4e72f436b88e0c50532b65baa0c15.csv: no such file or directory
    Feb 17 22:01:34 spectre daemon/apps[653]: subrecorder.go:169: SubRecorder.loadStatusFromFile failed open /home/wamari/.config/deepin/dde-daemon/apps/launched-4ab4e72f436b88e0c50532b65baa0c15.csv: no such file or directory
    ---
    Feb 18 08:23:48 spectre dde-lockservice[6933]: pam_unix(lightdm:auth): authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=  user=wamari
    Feb 18 08:23:48 spectre com.deepin.dde.lockFront[601]: 2018-02-18, 08:23:48.032 [Debug  ] [lockmanager.cpp      LockManager::lockServiceEvent       397] 2 6923 "wamari" "Password: "
    Feb 18 08:23:48 spectre com.deepin.dde.lockFront[601]: 2018-02-18, 08:23:48.032 [Debug  ] [lockmanager.cpp      LockManager::lockServiceEvent       417] prompt secret from pam:  "Password: "
    Feb 18 08:23:50 spectre com.deepin.dde.LockService[311]: Failed to authenticate: Authentication failure
    Feb 18 08:23:50 spectre com.deepin.dde.lockFront[601]: 2018-02-18, 08:23:50.026 [Debug  ] [lockmanager.cpp      LockManager::lockServiceEvent       397] 5 6923 "wamari" "Authentication failure"
    Feb 18 08:23:50 spectre com.deepin.dde.lockFront[601]: 2018-02-18, 08:23:50.026 [Debug  ] [lockmanager.cpp      LockManager::onUnlockFinished       256] Authorization failed!
    ---
    
    Feb 17 22:01:33 spectre startdde[596]: switcher.go:124: Failed to load config: Failed to found config: /etc/deepin-wm-switcher/config.json
    Feb 17 22:01:33 spectre com.deepin.daemon.Display[596]: config_version.go:47: Failed to delete config: remove /home/wamari/.config/deepin/startdde/display.json: no such file or directory
    Feb 17 22:01:33 spectre dbus-daemon[311]: [system] Activating service name='com.deepin.daemon.helper.Backlight' requested by ':1.34' (uid=1000 pid=596 comm="/usr/bin/startdde ") (using servicehelper)
    Feb 17 22:01:33 spectre startdde[596]: switcher.go:145: Failed to set sogou skin: open /home/wamari/.config/sogou-qimpanel/main.conf: no such file or directory
    Feb 17 22:01:33 spectre startdde[596]: startmanager.go:89: open /usr/lib/UIAppSched.hooks/launched: no such file or directory
    Feb 17 22:01:34 spectre startdde[596]: session_procese.go:73: /usr/lib/deepin-daemon/dde-session-initializer StartDuration: 194.428779ms
    Feb 17 22:01:34 spectre com.deepin.daemon.Accounts[311]: <warning> subrecorder.go:169: SubRecorder.loadStatusFromFile failed open /home/wamari/.config/deepin/dde-daemon/apps/launched-4ab4e72f436b88e0c50532b65baa0c15.csv: no such file or directory
    Feb 17 22:01:34 spectre daemon/apps[653]: subrecorder.go:169: SubRecorder.loadStatusFromFile failed open /home/wamari/.config/deepin/dde-daemon/apps/launched-4ab4e72f436b88e0c50532b65baa0c15.csv: no such file or directory
    Feb 17 22:01:34 spectre dbus-daemon[601]: [session uid=1000 pid=601] Activating via systemd: service name='org.gtk.vfs.UDisks2VolumeMonitor' unit='gvfs-udisks2-volume-monitor.service' requested by ':1.19' (uid=1000 pid=686
    

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in Latests updates broke deepin settings panel, login and power screen:

    @keegan nice to see you around here

    Thanks! I wish I could make it back here more often, but I’m actually going to be moving soon - which obviously takes a lot of time away from the forum. But hopefully I’ll be around on a more consistent basis afterwards!

    but it looks like there is not a real solution and also no workaround jet

    Yeah. Sadly, no one that I know of has reported any sort of solution yet; however, since we now know this issue is brought about by the new QT version, I would suspect that perhaps downgrading that would at least improve things for now 🙂 . I suggested it on the other thread over at the Reborn OS forum, but no one has yet reported whether that fixes anything or not. So try at your own risk!

    Thank you!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

  • @Keegan ah you are right! i will try this…
    and take your time!

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Thank you @joekamprad 🙂 .

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

  • downgrading to the packages from 15.2.2018 works…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

deepin58 updates54 broke21 latests1 Posts 34Views 2005
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.