• vivaldi browser: worse a try?


    just installed vivaldi, but fontconfig error lol (i3wm)

  • Vivaldi on Antergos official packages is lacking some of the latest security fixes…
    That’s why I use chromium. But you can download the latest vivaldi from their site…

  • @manuel said in vivaldi browser: worse a try?:

    valdi on Antergos official packages is lacking some of the latest security fixes

    but vivaldi is not the same as chromium browser, it uses the chromium sources, to compare security you will need to take a look to what vivaldi itself is implementig on that case, and how the backend is used and changed by vivaldi development.

  • latest aviable stable version is 1.15.1147.42 and so what we are using at antergos repository also…

  • @joekamprad
    No, latest available stable version from Vivaldi is 1.15.1147.47.
    And yes, in Antergos we have 1.15.1147.42, and AFAIK it is missing the latest security updates.

  • @manuel uhh i do not get notified on this update then… and also AUR package is already updated…

    thanks for linking me to this…i will do a pull request…

  • @ringo32 said in vivaldi browser: worse a try?:

    but fontconfig error

    this is caused by chromium is not following the standards on this and using its own fontconfig… they should not do that…

  • @joekamprad

    uhh i do not get notified on this update then…

    I have noticed that Antergos version of vivaldi is not always up to date, so I wrote a script that checks the version from vivaldi.com and compares that to pacman version.

  • @joekamprad could :) saw some on chromium old issue on buglist indeed but vivaldo dont want to start at all :)

    but i am really a google user at the end :) i will try further but before did worked, will see for later

  • @manuel said in vivaldi browser: worse a try?:

    @joekamprad

    uhh i do not get notified on this update then…

    I have noticed that Antergos version of vivaldi is not always up to date, so I wrote a script that checks the version from vivaldi.com and compares that to pacman version.

    I do try to make it more up to date, but it is a complicated package, and needs some friggeling on every update…

  • @joekamprad
    If it is of any help to you, I could share my script.
    It also downloads the rpm package from vivaldi.com, extracts files from the package, and copies the files to /opt/ext_vivaldi, and modifies permissions of file vivaldi-sandbox.

  • look here:
    https://github.com/Antergos/antergos-packages/blob/master/antergos/vivaldi/PKGBUILD

    This is a hybrid package including vivaldi / vivaldi-ffmpeg-codecs / vivaldi-widevine in one package…

  • @joekamprad
    Fortunately I don’t have to maintain that! ;)
    It does so many things that it sure is challenging to maintain.
    My only advice is: divide and conquer. :)

  • Builds here without issue:
    0_1529348269507_Bildschirmfoto vom 2018-06-18 20-56-58.png

browser35 vivaldi20 Posts 37Views 1827
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.