• Touchpad not working


    The touchpad of my laptop doesn’t work, Its a yepo (Chinese brand). With windows 10 worked, I believe it also worked in one or two distros that I tried before installing Antergos.

    I am not sure where the problem is, xinput detects it.

    xinput --list
    ⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
    ⎜   ↳ SYNA3602:00 0911:5288 Touchpad          	id=9	[slave  pointer  (2)]
    ⎜   ↳  USB OPTICAL MOUSE                      	id=13	[slave  pointer  (2)]
    ⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
        ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
        ↳ Video Bus                               	id=6	[slave  keyboard (3)]
        ↳ Power Button                            	id=7	[slave  keyboard (3)]
        ↳ USB2.0 UVC PC Camera: USB2.0 UV         	id=8	[slave  keyboard (3)]
        ↳ Intel HID events                        	id=10	[slave  keyboard (3)]
        ↳ Intel HID 5 button array                	id=11	[slave  keyboard (3)]
        ↳ AT Translated Set 2 keyboard            	id=12	[slave  keyboard (3)]

    When I run libinput debug-events I get this:

    libinput  debug-events
    libinput error: event15 - libinput error: SYNA3602:00 0911:5288 Touchpad: libinput error: kernel bug: clickpad advertising right button

    I hoped that the issue would be fixed in 4.15, but remains the same as 4.14
    Where can I look next? Currently I am using an external USB mouse but its not a solution.

  • HI.
    I’m not 100 percent certain but I’m only offering this as an idea rather than a solution. But what about downgrading libinput?
    Question: was there an update prior to this not functioning or was it not working since day one? That is, was it not working immediatly post fresh install?
    I’m wondering also that maybe the problem is tap to click not enabled by default for some uncanny reason.
    Another thing that comes to mind is what about uninstalling xf86-input-synaptics. Can always re-install afterwards if this idea/solution doesn’t work.
    These are just a list of ideas that you could think about before proceeding.

  • I have to double post here because there’s some issue here with the forums in editing. Regardless, I may have found something but I’m none too sure if it’ll work. I’ll provide the link:
    link text

  • Any idea is welcome :)
    It never worked not even moving, actually I tried to fix it once I finish the installation and it went so bad, that I had to reinstall the OS again (the keyboard and the external mouse stop working ).

    Regarding xf86-input-synaptics its not installed, I only have xf86-input-libinput
    These were my configs, but things went south and I had to comment them.

    #Section "InputClass"
     #       Identifier "libinput touchpad catchall"
      #      MatchIsTouchpad "on"
    #       Tapping "on"
     #       MatchDevicePath "/dev/input/event*"
      #      Driver "libinput"

    Since the mouse doesn’t even move I think its not the same as the redit. Do you other ideas rather than installing synapitcs?


  • Hi @Kxp
    Those were basically all the ideas that i was able to exhaust.
    All I can suggest is what’s on the Wiki at
    There is also this:

    I suggest just only reading this link here


    It only mentions about upgrading to testing to get various libs and firmwars updated to get the touchpad working but I’d do that as the last thing. But then again, you never know.

    I got that idea/link from this thread:

    Something that comes up is to do with your 50-synaptcis.conf in /etc/X11/xorg.conf.d/

    But I’m none too sure where to look with regards to that particular file.
    That file is to do with your touchpad.

  • May be some steps can fix this issue. Follow the steps below
    Open settings> Devices> Mouse and touchpad> Additional mouse settings> Mouse properties> Click the touchpad from list
    Now see if the touchpad is disable, click on enable.
    If it doesn’t work you uninstall the touchpad driver and install it again.
    Source: [https://windowsclassroom.com/touchpad-not-working-windows-10/](link url)

touchpad55 Posts 6Views 2165
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.