• failed start light display manager


    Hallo,

    folgendes ist passiert. 4 Updates standen an. Dabei kam es zu fontproto Fehler. Habe daraufhin die libxfont und libxfont2 deinstalliert. Danach liefen auch die Updates wieder. Libxfont wurde dabei auch wieder installiert. Danach habe ich den Rechner neu gestartet und seitdem streikt er. Ich sehe nur folgendes Bild.

    http://fs5.directupload.net/images/180211/bs29bh3n.jpg
    _
    [URL=http://www.directupload.net/file/d/4995/bs29bh3n_jpg.htm][IMG]http://fs5.directupload.net/images/180211/temp/bs29bh3n.jpg[/IMG][/URL]

    Jetzt weiß ich nicht weiter. Mit putty komme ich drauf. pacman und yaourt Update zeigen keine Fehler. Was tun?

  • @archibald die Bilder kann ich alle nicht sehen…

    libxfont2 hatte nicht deinstalliert werden sollen:

    https://forum.antergos.com/topic/9148/update-to-xorgproto-breaks-dependencies/3

    Noch bei KDE oder inzwischen gewechselt?

    ich würde als erstes versuchen einen anderen DM zu versuchen:

    sudo pacman -S sddm sddm-kcm

    sudo systemctl -f enable sddm

    nach dem reboot startet der neue loginmamager (für KDE)

  • Hallo,

    ich probiere nochmal einen anderen Hoster.
    http://www.bilderload.com/daten/antergosbootfehler20180211CJA3D.jpg
    _
    Bild Text

    Oh, du kennst noch meine Vorgeschichte? Wahnsinn.
    Das ist jetzt Gnome. Also Antergos Standard Installation.

    Ohne Deinstallation von libxfont2 kam wieder der fontsproto Fehler.

    Soll ich immer noch die beiden Befehle eintippen?

  • Für GNOME besser GDM dann:

    sudo pacman -S gdm

    sudo systemctl -f enable gdm

    und rebooten

    wie es aussieht haben einige probleme mit lightdm und Gnome im moment…

  • Hallo,

    vielen Dank. Bootet wieder. 👍
    Was ich nicht finde ist wo ich das Auto Login einschalte. Wenn ich in “Einstellungen” auf Benutzer gehe, dann friert das Fenster ein. Ich sehe nur das Infofenster Gnome 3.26.2.

  • Automatischer Login
    Um die automatische Anmeldung bei GDM zu aktivieren, fügen Sie Folgendes zur /etc/gdm/custom.conf hinzu (ersetzen Sie username durch ihren eigenen):

    /etc/gdm/custom.conf

    # Enable automatic login for user
    [daemon]
    AutomaticLogin=username
    AutomaticLoginEnable=True
    
  • Hallo,

    auto login funktioniert wieder. Danke.

    Ich musste jedoch dabei feststellen, dass noch irgendwas mit dem “display: 0” nicht stimmt. Normalerweise erledige ich solche Dinge immer mit “sudo gedit …” aus der Konsole heraus. Das funktionierte jedoch nicht. Fehlermeldung “cannot open display: 0”
    Rufe ich gedit ohne sudo auf öffnet es sich ganz normal.
    Ich habe dann sudo nano verwendet um etc/gdm/custom.conf anzupassen.

    Für meinen Remotezugriff verwende ich nomachine. Bisher ohne Probleme. Beim Login will der nun immer einen neue Desktopanzeige starten. Lehne ich das ab, passiert nicht. Lasse ich das zu, lande ich auf einem komplett schwarzen Desktop. Ich möchte jedoch auf dem normalen Gnome Desktop landen damit ich alles bedienen kann. Mir scheint das etwas mit dem Standard Desktop 0 noch nicht stimmt. Kann das sein? Gibt es dafür eine Lösung?

    mit pacman -Syu … ist alles i.O.
    mit yaourt -Syua … wird angezeigt das “cwiid” verwaist ist

  • dann bist du in einer Gnome Wayland session… beim Anmelden GNOME X-org session wählen und es geht wieder…
    wenn du unter wayland graphische apps als root nutzen wills vorher das im terminal ausführen:
    xhost +SI:localuser:root

  • Hallo,

    besten Dank. Geändert auf Gnome X-org, neu booten, klappt. 👍
    Danke für den Wayland Tipp. Ist vorgemerkt.

manager74 display50 light19 Posts 9Views 808
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.