• Loud click/pop when sound activated (pulseaudio?)


    Whenever sound is activated, or a sound related program such as pavucontrol is opened, I get a loud pop/click from my speakers (even opening a browser tab can cause it). If I stop and start the sound this wont happen again within a short period of time, but if I wait 30+ seconds to reactivate sound it happens again. Done a fair bit of Google searching but can’t seem to find a fix.

    client.conf

    # This file is part of PulseAudio.
    #
    # PulseAudio is free software; you can redistribute it and/or modify
    # it under the terms of the GNU Lesser General Public License as published by
    # the Free Software Foundation; either version 2 of the License, or
    # (at your option) any later version.
    #
    # PulseAudio is distributed in the hope that it will be useful, but
    # WITHOUT ANY WARRANTY; without even the implied warranty of
    # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
    # General Public License for more details.
    #
    # You should have received a copy of the GNU Lesser General Public License
    # along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
    
    ## Configuration file for PulseAudio clients. See pulse-client.conf(5) for
    ## more information. Default values are commented out.  Use either ; or # for
    ## commenting.
    
    ; default-sink =
    ; default-source =
    ; default-server =
    ; default-dbus-server =
    
    ;autospawn = yes
    ; daemon-binary = /usr/bin/pulseaudio
    ; extra-arguments = --log-target=syslog
    
    ; cookie-file =
    
    ; enable-shm = yes
    ; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
    
    ; auto-connect-localhost = no
    ; auto-connect-display = no
    

    daemon.conf

    # This file is part of PulseAudio.
    #
    # PulseAudio is free software; you can redistribute it and/or modify
    # it under the terms of the GNU Lesser General Public License as published by
    # the Free Software Foundation; either version 2 of the License, or
    # (at your option) any later version.
    #
    # PulseAudio is distributed in the hope that it will be useful, but
    # WITHOUT ANY WARRANTY; without even the implied warranty of
    # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
    # General Public License for more details.
    #
    # You should have received a copy of the GNU Lesser General Public License
    # along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
    
    ## Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for
    ## more information. Default values are commented out.  Use either ; or # for
    ## commenting.
    
    ; daemonize = no
    ; fail = yes
    ; allow-module-loading = yes
    ; allow-exit = yes
    ; use-pid-file = yes
    ; system-instance = no
    ; local-server-type = user
    ; enable-shm = yes
    ; enable-memfd = yes
    ; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
    ; lock-memory = no
    ; cpu-limit = no
    
    ; high-priority = yes
    ; nice-level = -11
    
    ; realtime-scheduling = yes
    ; realtime-priority = 5
    
    ; exit-idle-time = 20
    ; scache-idle-time = 20
    
    ; dl-search-path = (depends on architecture)
    
    ; load-default-script-file = yes
    ; default-script-file = /etc/pulse/default.pa
    
    ; log-target = auto
    ; log-level = notice
    ; log-meta = no
    ; log-time = no
    ; log-backtrace = 0
    
    ; resample-method = speex-float-1
    ; avoid-resampling = false
    ; enable-remixing = yes
    ; remixing-use-all-sink-channels = yes
    ; enable-lfe-remixing = no
    ; lfe-crossover-freq = 0
    
    flat-volumes = no
    ; flat-volumes = yes
    
    ; rlimit-fsize = -1
    ; rlimit-data = -1
    ; rlimit-stack = -1
    ; rlimit-core = -1
    ; rlimit-as = -1
    ; rlimit-rss = -1
    ; rlimit-nproc = -1
    ; rlimit-nofile = 256
    ; rlimit-memlock = -1
    ; rlimit-locks = -1
    ; rlimit-sigpending = -1
    ; rlimit-msgqueue = -1
    ; rlimit-nice = 31
    ; rlimit-rtprio = 9
    ; rlimit-rttime = 200000
    
    ; default-sample-format = s16le
    ; default-sample-rate = 44100
    ; alternate-sample-rate = 48000
    ; default-sample-channels = 2
    ; default-channel-map = front-left,front-right
    
    ; default-fragments = 4
    ; default-fragment-size-msec = 25
    
    ; enable-deferred-volume = yes
    ; deferred-volume-safety-margin-usec = 8000
    ; deferred-volume-extra-delay-usec = 0
    

    Thanks.

  • I’ve found a fix but don’t know how to make it permanent (it reverts to previous state after reboot).

    /sys/module/snd_hda_intel/parameters/power_save

    contains the value “10”, if I set this to “0” all clicks and pops are gone.

    There is probably a way to write a shell script to stop it reverting to “10” every time I reboot but not sure how to do this.

  • Also, would this be regarded as a bug?

  • The “popping sound” relates to additional power savings, and that change was/is kinda poorly communicated.

    To make it go away …

    sudo touch /etc/modprobe.d/snd_hda_intel.conf
    sudo nano /etc/modprobe.d/snd_hda_intel.conf

    Insert into the file…

    options snd_hda_intel power_save=0

    CTRL+O, CTRL+X

    Done, the change is now permanent across reboots.

  • Thank you Phunk-N-Further. Your solution worked.

    I still get the popping sound at boot and shutdown but this isn’t really a problem (I think it’s always happened, also when I used to run Ubuntu).

  • I still get the popping sound at boot and shutdown

    Yes, the pop/crackle you hear on boot (kernel module initializes) and shutdown (kernel module unloads) are normal and have always been there; even in Windows and every other Linux distro out there.

    If your rig is connected to an power amp with serious speakers, like mine is, simply switch to another input on the amp during boot/reboot/shutdown to avoid the unpleasant “surprise”. In case you have active speakers connected turn them off, and in case of headphones, where it’s not that bad, just take 'em off.

sound50 loud2 activated1 clickpop1 Posts 7Views 318
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.