• During boot font too tiny for 4k monitor


    During the boot process the text that scrolls on the screen is extremely tiny and illegible. AS well, the login screen, while readable is not using the HiDPI setting which is applied once I am logged in.

    Using Cinnamon with LightDM.

  • to get correct screensize on bootup you will need to edit /etc/default/grub and rebuild grub.cfg:

    ...
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE=4096×2160
    ...
    

    4096×2160 is only an example you need to take a resolution supported by your graphics!!!

    then rebuild grub.cfg:

    sudo grub-mkconfig -o /boot/grub/grub.cfg

    For login manager i do not think that the standard greeter is easy to configure for this, asit should be done by the theme automaticly… https://github.com/Antergos/web-greeter/issues/48

    So i would try to change grub resolution first, and may theme for greeter take the right resolution then!

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • For the display manager, I got this to work: https://www.mattfischer.com/blog/archives/154

    In short, it boils down to creating a script, e.g. /usr/bin/lightdmxrandr

    sudo nano /usr/bin/lightdmxrandr
    

    Enter a couple of xrandr commands:

    	#!/bin/sh
    	xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
    	xrandr --addmode eDP1 1920x1080_60.00
    	xrandr --output eDP1 --mode 1920x1080_60.00
    

    The code depends on your specific needs. You can retrieve the options for the first xrandr command from the command

    cvt 1920 1080
    

    The command ‘xrandr’ will tell you the names of your displays (mine was eDP1).
    Once you created the script, make it executable:

    sudo chmod +x /usr/bin/lightdmxrandr
    

    Open the configuration file of lightDM, the default Antergos display manager:

    sudo nano  /etc/lightdm/lightdm.conf 
    

    and add the line

    display-setup-script=/usr/bin/lightdmxrandr
    

    under the section “[Seat:*]” in /etc/lightdm/lightdm.conf
    On next boot, lightDM should display in a lower resolution.

boot248 during31 font27 tiny1 Posts 3Views 309
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.