• update to xorgproto breaks dependencies


    sudo pacman -Syu wants to upgrade to xorgproto. After answering y to the questions the update fails to finish with:

    error: failed to prepare transaction (could not satisfy dependencies)
    :: libxfont: removing fontsproto breaks dependency ‘fontsproto>=2.1.3’

  • Uninstall libxfont package (not libxfont2, you want to keep that one) then you will be able to update normally.

    Cheers!

  • @lots-0-logs said in update to xorgproto breaks dependencies:

    Uninstall libxfont package (not libxfont2, you want to keep that one) then you will be able to update normally.

    Cheers!

    same problem here and your solution working and fix the problem!

    SOLVED

  • My case is similar. But when I try to uninstall libxfront on the terminal, it tells me that it will also uninstall 32 packages. I don’t know if it’s good to say yes:

    [macantergos2 ~]$ yaourt -Rsnc libxfont
    [sudo] password for salva: 
    checking dependencies...
    :: avahi optionally requires pygtk: avahi-bookmarks
    :: google-earth optionally requires nvidia-utils: For the NVIDIA driver
    :: imagemagick optionally requires libwmf: for WMF support
    :: vulkan-icd-loader optionally requires vulkan-driver: packaged vulkan driver
    xscreensaver optionally requires gdm: for login manager support
    
    Packages (32) djvulibre-3.5.27-3 evince-3.24.1-1 gdm-3.24.2-1 gegl02-0.2.0-7
                  gimp-2.8.22-1 gnome-documents-3.24.3-1 gsfonts-20170720-1
                  lcms-1.19-5 libgepub-0.5.2-1 libspectre-0.2.8-1.
                  libwmf-0.2.8.4-14 libxfont2-2.0.0.1-1 libxnvctrl-384.59-1.59-1.
                  nvidia-384.59-5 nvidia-settings-384.59-1 nvidia-utils-384.59-1
                  pygobject2-devel-2.28.6-13 pygobject2-devel-2.6-13 pygtk-2.24.0-7
                  python2-cairo-1.13.3-1 python2-gobject2-2.28.6-13 t1lib-5.1.2-6.2-6.
                  ttf-bitstream-vera-1.10-11 ttf-liberation-2.00.1-7
                  xf86-input-libinput-0.25.1-1 xorg-bdftopcf-1.0.0.5-1
                  xorg-font-utils-7.6-4 xorg-fonts-alias-1.0.3-1.
                  xorg-fonts-misc-1.0.3-5 xorg-server-1.19.3-3.
                  xorg-server-common-1.19.3-3 xorg-server-xwayland-1.19.3-3
                  libxfont-1.5.2-1
    
    Total size removed: 250.49 MiB
    
    Do you want to remove these packages? [S/n]
    

    I’m a novice with Antergos and I don’t know if it’s wise to uninstall libxfont

  • @salvaestudio
    That sounds tricky!
    Package libxfont does not exist anymore, and I believe package libxfont2 replaces that old one.
    Maybe you could first install libxfont2 and if that succeeds, try to update your system.

  • I have already been able to delete ONLY libxfont with:

    pacman -Rdd libxfont
    

    but when I update it still gives me problems:

    [macantergos2 ~]$ sudo pacman -Syyyuu
    Synchronizing the packet databases...
     180.0 KiB 2000K/s 00:00[##################################] 100% %.
     Core 127.8 KiB 1659K/s 00:00[################################## 100%] 100
     extra 1595,1 KiB 7,21M/s 00:00[################################, 100%] 100
     community 4,1 MiB 10,8M/s 00:00[################################] 100%
     multilib 166.7 KiB 12.5M/s 00:00[################################# 100%] 100
    Start complete system update...
    Replace compositeproto with extra/xorgproto?  [S/n] 
    Replace damageproto with extra/xorgproto?  [S/n] 
    Replace dmxproto with extra/xorgproto?  [S/n] 
    Replace dri2proto with extra/xorgproto?  [S/n] 
    Replace dri3proto with extra/xorgproto?  [S/n] 
    Replace fixesproto with extra/xorgproto?  [S/n] 
    Replace fontsproto with extra/xorgproto?  [S/n] 
    Replace gcc-libs-multilib with core/gcc-libs?  [S/n] 
    Replace gcc-multilib with core/gcc?  [S/n] 
    Replace glproto with extra/xorgproto?  [S/n] 
    Replace gtk3-print-backends with extra/gtk3?  [S/n] 
    Replace inputproto with extra/xorgproto?  [S/n] 
    Replace kbproto with extra/xorgproto?  [S/n] 
    Replace mime-types with extra/mailcap?  [S/n] 
    Replace presentproto with extra/xorgproto?  [S/n] 
    Replace randrproto with extra/xorgproto?  [S/n] 
    Replace recordproto with extra/xorgproto?  [S/n] 
    Replace renderproto with extra/xorgproto?  [S/n] 
    Replace resourceproto with extra/xorgproto?  [S/n] 
    Replace scrnsaverproto with extra/xorgproto?  [S/n] 
    Replace video product with extra/xorgproto?  [S/n] 
    Replace xextproto with extra/xorgproto?  [S/n] 
    Replace xf86dgaproto with extra/xorgproto?  [S/n] 
    Replace xf86driproto with extra/xorgproto?  [S/n] 
    Replace xf86miscproto with extra/xorgproto?  [S/n] 
    Replace xf86videproto with extra/xorgproto?  [S/n] 
    Replace xineramaproto with extra/xorgproto?  [S/n] 
    Replace xproto with extra/xorgproto?  [S/n] 
    resolving dependencies...
    searching for conflicts between packages...
    
    Warning: Dependency loop detected:
    Warning: table will be installed before your libglvnd dependency
    Warning: Dependency loop detected:
    Warning: nvidia-utils will be installed before your libglvnd dependency
    Warning: Dependency loop detected:
    Warning: xorg-server will be installed before your libglvnd dependency
    Warning: Dependency loop detected:
    Warning: harfbuzz will be installed before your freetype2 dependency.
    Warning: Dependency loop detected:
    Warning: usbmuxd will be installed before your libimobiledevice dependency
    Warning: Dependency loop detected:
    Warning: phon-qt5-gstreamer will be installed prior to its dependency phon-qt5
    Warning: Dependency loop detected:
    Warning: lib32-harfbuzz will be installed before its dependency lib32-freetype2
    Warning: Dependency loop detected:
    Warning: lib32-table will be installed before your dependency lib32-libglvnd
    
    Packages (721)0ad-a22-4 adwaita-icon-theme-3.26.1-1 alembic-1.7.3-2
                   alsa-lib-1.1.5-1 alsa-plugins-1.1.5-1 alsa-utils-1.1.5-2
                   
                   0.3-2 apm-1.19.0-1.7-3 apm-1.19.0-1.1
                   appstream-glib-0.7.4-1 archlinux-appstream-data-20180129-1
                   archlinux-keyring-20180108-1 argon2-20171227-3
                   at-spi2-atk-2.26.1-1 at-spi2-core-2.26.2-1 atk-2.26.1-1
                   atom-1.23.3-2 attica-qt5-5.42.0-1 avahi-0.7-4 babl-0.1.38-1.
                   baobab-3.26.1-1 bash-4.4.018-1 bash-completion-2.7-2.
                   bind-tools-9.12.0-1 binutils-2.29.1-2 blas-3.8.0-1.0
                   blender-17:2.79-9 blosc-1.13.7-1 bluez-5.48-1
                   bluez-libs-5.48-1 boost-1.66.0-1 boost-libs-1.66.0-1
                   bra-3.12.2-2 brltty-5.5-3 btrfs-progs-4.15-1
                   bubblewrap-0.2.0-1 ca-certificates-mozilla-3.35-1.35-1
                   cabextract-1.6-2 cairo-1.15.10-1 cantarell-fonts-1:0.100-1.
                   cblas-3.8.0-1 cdrtools-3.02a09-1 celt-0.11.3-3.
                   cheese-3.26.0-1 chromaprint-1.4.3-1 cmake-3.10.2-2
                   colord-1.4.1+6+gf08c25d-1 compositeproto-0.4.2-3[removing]
                   coreutils-8.29-1 cryptsetup-2.0.1-1 cups-2.2.6-4.
                   cups-filters-1.20.0-1 curl-7.58.0-1
                   damageproto-1.2.1-3[removing] dbus-1.12.4-1 dbus-glib-0.110-1
                   dconf-0.26.1-1 device-mapper-2.02.177-1
                   dleyna-connector-dbus-0.3.0-1 dleyna-core-0.6.0-1
                   dleyna-renderer-0.6.0-1 dleyna-server-0.6.0-1.6.0-1.
                   dmxproto-2.3.1-3[removing] docbook-xsl-1.79.2-4
                   dri2proto-2.8-2[removing] dri3proto-1.0-1[removing]
                   dropbox-43.4.50-1 e2fsprogs-1.43.8-1 electron-1.7.12-1.12-1eog-3.26.2-1  etl-1.2.1-1
                                  evince-3.26.0+14+g2a499547-1  evolution-3.26.5-1
                                  evolution-data-server-3.26.5-1  exempi-2.4.3+2+g65a8492-1
                                  exiv2-0.26-2  expat-2.2.5-1  extra-cmake-modules-5.42.0-1
                                  f2fs-tools-1.10.0-1  faac-1.29.7.7-1  faad2-2.8.5-1
                                  fakeroot-1.22-1  ffmpeg-1:3.4.1-4  ffmpeg2.8-2.8.13-5
                                  fftw-3.3.7-1  file-5.32-1  file-roller-3.26.2-1
                                  filesystem-2017.10-2  firefox-58.0.2-1
                                  fixesproto-5.0+9+g4292ec1-1 [quitando]
                                  fontconfig-2.12.6+5+g665584a-1  fontsproto-2.1.3-2 [quitando]
                                  foomatic-db-engine-4:4.0.12-7  freeglut-3.0.0-2  freetype2-2.9-2
                                  fribidi-0.19.7-2  ftgl-2.1.3rc5-10  fuse-common-3.2.1-1
                                  fuse2-2.9.7-4  gawk-4.2.0-3  gcab-1.0+2+gc0947f6-1  gcc-7.3.0-1
                                  gcc-libs-7.3.0-1  gcc-libs-multilib-7.1.1-4 [quitando]
                                  gcc-multilib-7.1.1-4 [quitando]  gcr-3.20.0+55+g470bf4c-1
                                  gdbm-1.14.1-1  gdk-pixbuf2-2.36.11-1  gdm-3.26.2.1-1
                                  gegl-0.3.26-1  geocode-glib-3.25.4.1-1  geoip-1.6.11-1
                                  geoip-database-20180206-1  ghostscript-9.22-7  git-2.16.1-1
                                  gjs-1:1.50.4-1  glib-networking-2.54.1-1
                                  glib2-2.54.3+2+g94b38beff-1  glibc-2.26-11  glibmm-2.54.1-1
                                  glproto-1.4.17-1 [quitando]  gmime-2.6.23+4+g91dcee38-2
                                  gmime3-3.2.0-1  gnome-backgrounds-3.26.2-1
                                  gnome-bluetooth-3.26.0+1+g3875844-1  gnome-calculator-3.26.0-2
                                  gnome-calendar-3.26.3-1
                                  gnome-color-manager-3.26.0+16+g3b2109b-1
                                  gnome-contacts-3.26+3+g643f622-1
                                  gnome-control-center-3.26.2+14+g5ac6a0da6-1
                                  gnome-desktop-1:3.26.2-2  gnome-disk-utility-3.26.2-1
                                  gnome-documents-3.26.1-1  gnome-font-viewer-3.26.0-1
                                  gnome-keyring-1:3.27.2-1  gnome-logs-3.26.3-1
                                  gnome-maps-3.26.2-1  gnome-menus-3.13.3+29+g7f0844e-1
                                  gnome-music-3.26.1-1  gnome-online-accounts-3.26.2-1
                                  gnome-online-miners-3.26.0-1  gnome-photos-3.26.3-1
                                  gnome-screenshot-3.26.0-1  gnome-session-3.26.1-2
                                  gnome-settings-daemon-3.26.2-1
                                  gnome-shell-3.26.2+14+g64c857e3f-1
                                  gnome-shell-extension-dash-to-dock-1:61-1
                                  gnome-shell-extensions-3.26.2+9+g683b5ee-1
                                  gnome-system-monitor-3.26.0+1+g97b9578d-1
                                  gnome-terminal-3.26.2-1
                                  gnome-themes-standard-3.22.3+16+gc092fc89-1
                                  gnome-tweak-tool-3.26.4-1  gnome-weather-3.26.0-1  gnupg-2.2.4-2
                                  gnutls-3.5.17-1  gobject-introspection-runtime-1.54.1-1
                                  gom-0.3.3-1  gpgme-1.10.0-1  gpm-1.20.7-8  grilo-0.3.4-1
                                  grilo-plugins-0.3.5-1  grub-2:2.02-4
                                  gsettings-desktop-schemas-3.24.1+3+ge869987-1
                                  gsfonts-20170829-1  gsm-1.0.17-1  gspell-1.7.1-1
                                  gst-libav-1.12.4-1  gst-plugins-bad-1.12.4-3
                                  gst-plugins-base-1.12.4-1  gst-plugins-base-libs-1.12.4-1
                                  gst-plugins-good-1.12.4-2  gst-plugins-ugly-1.12.4-3
                                  gstreamer-1.12.4-1  gstreamer-vaapi-1.12.4-1
                                  gtk-engine-murrine-0.98.2-3
                                  gtk-update-icon-cache-3.22.26+161+g60750b3ffd-1  gtk2-2.24.32-1
                                  gtk3-3.22.26+161+g60750b3ffd-1
                                  gtk3-print-backends-3.22.18-2 [quitando]
                                  gtkmm3-3.22.2+2+g3002ed86-1  gtksourceview3-3.24.6-1
                                  gtkspell-2.0.16-7  gtkspell3-3.0.9-3  guile-2.2.3-1
                                  gupnp-1.0.2+4+g47b1010-1  gvfs-1.34.2-1  gvfs-mtp-1.34.2-1
                                  gzip-1.9-1  harfbuzz-1.7.5-1  harfbuzz-icu-1.7.5-1
                                  haveged-1.9.1-4  hdf5-1.10.1-2  hicolor-icon-theme-0.17-1
                                  hplip-3.17.11-1  hspell-1.4-1  hunspell-1.6.2-1
                                  hunspell-es-1:2.3-1  hwids-20171003-1  iana-etc-20180131-1
                                  icoutils-0.32.2-1  icu-60.2-1  imagemagick-7.0.7.22-1
                                  inkscape-0.92.2-8  inputproto-2.3.2-1 [quitando]
                                  intel-tbb-2018_20171205-1  iproute2-4.15.0-1  iptables-1.6.1-2
                                  iso-codes-3.76-1  iw-4.14-1  jansson-2.10-3  jasper-2.0.14-1
                                  jbig2dec-0.14-1  jemalloc-1:5.0.1-4
                                  jetbrains-toolbox-2:1.6.2914-1  js38-38.8.0-4  js52-52.5.2-1
                                  json-c-0.13-1  json-glib-1.4.2-1  jsoncpp-1.8.4-2
                                  karchive-5.42.0-1  kauth-5.42.0-1  kbookmarks-5.42.0-1
                                  kbproto-1.0.7-1 [quitando]  kcodecs-5.42.0-1
                                  kcompletion-5.42.0-1  kconfig-5.42.0-1  kconfigwidgets-5.42.0-1
                                  kcoreaddons-5.42.0-1  kcrash-5.42.0-1  kdbusaddons-5.42.0-1
                                  kdoctools-5.42.0-1  kfilemetadata-5.42.0-1
                                  kglobalaccel-5.42.0-1  kguiaddons-5.42.0-1  ki18n-5.42.0-1
                                  kiconthemes-5.42.0-1  kinit-5.42.0-1  kio-5.42.0-1
                                  kitemmodels-5.42.0-1  kitemviews-5.42.0-1  kjobwidgets-5.42.0-1
                                  knewstuff-5.42.0-1  knotifications-5.42.0-2
                                  knotifyconfig-5.42.0-1  krb5-1.16-1  krita-3.3.3-1
                                  kservice-5.42.0-1  ktextwidgets-5.42.0-1  kwallet-5.42.0-1
                                  kwidgetsaddons-5.42.1-1  kwindowsystem-5.42.0-1
                                  kxmlgui-5.42.0-1  lame-3.100-1  lapack-3.8.0-1  lcms-1.19-7
                                  lcms2-2.9-1  ldb-1.3.0-1  ldns-1.7.0-4  lib32-acl-2.2.52-3
                                  lib32-alsa-lib-1.1.5-1  lib32-alsa-plugins-1.1.5-1
                                  lib32-atk-2.26.1-1  lib32-attr-2.4.47-2  lib32-cairo-1.15.8-1
                                  lib32-curl-7.58.0-1  lib32-dbus-1.12.4-1
                                  lib32-e2fsprogs-1.43.7-1  lib32-fontconfig-2.12.6+5+g665584a-1
                                  lib32-freetype2-2.8.1-1  lib32-gcc-libs-7.3.0-1
                                  lib32-glib2-2.54.2-2  lib32-glibc-2.26-11
                                  lib32-harfbuzz-1.7.1-1  lib32-icu-60.1-1  lib32-krb5-1.16-1
                                  lib32-libcurl-compat-7.58.0-1  lib32-libcurl-gnutls-7.58.0-1
                                  lib32-libdrm-2.4.89-1  lib32-libelf-0.170-1
                                  lib32-libgcrypt-1.8.1-1  lib32-libglvnd-1.0.0-1
                                  lib32-libgudev-232-1  lib32-libjpeg-turbo-1.5.3-1
                                  lib32-libjpeg6-turbo-1.5.3-1  lib32-libnl-3.4.0-1
                                  lib32-libnm-glib-1.10.2-1  lib32-libogg-1.3.3-2
                                  lib32-libpciaccess-0.14-1  lib32-libpng-1.6.34-1
                                  lib32-libpsl-0.19.1-1  lib32-libpulse-11.1-1
                                  lib32-libsm-1.2.2-2  lib32-libtasn1-4.13-1  lib32-libxau-1.0.8-2
                                  lib32-libxcursor-1.1.15-1  lib32-libxinerama-1.1.3-2
                                  lib32-libxml2-2.9.4+16+g07418011-2  lib32-llvm-libs-5.0.1-1
                                  lib32-mesa-17.3.3-1  lib32-mpg123-1.25.7-1
                                  lib32-ncurses-6.0+20170902-1  lib32-nss-3.34-1
                                  lib32-openal-1.18.2-1  lib32-openssl-1:1.1.0.g-1
                                  lib32-openssl-1.0-1.0.2.n-1  lib32-p11-kit-0.23.9-1
                                  lib32-sdl-1.2.15-7  lib32-sdl2-2.0.7-1  lib32-sdl2_mixer-2.0.2-1
                                  lib32-sqlite-3.21.0-1  lib32-systemd-237.0-1  lib32-tdb-1.3.15-1
                                  lib32-util-linux-2.31-1  lib32-wayland-1.14.0-1  libabw-0.1.2-1
                                  libaec-1.0.2-1  libao-1.2.2-2  libass-0.14.0-1
                                  libassuan-2.5.1-1  libatomic_ops-7.6.2-1  libblockdev-2.14-2
                                  libbs2b-3.1.0-6  libbsd-0.8.7-1  libbytesize-1.0-2
                                  libcdio-2.0.0-1  libcdio-paranoia-10.2+0.94+2-2  libcdr-0.1.4-2
                                  libchamplain-0.12.16-1  libcmis-0.5.1-8
                                  libcryptui-3.12.2+24+gd5e5bc5-1  libcups-2.2.6-4
                                  libcurl-compat-7.58.0-1  libcurl-gnutls-7.58.0-1
                                  libdmapsharing-2.9.39-1  libdrm-2.4.89-1  libdvdcss-1.4.1-1
                                  libe-book-0.1.3-1  libebml-1.3.5-1  libebur128-1.2.4-1
                                  libelf-0.170-1  libepubgen-0.1.0-1  libetonyek-0.1.7-1
                                  libevdev-1.5.8-1  libexttextcat-3.4.5-1
                                  libfbclient-2.5.7.27050-4  libfreehand-0.1.2-1  libftdi-1.4-1
                                  libgadu-1.12.2-5  libgcrypt-1.8.2-1  libgdata-0.17.9-1
                                  libgdm-3.26.2.1-1  libgexiv2-0.10.7-1  libglvnd-1.0.0-1
                                  libgnomekbd-3.26.0-1  libgsf-1.14.42-1
                                  libgtop-2.38.0+1+g487e584a-2  libgudev-232-1
                                  libgweather-3.26.1-1  libibus-1.5.17-1  libical-3.0.1-1
                                  libice-1.0.9-2  libidn2-2.0.4-2
                                  libimobiledevice-1.2.0+66+g5a85432-1  libinput-1.9.4-1
                                  libixion-0.13.0-1  libjpeg-turbo-1.5.3-1  libjpeg6-turbo-1.5.3-1
                                  libksba-1.3.5-1  libldap-2.4.45-4  liblouis-3.4.0-1
                                  libmagick-7.0.7.22-1  libmagick6-6.9.9.34-1  libmatroska-1.4.8-1
                                  libmbim-1.16.0-1  libmediaart-1.9.4+1+ga704d0b-1
                                  libmm-glib-1.6.12-1  libmms-0.6.4-2  libmpc-1.1.0-1
                                  libmspub-0.1.3-1  libmtp-1.1.14-1  libmwaw-0.3.13-1
                                  libnautilus-extension-3.26.2-3  libnftnl-1.0.9-1
                                  libnghttp2-1.29.0-1  libnl-3.4.0-1
                                  libnm-1.10.3dev+38+g78ef57197-1
                                  libnm-glib-1.10.3dev+38+g78ef57197-1  libogg-1.3.3-2
                                  liborcus-0.13.2-1  libosinfo-1.1.0-1  libpagemaker-0.0.4-1
                                  libpciaccess-0.14-1  libpeas-1.22.0-1  libphonenumber-8.8.9-1
                                  libpipeline-1.5.0-1  libplist-2.0.0+11+gec9ba8b-1
                                  libpng-1.6.34-2  libpng12-1.2.57-3  libproxy-0.4.15-6
                                  libpsl-0.19.1-1  libpst-0.6.71-2  libpulse-11.1-1
                                  libpurple-2.12.0-4  libpwquality-1.4.0-1  libqmi-1.20.0-1
                                  libqxp-0.0.1-1  libraqm-0.4.0-1  libraw-0.18.7-1
                                  libreoffice-fresh-6.0.1-1  libreoffice-fresh-es-6.0.1-1
                                  librsvg-2:2.42.2-1  libsasl-2.1.26-12  libseccomp-2.3.2-2
                                  libsodium-1.0.16-1  libsoup-2.60.3-1  libspeechd-0.8.8-1
                                  libspnav-0.2.3-2  libsrtp-1:2.1.0-1  libstaroffice-0.0.5-1
                                  libsystemd-237.0-2  libtasn1-4.13-1  libteam-1.27-1
                                  libthai-0.1.27-1  libtiff-4.0.9-1  libtirpc-1.0.2-3
                                  libtommath-1.0.1-1  libtool-2.4.6+40+g6ca5e224-4
                                  libunistring-0.9.8-1  libupnp-1.6.24-2
                                  libusbmuxd-1.0.10+13+gc724e70-1  libutil-linux-2.31.1-1
                                  libuv-1.19.1-1  libva-2.0.0-2  libvdpau-1.1.1+3+ga21bf7a-1
                                  libvisio-0.1.6-2  libvpx-1.7.0-1  libwacom-0.27-1
                                  libwbclient-4.7.4-1  libwebp-0.6.1-1  libwpd-0.10.2-1
                                  libwpg-0.3.2-1  libwps-0.4.8-1  libx264-2:152.20171224-1
                                  libx264-all-2:152.20171224-1  libxau-1.0.8-3
                                  libxcursor-1.1.15-1  libxdamage-1.1.4-3  libxfixes-5.0.3-2
                                  libxfont2-2.0.3-1  libxkbcommon-0.8.0-1
                                  libxkbcommon-x11-0.8.0-1  libxklavier-5.4-2
                                  libxml2-2.9.7+4+g72182550-2  libxnvctrl-390.25-1
                                  libxrandr-1.5.1-2  libxres-1.2.0-1  libxslt-1.1.32+3+g32c88216-1
                                  libyaml-0.1.7-1  libytnef-1.9.2-2  libzip-1.3.2-1
                                  libzmf-0.0.2-2  licenses-20171006-1  lightdm-1:1.24.0-3
                                  linux-4.15.2-2  linux-api-headers-4.14.8-1
                                  linux-firmware-20180119.2a713be-1  live-media-2018.01.29-1
                                  llvm-libs-5.0.1-2  logrotate-3.13.0-1  lua52-bitop-1.0.2-8
                                  lua52-luajson-1.3.4-1  lvm2-2.02.177-1  lz4-1:1.8.1.2-1
                                  mailcap-2.1.48+14+g5811758-1  man-db-2.8.0-1  man-pages-4.15-1
                                  mesa-17.3.3-2  mesa-demos-8.3.0-4  mesa-vdpau-17.3.3-2
                                  mime-types-9-1 [quitando]  miniupnpc-2.0.20170509-2
                                  mkinitcpio-24-2  mkinitcpio-busybox-1.27.2-1  mlt-6.6.0-3
                                  modemmanager-1.6.12-1  mpfr-4.0.0-1  mpg123-1.25.8-1
                                  mutter-3.26.2+43+g77dd1bf63-1  nano-2.9.3-1  nautilus-3.26.2-3
                                  ncurses-6.0+20170902-3  net-snmp-5.7.3-7  netcdf-4.5.0-1
                                  netctl-1.15-1  nettle-3.4-1
                                  network-manager-applet-1.8.11dev+7+ga52ccb2f-1
                                  networkmanager-1.10.3dev+38+g78ef57197-1
                                  networkmanager-openvpn-1.8.1dev+10+ge4d8cda-2
                                  networkmanager-pptp-1.2.4-3  nfs-utils-2.3.1-1  nfsidmap-2.3.1-1
                                  nilfs-utils-2.2.7-1
                                  nm-connection-editor-1.8.11dev+7+ga52ccb2f-1  nodejs-9.5.0-1
                                  npm-5.6.0-1  nspr-4.18-1  nss-3.35-1
                                  numix-icon-theme-1:0.r1974-1  nvidia-390.25-9
                                  nvidia-settings-390.25-1  nvidia-utils-390.25-2
                                  ocl-icd-2.2.12-1  openal-1.18.2-1  opencl-nvidia-390.25-2
                                  opencollada-1:1.6.59-1  openimageio-1.7.17-2  openjpeg2-2.3.0-1
                                  openshadinglanguage-1.7.6-3  openssh-7.6p1-2  openssl-1.1.0.g-1
                                  openssl-1.0-1.0.2.n-1  openvdb-4.0.2-4  openvpn-2.4.4-1
                                  orc-0.4.28-1  orca-3.26.0-1  os-prober-1.76-1
                                  osinfo-db-20170813-1  p11-kit-0.23.9-1  p7zip-16.02-4
                                  pacman-mirrorlist-20180203-1  pamac-6.2.4-1  pambase-20171006-1
                                  pango-1.40.14-1  parted-3.2-6  pciutils-3.5.6-1  pcre2-10.30-1
                                  perl-5.26.1-2  perl-clone-0.39-4  perl-dbi-1.640-1
                                  perl-encode-locale-1.05-3  perl-error-0.17025-2
                                  perl-file-listing-6.04-4  perl-html-parser-3.72-5
                                  perl-html-tagset-3.20-6  perl-http-cookies-6.04-2
                                  perl-http-daemon-6.01-5  perl-http-date-6.02-4
                                  perl-http-message-6.14-1  perl-http-negotiate-6.01-4
                                  perl-io-html-1.001-3  perl-libwww-6.26-3
                                  perl-lwp-mediatypes-6.02-4  perl-net-http-6.17-1
                                  perl-try-tiny-0.30-1  perl-uri-1.73-1
                                  perl-www-robotrules-6.02-4  perl-xml-libxml-2.0132-1
                                  perl-xml-parser-2.44-6  phonon-qt5-4.9.1-5
                                  phonon-qt5-gstreamer-4.9.0-4  pidgin-2.12.0-4  pinentry-1.1.0-1
                                  playonlinux-4.2.12-1  polkit-0.113+34+g29ba7af-1
                                  polkit-qt5-0.112.0+git20180107-1  poppler-0.61.1-1
                                  poppler-glib-0.61.1-1  poppler-qt5-0.61.1-1  potrace-1.15-1
                                  ppp-2.4.7-4  pptpclient-1.10.0-1  presentproto-1.1-1 [quitando]
                                  procps-ng-3.3.12-2  protobuf-3.5.1.1-1  protobuf-c-1.3.0-2
                                  pulseaudio-11.1-1  pulseaudio-bluetooth-11.1-1
                                  pygobject-devel-3.26.1-1  pygobject2-devel-2.28.7-1
                                  pygtk-2.24.0-8  python-3.6.4-2  python-atspi-2.26.0-1
                                  python-cairo-1.15.4-1  python-dbus-1.2.6-1
                                  python-dbus-common-1.2.6-1  python-gobject-3.26.1-1
                                  python-numpy-1.14.0-1  python-psutil-5.4.3-1
                                  python-pycurl-7.43.0.1-1  python-pydbus-0.6.0-1
                                  python-setuptools-1:38.5.1-1  python-simplejson-3.13.2-1
                                  python-sip-4.19.7-1  python-six-1.11.0-1  python2-2.7.14-2
                                  python2-cairo-1.15.4-1  python2-gobject-3.26.1-1
                                  python2-gobject2-2.28.7-1  python2-setuptools-1:38.5.1-1
                                  python2-six-1.11.0-1  qpdf-7.1.1-1  qt4-4.8.7-23
                                  qt5-base-5.10.0-4  qt5-declarative-5.10.0-1
                                  qt5-location-5.10.0-1  qt5-multimedia-5.10.0-1
                                  qt5-quickcontrols-5.10.0-1  qt5-script-5.10.0-1
                                  qt5-sensors-5.10.0-1  qt5-speech-5.10.0-1
                                  qt5-styleplugins-5.0.0.20170311-4  qt5-svg-5.10.0-1
                                  qt5-webchannel-5.10.0-1  qt5-webkit-5.212.0alpha2-11
                                  qt5-x11extras-5.10.0-1  qt5-xmlpatterns-5.10.0-1  qt5ct-0.34-2
                                  randrproto-1.5.0-1 [quitando]  raptor-2.0.15-7
                                  rasqal-1:0.9.33-2  re2-20180201-1  recode-3.7-1
                                  recordproto-1.14.2-2 [quitando]  reiserfsprogs-3.6.27-1
                                  renderproto-0.11.1-3 [quitando]
                                  resourceproto-1.2.0-3 [quitando]  rhash-1.3.5-2  rpcbind-0.2.4-4
                                  rtkit-0.11+8+ge0a51fe-1  run-parts-4.8.3-1  s-nail-14.9.6-1
                                  scrnsaverproto-1.2.2-2 [quitando]  sdl2-2.0.7-1
                                  sdl2_mixer-2.0.2-2  seahorse-3.20.0+105+gb31e32fe-1
                                  semver-5.5.0-1  shadow-4.5-4  shared-mime-info-1.9-1
                                  sip-4.19.7-1  smbclient-4.7.4-1  snappy-1.1.7-1  solid-5.42.0-1
                                  sonnet-5.42.0-1  soundtouch-2.0.0-1  speech-dispatcher-0.8.8-1
                                  sqlite-3.22.0-1  steam-1.0.0.54-3
                                  steam-native-runtime-1.0.0.54-5  sudo-1.8.22-1  systemd-237.0-2
                                  systemd-sysvcompat-237.0-2  talloc-2.1.11-1  tar-1.30-1
                                  tcl-8.6.8-1  tdb-1.3.15-1  tevent-1:0.9.34-1  texinfo-6.5-1
                                  thin-provisioning-tools-0.7.5-1  totem-3.26.0+1+g4e309671-1
                                  totem-plparser-3.26.0-1  tracker-2.0.3-1  tracker-miners-2.0.4-1
                                  transmission-gtk-2.93-1  tslib-1.15-1  twolame-0.3.13-8
                                  tzdata-2018c-1  udisks2-2.7.5-1  upower-0.99.7-1
                                  usb_modeswitch-2.5.2-1  usbmuxd-1.1.0+28+g46bdf3e-1
                                  usbutils-009-1  util-linux-2.31.1-1  v4l-utils-1.14.1-1
                                  vcdimager-2.0.1-1  videoproto-2.3.3-1 [quitando]  vlc-2.2.8-4
                                  volume_key-0.3.9-5  vte-common-0.50.2+6+g7fe155b9-1
                                  vte3-0.50.2+6+g7fe155b9-1  vulkan-icd-loader-1.0.68.0-1
                                  wayland-protocols-1.12-1  webkit2gtk-2.18.6-1  wget-1.19.4-1
                                  whois-5.2.20-1  wildmidi-0.4.2-1  wine-3.1-1
                                  wireless-regdb-2017.03.07-1  wpa_actiond-1.4-3
                                  wpa_supplicant-1:2.6-11  wxgtk-common-3.0.3.1-11
                                  wxgtk2-3.0.3.1-11  wxgtk3-3.0.3.1-11  wxpython-3.0.2.0-7
                                  x265-2.6-1  xdg-user-dirs-0.16-1  xextproto-7.3.0-1 [quitando]
                                  xf86-input-libinput-0.26.0-1
                                  xf86-video-fbdev-0.4.4+12+ge0bce0d-1
                                  xf86dgaproto-2.1-3 [quitando]  xf86driproto-2.1.1-3 [quitando]
                                  xf86miscproto-0.9.3-1 [quitando]
                                  xf86vidmodeproto-2.3.1-3 [quitando]  xfsprogs-4.14.0-1
                                  xineramaproto-1.2.1-3 [quitando]  xkeyboard-config-2.23.1-2
                                  xmlsec-1.2.25-1  xorg-bdftopcf-1.1-1
                                  xorg-server-1.19.6+13+gd0d1a694f-1
                                  xorg-server-common-1.19.6+13+gd0d1a694f-1
                                  xorg-server-devel-1.19.6+13+gd0d1a694f-1
                                  xorg-server-xwayland-1.19.6+13+gd0d1a694f-1  xorgproto-2018.1-1
                                  xproto-7.0.31-1 [quitando]  xscreensaver-5.38-1  xterm-331-1
                                  zenity-3.26.0-1  zeromq-4.2.2-2  zstd-1.3.3-1
    Total download size: 0.06 MiB
    Total installation size: 6678.41 MiB
    Net size after upgrade: 492.49 MiB
    
    Continue with installation? [S/n] s
    :: Getting the packages...
     jansson-2.10-3-x86_64 37.1 KiB 1427K/s 00:00[################################# 100%] 100
     lib32-attr-2.4.47-2... 8,4 KiB 0,00B/s 00:00[###############################] 100%.
     lib32-acl-2.2.52-3-... 16,2 KiB 0,00B/s 00:00[##############################] 100%.
    (693/693) by checking deposit keys[#################################] 100%.
    B (124/693) verifying the integrity of the packages...[###----------------------------------] (693/693) verifying the integrity of the packages...[##################################### 100%] ^B (124/693) verifying the integrity of the packages...[#############################################.
    error: jansson: signature from "Eli Schwartz <[email protected]" is marginal trust
    :: The /var/cache/pacman/pkg/jansson-2.10-3-x86_64. pkg. tar. xz file is corrupted (invalid or damaged package (PGP signature)).
    You want to take him out? [S/n] s
    error: lib32-attr: signature from "Eli Schwartz <[email protected]" is marginal trust
    :: The /var/cache/pacman/pkg/lib32-attr-2.4.47-2-x86_64. pacman/pkg/lib32-xtr-2.47-2-x86_64. pkg. tar. xz file is corrupted (invalid or damaged package (PGP signature)).
    You want to take him out? [S/n] s
    error: lib32-acl: signature from "Eli Schwartz <[email protected]" is marginal trust
    :: The /var/cache/pacman/pkg/lib32-acl-2.2.52-3-x86_64. pacman/pkg/lib32-acl-2.2.52-3-x86_64. pkg. tar. xz file is corrupted (invalid or damaged package (PGP signature)).
    You want to take him out? [S/n] s
    error: operation could not be performed (valid or damaged package)
    Errors occurred, so packages were not updated
    

    Keep in mind that I’m trying to update a Mac with Antergos that I haven’t been able to use for 5 months.

  • @salvaestudio
    Neglecting updates for 5 months can cause various and sometimes difficult problems.

    Now you have too old key signatures, so you may try to update them first. I don’t remember the syntax for that now, but it should be easy to search from e.g. Antergos forums or Arch wiki.

    And if it doesn’t help, it may be time for reinstallation (but backup first…).

  • try to install archlinux-keyring

    sudo pacman -S archlinux-keyring
    
  • Thanks. System upgraded normally after removing libxfont

  • I had the same problem, but fixed it by uninstalling libxfont. Although uninstalling a package, refreshing the database… do fix these problems, I have to wonder how these problems occur in the first place, and why so often? I had it happen for the second time this year, and many times last year.

    Is someone not paying attention when making or packaging updates or what? Why can’t pacman deal with it automatically…

    I get updates nearly every day, sometimes twice a day, and always install them. I rarely install or remove any software, so I am sure it’s not my error.

    A long time ago when I was trying to figure out whether to switch from Windows to Linux, word was that Linux handles dependencies like a charm compared to Windows, and I found out that it was in fact much better, but now it is nowhere near as good as it was years ago when I made the switch (it has regressed). What’s up with that? If anything I would expect it to get better over time.

    Not trying to be a pest.

  • @zoidmo
    Maybe there are (at least) three quite general and understandable reasons:

    1. it’s Arch
    2. it’s user-to-user
    3. it’s a rolling release

    Let’s explain a bit.

    1. Most packages in Antergos are from the upstream produced, Arch. So they decide about most of the packages. Antergos team is much smaller, and this is a sensible way to organize things for having a distribution.
      Note that Antergos provides some great additions, like a graphical installer, and some additional packages by default, that are not provided by default in upstream.
    2. Open source is very much about user involvement. Software is made by users and they give it free of charge to other users. You also have the opportunity to be involved, i.e. give others access to stuff you’ve made. And as you may imagine, it is by no means easy to be compatible with every other open source software/environment in the world. You know, there are tens of thousands of packages available directly in Antergos package manager.
    3. Antergos (like Arch) is a rolling release. So it is all the time up to date, meaning packages from their producers become very quickly to be available in Antergos. Sometimes some new packages have problems that the developer did not see, and that may cause problems for Antergos (or any rolling release) users if the distribution maintainer too does not detect the problem. And as you probably know, it is practically impossible to check all possible flaws in any program, simply because there are so many possibilities/places for errors.
      Thus a rolling release assumes more from a user than a “traditional” non-rolling distribution. A rolling release user is advised to check e.g. Arch website about possible problems before performing an update. That’s the price you have to pay for using a rolling release (unless you are a seasoned linux user and know exactly how to fix any problems that occur).
breaks31 dependencies18 xorgproto1 Posts 11Views 15536
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.