• Wifi-adapter not recognized after update/reboot


    Been running antergos for a little while now without any major problems. That is, until today. After a system update and reboot my wifi suddenly just won’t work anymore. Networkmanager can’t find the pci adapter, neither can ifconfig or iwconfig or any of those.

    The only way I can find it is running lshw or lspci.
    Output of lshw:

    *-pci:2
                 description: PCI bridge
                 product: 82801I (ICH9 Family) PCI Express Port 2
                 vendor: Intel Corporation
                 physical id: 1c.1
                 bus info: [email protected]:00:1c.1
                 version: 03
                 width: 32 bits
                 clock: 33MHz
                 capabilities: pci pciexpress msi pm normal_decode bus_master cap_list
                 configuration: driver=pcieport
                 resources: irq:16 ioport:4000(size=4096) memory:f8000000-f9ffffff ioport:f2000000(size=33554432)
               *-network UNCLAIMED
                    description: Network controller
                    product: BCM4312 802.11b/g LP-PHY
                    vendor: Broadcom Limited
                    physical id: 0
                    bus info: [email protected]:04:00.0
                    version: 01
                    width: 64 bits
                    clock: 33MHz
                    capabilities: pm msi pciexpress bus_master cap_list
                    configuration: latency=0
                    resources: memory:f8000000-f8003fff
    

    lspci:

    04:00.0 Network controller: Broadcom Limited BCM4312 802.11b/g LP-PHY (rev 01)
    

    ‘-network UNCLAIMED’ what exactly does that mean? I have b43-firmware and b43-fwcutter installed, and have tried reinstalling both. I didn’t touch anything relating to wifi or network before rebooting, I only installed some completely unrelated packages from AUS (which I tried uninstalling, didn’t help)

    [[email protected] ~]$ nmcli r 
    WIFI-HW  WIFI     WWAN-HW  WWAN    
    enabled  enabled  enabled  enabled 
    
    

    Any one have any ideas? Tell me which logs to post if I’m missing any.

  • @joekamprad Damn thanks dude, you’re fast. It worked. After installing linux-headers and broadcom-wl-dkms and after a quick reboot I finally got my wifi back again.

  • the magic of dkms… it builds the modules against running kernel …

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in Wifi-adapter not recognized after update/reboot:

    the magic of dkms… it builds the modules against running kernel …

    That was an amazing tip, as I also fixed my Toshiba laptop and it now works with wifi. BUT, hehehe there’s always a but and there are nice but’s and less nicer but’s, but there’s always a but, and who does not like but’s?

    So the “butt” is, it does recognize my wifi, but it catches lot’s of other’s people around me. WDF?

    Yes, I have MAC address thing limit only MAC crap registered off or something, can’t remember what’s the name of that.

  • Found it. It’s the Authentication Method and the WPA encryption that are sooooooo old on the laptop, that it does recognize WPA2, and needs to be TKIP+AES.

    Thanks.

recognized10 updatereboot1 wifi-adapter1 Posts 6Views 168
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.