• Unable to boot after kernel update (4.10 and up including LTS 4.14)


    Hello!
    I have an ASUS X553MA Laptop:

    Intel® Bay Trail-M Quad Core Celeron N2930 Processor
    8GB RAM
    500 GB HDD

    It is one of the hardest laptops I have ever seen to find he right distro to install and get a ¨stable¨ system.
    I have tried several distros (at least 15) and the only one that used to work ¨fine¨ was AntergOS, that until kernel updated from 4.9 to 4.10, had to use the past LTS version (4.9) of the kernel for several months until the LTS updated to LTS 4.14, at that moment my system wouldn’t boot again, so I decided to install another distro, but run into the same problem I had before, no other distribution work as good as AntergOS on my laptop, and no other distro has what fits pretty much all my needs, almost all Arch Linux derivatives have the same problem, they freeze immediately at boot using the live USB, even using the DD method to write the image file, only Gentoo Linux and another ugly distro booted without much issues, but it is a nightmare (speaking of the time it takes to install it).
    Sorry if it sound irrelevant but I LOVE this distro and I would like to find help in order to keep my laptop with a linux distro, otherwise I will have to switch back to windows (which I like but not much).

    So, in desperation, I had an idea, install AntergOS on another laptop I have (ASUS X5531MA), using the hdd on my X553MA and after installation reinstall the HDD back and see what happened, and amazingly, it worked, it even solved a screen tearing problem it had before (at least for now).
    The fear I have is that after a kernel update my system will go to waste again and I won’t be able to boot, I have read that I can install an old version of the kernel using an old live CD, which I have, AntergOS 17.5, but it is a really old kernel, I wouldn’t like to have to keep my laptop using that kernel for years to come.

    So, hopefully, if someone else has the same problem, they might be able to solve it using my ¨amazing" solution and share if this worked for them too and if it works, they could report if after the next kernel update the system still boots and also meanwhile, see if someone cares for solving this annoying bug in the Arch kernel or configuration files, or whatever it is causing this problem with Arch derivatives on a minuscule amount of systems.

    I read that it can be solved turning ACPI off, but they said it is not good for a laptop to do that.

    It seems there’s not much interest in solving this issue as it has been reported by some users already but there’s no correct solution applied to it. I remember seeing this bug reported on Arch, AntergOS, Bugzilla and GitHub, if I remember correctly, several month ago.

    Any suggestions on what to do here?
    If I can provide any log files at the moment I can gladly help with it, I may be updating this if the issue appears again after a kernel update.

    As additional information, some debian distros boot just fine on my laptop using their live CD, but they have some annoying errors after installation. Most of the Linux distros I succesfully installed on my laptop were using kernel 4.13, so this may indicate is an Arch Linux and its derivatives problem.

    THANKS IN ADVANCE!

  • Do you read this already?
    https://wiki.archlinux.org/index.php/ASUS_X553MA

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad 😅 Didn’t think about it, I haven’t tried that, but I will if my laptop has the same problem after the next kernel update and see if that works, as there’s different X553MA and maybe it doesn’t work for all of them, but I will update this post if necessary. Right now my laptop works, with some weird messages when booting and when turning it off, but it works, so I don’t know if this matter would be considered solved. I will be updating regardless of the status.

    THANKS!! 🙃

  • May we can find out if the models have the same Chipsets, then it would be possible a chance .

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad Yeah! maybe we could 😋 , another weird thing is that the UEFI configuration is pretty much the same as the default configuration, I just turned Secure Boot off and that’s it. Before the LTS kernel update I had the same configuration, after the kenel update I kept the same configuration and after my ¨experiment¨ I still have the same configuration, but Antergos may work or not depending on something unknown to me.
    Another detail is that as suggested in the Arch Linux page for X553MA, I didn’t blacklisted the dw_mac modules, even so I get a message when booting about dw_mac but I found out it is a module for the SD slot in the X551MA that is missing, don’t know if that produced the same effect as blacklisting the module and that’s why I am able to get it to boot. Also I still keep the UEFI configuration to use the windows 8 as OS selection.
    I guess I will try to see if blacklisting the dw_mac modules when booting on the live USB works and update the post.

    THANKS AGAIN!

  • @dante_igashu Sounds like lts kernels are good for you, 4.9 will still be supported like two years, and 4.14 too.
    The problem may also be caused by graphics card and drivers.Which drivers are you using?

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel Hello! and thanks for answering! 😃
    Well, right now it is working with the latest 4.15 kernel, but, as I mentioned, just because I installed on another laptop and then reinserted the HDD with the OS already installed, also doubt that it is a graphics card as it uses the intel integrated chip, and about other drivers, well, I don’t know, Everything is working fine, except for the card reader, as it has always been that way.

    @joekamprad
    Well, I tried to boot using the USB live, used ISO and DD, but both have the same problems.
    I added the kernel parameter mentioned in the X553MA Arch Linux article, also switched to Windows 7 OS option and added the kernel parameter again, but nothing, it just freezes. Also tried using the “secure configuration”, “no ACPI” and “No ACPI local” option for the kernel but still freezes, the later one gives me an error message but it freezes after that.

    I guess the simplest and less annoying solution seems to be the one I used and that made the laptop boot, install on another pc or laptop and reinstall my HDD after OS installation 😭 .
    Do you know if there’s any security problems by doing this? or any other “side effects”?
    Right now I have notices several things that work different:

    Good ones:

    1. It boots.
    2. A screen tearing problem is gone (seems it is using wayland, wich couldn’t be used before, but I haven’t made sure it is so).

    Bad ones:

    1. The keyboard works in a weird way for some keys, (I have to press it twice in order to make it work when using composite switch).
    2. It is unable to suspend or hibernate (freezes with black screen), which worked just fine with kernel 4.9 LTS.
    3. I get some messages that seem to be some kind of warning when booting, but it boots “normally”.
    4. I get several errors when powering off, which doesn’t seem to have any negative effects.
  • @joekamprad ALSO:
    The kernel had an update on 2018/02/10 and the laptop still boots.

  • Update:
    It seems the system is working as it should (which doesn’t mean is working correctly), I still don’t know what the “dw_mac MIssing DT data” and the “pwm-lpss invalid resource” refer to, the first one seems to be the SD card reader, but I am not sure as it has never worked on linux, the second one seems to be related with power management, which is probably the cause the live USB cannot boot, but I am not sure, but since that was included in the kernel I haven’t been able to boot with kernel 4.10 or newer version.
    Also when turning it off I get a message similar to this “Failed to wait for protocol: protocol error” like 6 times and then the laptop seems to get powered off normally, but I notices my desktop does the same thing, so it must be a kernel issue.
    I still have no idea why my method worked, but it works, at the moment.

boot236 kernel105 unable54 4.104 Posts 9Views 699
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.