• Can't get Sonarr and NZBGet working together

    I’m trying to switch away from Mint to Antergos for my Plex server but for the life of me, I can’t get Sonarr and NZBGet to work together.

    I have the following accounts on my system:
    roadhazard, plex, nzbget and sonarr

    All belong to the ‘wheel’ group and I’m pretty sure I assigned the wheel group to my “tvshows” folder (will double check tonight). What happens is, Sonarr will tell NZBGet to download a file. NZBGet downloads it to the tvshows folder but sonarr can’t rename/import it due to permission errors.

    In a bit of frustration, I even tried adding all these accounts to the sudoers file (and restarted afterwards) but STILL had problems with permissions. Permissions on the folder are:

    drwxrwxrwx 4 roadhazard users 109 Feb 3 17:56 .
    drwxr-xr-x 18 root root 241 Feb 1 18:18 …
    drwxr-xr-x 3 sonarr sonarr 22 Feb 3 17:56 ‘Super Awesome TV Show’
    drwxr-xr-x 2 nzbget nzbget 50 Feb 3 17:55 ‘Super.Awesome.TV Show.S01E13.blahblah’

    How do I use umask to permanently adjust this folder so that existing files, AND NEWLY CREATED FILES/FOLDERS are open to the world? So that ANY user can do whatever they want to any file in there? Do I create my folder, go into it and just type: umask 000 ?

    Or, is there a stupid-proof, step-by-step, ultra friendly newbie guide to setting up Sonarr and NZBGet to run under my account?

    I’ve seen a LOT of posts talking about how difficult it is getting NZBGet working under Arch. Maybe I’ll do what others suggested… switch to SabNZB and dump Sonarr for Medusa or something else.

    In Mint, NZBGet and Sonarr run under my account and I don’ t have any of these problems. I use Antergos on my gaming PC and would really like to switch to Antergos on my Plex server butman is this frustrating! (Don’t worry… not going back to Windows… ever. :)

  • i use sabnzb and sonarr work great on antergos. never had any luck with nzbget.

  • @megaman said in Can't get Sonarr and NZBGet working together:

    i use sabnzb and sonarr work great on antergos. never had any luck with nzbget.

    Solved my problems. I think everything centered around NZBGet being the main problem!? Just in case somebody else (far into the future) has the same issue, what I did to fix things was:

    Don’t mess with any Sonarr settings. Leave it running under the ‘sonarr’ user account. Make sure to add sonarr to the groups ‘users’ AND ‘wheel’!


    1. Log into the web console and in the security section/DaemonUsername field, change it to your account (or whatever account you want it to run under, don’t leave it running under nzbget…unless you like banging your head into the wall in frustration like I did and waste your time chasing down permission issues.)

    2. Set UMask to 0000

    3. Stop NZBGet (if it’s running!) and edit /lib/systemd/system/nzbget.service. Change user and group to your account and the group that you’re in.

    4. Make sure all accounts are added to each others’ groups. (add your account to wheel, plex, nzbget, sonarr)… nzbget to users, plex, sonarr, wheel, etc., etc.

    5. Restart the PC (I tried re-enabling the service and manually starting it but that didn’t work. I had to reboot my PC at this point.)

    Right now, sonarr has NZBGet grab the files, sonarr can rename and import them and plex can see things just fine. Everything is finally working together in perfect harmony!

    Side question…I’m painfully aware of how much Linux LOVES file permissions… as I switch over to Antergos from Mint, will I need to do anything special to my movies/tv folders? In Windows, when you hook up a new data drive, you sometimes have to take ownership of the folders/files. Will it be the same with switching distros? Will I have to go into the folders (once the mdadm RAID 6 array is assembled) and go into the properties of these folders and do anything?

together3 sonarr2 nzbget2 Posts 3Views 654
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.