• KDE Plasma Desktop broken


    qdbus org.kde.KWin /KWin supportInformation

    KWin Support Information:
    The following information should be used when requesting support on e.g. http://forum.kde.org.
    It provides information about the currently running instance, which options are used,
    what OpenGL driver and which effects are running.
    Please post the information provided underneath this introductory text to a paste bin service
    like http://paste.kde.org instead of pasting into support threads.
    
    ==========================
    
    Version
    =======
    KWin version: 5.12.0
    Qt Version: 5.10.0
    Qt compile version: 5.10.0
    XCB compile version: 1.12
    
    Operation Mode: X11 only
    
    Build Options
    =============
    KWIN_BUILD_DECORATIONS: yes
    KWIN_BUILD_TABBOX: yes
    KWIN_BUILD_ACTIVITIES: yes
    HAVE_INPUT: yes
    HAVE_DRM: yes
    HAVE_GBM: yes
    HAVE_X11_XCB: yes
    HAVE_EPOXY_GLX: yes
    HAVE_WAYLAND_EGL: yes
    
    X11
    ===
    Vendor: The X.Org Foundation
    Vendor Release: 11906000
    Protocol Version/Revision: 11/0
    SHAPE: yes; Version: 0x11
    RANDR: yes; Version: 0x14
    DAMAGE: yes; Version: 0x11
    Composite: yes; Version: 0x4
    RENDER: yes; Version: 0xb
    XFIXES: yes; Version: 0x50
    SYNC: yes; Version: 0x31
    GLX: yes; Version: 0x0
    
    Decoration
    ==========
    Plugin: org.kde.breeze
    Theme: 
    Blur: 0
    onAllDesktopsAvailable: false
    alphaChannelSupported: false
    closeOnDoubleClickOnMenu: false
    decorationButtonsLeft: 0, 2
    decorationButtonsRight: 6, 3, 4, 5
    borderSize: 3
    gridUnit: 10
    font: Noto Sans,10,-1,0,50,0,0,0,0,0,Regular
    smallSpacing: 2
    largeSpacing: 10
    
    Platform
    ==========
    Name: KWin::X11StandalonePlatform
    
    Options
    =======
    focusPolicy: 0
    nextFocusPrefersMouse: false
    clickRaise: true
    autoRaise: false
    autoRaiseInterval: 0
    delayFocusInterval: 0
    shadeHover: false
    shadeHoverInterval: 250
    separateScreenFocus: false
    placement: 4
    focusPolicyIsReasonable: true
    borderSnapZone: 10
    windowSnapZone: 10
    centerSnapZone: 0
    snapOnlyWhenOverlapping: false
    rollOverDesktops: true
    focusStealingPreventionLevel: 1
    legacyFullscreenSupport: false
    operationTitlebarDblClick: 5000
    operationMaxButtonLeftClick: 5000
    operationMaxButtonMiddleClick: 5015
    operationMaxButtonRightClick: 5014
    commandActiveTitlebar1: 0
    commandActiveTitlebar2: 30
    commandActiveTitlebar3: 2
    commandInactiveTitlebar1: 4
    commandInactiveTitlebar2: 30
    commandInactiveTitlebar3: 2
    commandWindow1: 7
    commandWindow2: 8
    commandWindow3: 8
    commandWindowWheel: 31
    commandAll1: 10
    commandAll2: 3
    commandAll3: 14
    keyCmdAllModKey: 16777251
    showGeometryTip: false
    condensedTitle: false
    electricBorderMaximize: true
    electricBorderTiling: true
    electricBorderCornerRatio: 0.25
    borderlessMaximizedWindows: false
    killPingTimeout: 5000
    hideUtilityWindowsForInactive: true
    inactiveTabsSkipTaskbar: false
    autogroupSimilarWindows: false
    autogroupInForeground: true
    compositingMode: 1
    useCompositing: false
    compositingInitialized: false
    hiddenPreviews: 1
    glSmoothScale: 2
    xrenderSmoothScale: false
    maxFpsInterval: 16666666
    refreshRate: 0
    vBlankTime: 6000000
    glStrictBinding: true
    glStrictBindingFollowsDriver: true
    glCoreProfile: false
    glPreferBufferSwap: 97
    glPlatformInterface: 1
    windowsBlockCompositing: true
    
    Screen Edges
    ============
    desktopSwitching: false
    desktopSwitchingMovingClients: false
    cursorPushBackDistance: 1x1
    timeThreshold: 150
    reActivateThreshold: 350
    actionTopLeft: 0
    actionTop: 0
    actionTopRight: 0
    actionRight: 0
    actionBottomRight: 0
    actionBottom: 0
    actionBottomLeft: 0
    actionLeft: 0
    
    Screens
    =======
    Multi-Head: no
    Active screen follows mouse:  no
    Number of Screens: 2
    
    Screen 0:
    ---------
    Name: VGA-0
    Geometry: 1920,0,1920x1080
    Scale: 1
    Refresh Rate: 60
    
    Screen 1:
    ---------
    Name: DVI-I-1
    Geometry: 0,0,1920x1080
    Scale: 1
    Refresh Rate: 60
    
    
    Compositing
    ===========
    Compositing is not active
    
    
  • I did notice when opening Kate will start the coredump process
    idk if that’s any help or not.

    Edit: Also an update just came in to update
    dbus
    linux
    Nvidia
    libre office
    But wouldn’t update unless libxfont was removed because it breaks fontproto
    I removed and updated, still no change coredump still happend in KDE imidiatly but waits for certain programs in gnome then starts.

  • Downgrading kwin to the oldest version available ( pre wayland!) eliminated the kwin crashes here.
    J.

  • Actually at this point, with opening certain applications in gnome causes the systemcoredump as well I’m not sure anymore that the problem was kdeplasma to start with. However I did downgrade kwin anyway to test it, but no change.

  • Installed xfce desktop.
    While it seems much more stable, kate does not start a systemdcoredump, but wine does, so much more convinced original topic is not the cause but not sure what to do next.

  • i think has to do on wayland i dont know, also i dont know which starts first, xorg or wayland.

  • @Firespray

    • what graphic drivers are installed and how ?
    • do you reinstall system with GNOME / XFCE4 or do you install on the defect KDE system?
  • Gnome just happened to be there when I logged out of plasma when this started.
    Maybe I tried installing it at one time according to pacman logviewer it went in last april around the time I switched completely over to antergos.

    I added xfce yesterday which runs ok, until I need something I always use, and then that’s when everything goes wonky and causes the repeated systemdcoredump

    So as far as video drivers go I have nvidia & nvidia-lts

    Every reboot yesterday system was booting into linux-lts, I turn it on today and it’s back at 4.15.2-2-Arch

  • browser and/or network not letting me edit my post. keeps dropping connection to forums.
    If I knew it was safe to reinstall the system without loosing my current settings setup and files I’d try it, but everything is built on top of whatevers there.

  • if you have /home on a seperate partition, it will be easy, if not you will need to backup first…
    but as you have mixed 3 different DE kde/gnome/xfce i would backup personal files and settings somewhere and do a clean install. Then you can put back settings for programs one by one, and setup DE from scratch/defaults.

  • is there a link that provides all these things like backing up, will wine work when it gets reinstalled if the directories are saved.
    What about things like teamspeak settings.
    How do you put home back after reinstalling?
    If I recall right 3 things were done on install home, files system, and swap.
    Can I put home on a different drive?

    I guess I need to know where to start I was hoping it would just be a matter of removing kde and reinstalling.

    Is removing all the DE’s and putting back in a possability?

  • setting system back to base is only possible on pure Archlinux, as Antergos do some configs…

    every program has different setup files, as i do not use teamspeak and wine i do not know exactly…

    but most local user settings are saved under /home/username/.configs and /home/username/.local or directly under /home/username/

    You can put home where you want it and as i say if you have this on a different partition you can add this back on a reinstall without clear it of (format) only by choosing it as /home under advanced partition

  • Question: What is so different about reinstall if the config files go back in,
    vs just removing all the DE’s and putting back in or uninstall linux & reinstall it?

    Ok, so backup home.
    Use usb installer but don’t format.
    Does it ask in there if you want to remount a home directory or search for an existing one?
    It’s been awhile since install so I’m just covering what might go on.

  • If /home is NOT on a separate partition you will need to backup on your own first!
    There is no option for it inside installer.
    If you reach partition screen you can choose advanced and set them manual.

    So you will be able to create a new /home on its own partition, and then if you need to reinstall again you can choose this one and only mount it as /home and do not format.

    Standard setup do not do this and home is a folder under the system root / on the same partition, so it will be overwritten when installer formatting root filesystem!

  • Ok thankyou for the information.
    Throughout the week I’ll be reinstalling as time allows.
    Backing up /home to my server is rather slow and I’ll probly test on
    a spare hard drive lol
    I’ll report back here as soon as I get realigned.

  • Ok, thanks for all the help.
    It was quite easy actually, but never doing before makes a person nervous lol.

    New install now has /home on separate partition so I don’t have to copy over stuff so much but have just ran into another issue so will post if I can’t solve it.

kde206 plasma46 broken38 Posts 36Views 3122
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.