• KDE Plasma Desktop broken


    Came home from work booted up and desktop gone.
    alt+F2 make background show then disappear, but I can still load programs…
    assuming I can remember what they are called lol

    I couldn’t find place to attach logs, I hope dropbox is ok.
    I hope I have the right logs
    link text

  • Todays updates have caused something bad.

    system core dump is constantly running and not stopping makeing the drive run nonstop!

    In the root temp folder in dolphin, a systemd-private- bunch of numberssystemd-coredump folder is constantly being written over and over…

    logs
    https://www.dropbox.com/s/48h9bx6saloez0a/logs2.tar?dl=0

  • @firespray do you also have linux-lts kernel? or you using lts kernel?

  • as far as I can tell it’s using lts.
    That what I thought it had been booting up with.

    Not sure now after typing this

    pacman -Qi linux
    Name            : linux
    Version         : 4.15.1-2
    Description     : The Linux kernel and modules
    Architecture    : x86_64
    URL             : https://www.kernel.org/
    Licenses        : GPL2
    Groups          : base
    Provides        : None
    Depends On      : coreutils  linux-firmware  kmod  mkinitcpio>=0.7
    Optional Deps   : crda: to set the correct wireless channels of your country [installed]
    Required By     : nvidia
    Optional For    : None
    Conflicts With  : None
    Replaces        : None
    Installed Size  : 111.01 MiB
    Packager        : Jan Alexander Steffens (heftig) <[email protected]>
    Build Date      : Sun 04 Feb 2018 06:10:43 PM EST
    Install Date    : Tue 06 Feb 2018 04:43:21 PM EST
    Install Reason  : Explicitly installed
    Install Script  : Yes
    Validated By    : Signature
    
  • ok now I know I’m using it

    cat /proc/version
    Linux version 4.14.18-1-lts ([email protected]) (gcc version 7.3.0 (GCC)) #1 SMP Thu Feb 8 15:49:23 CET 2018
    

    I must have not been as I didn’t have nvidia-lts in so I did

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    then installed

    nvidia-lts
    

    rebooted and selected linux-lts from menu
    but it still does it.

    Now I did find that if I logout of plasma, I find I have gnome desktop, I don’t recall installing, but it works when loaded, however at some point it does it in gnome as well! However idk what triggers it.

    It will keep me functional enough to check msg’s and whatnot, but I have to get back to plasma as I don’t like desktops that look like a cell phone menu lol

  • @firespray said in KDE Plasma Desktop broken:

    cat /proc/version

    is more like

    uname -a
    

    pacman -Qi linux-lts also installed ?

    just that you can see if its on kernel or systemd, 4.15 is stil young

  • Well to day I bootup and and conky no longer says lts under kernel hhmmm

    uname -a
    Linux Beholder 4.15.1-2-ARCH #1 SMP Sun Feb 4 22:27:45 UTC 2018 x86_64 GNU/Linux

    pacman -Qi linux-lts

    Name            : linux-lts
    Version         : 4.14.18-1
    Description     : The Linux-lts kernel and modules
    Architecture    : x86_64
    URL             : https://www.kernel.org/
    Licenses        : GPL2
    Groups          : None
    Provides        : None
    Depends On      : coreutils  linux-firmware  kmod  mkinitcpio>=0.7
    Optional Deps   : crda: to set the correct wireless channels of your country [installed]
    Required By     : nvidia-lts
    Optional For    : None
    Conflicts With  : None
    Replaces        : None
    Installed Size  : 104.47 MiB
    Packager        : Andreas Radke <[email protected]>
    Build Date      : Thu 08 Feb 2018 09:52:17 AM EST
    Install Date    : Thu 08 Feb 2018 06:14:44 PM EST
    Install Reason  : Explicitly installed
    Install Script  : Yes
    Validated By    : Signature
    

    idk whats happening now lol
    I’ll just wait until you tell me next step.

  • was just curius if you load in advance menu in grub you see the lts, does it there also?

  • I have it in the menu to select but I thought it was supposed to keep that option permenant after doing the grub cfg reboot and select it, but I guess it didn’t.

    But yes I can select it in the advanced menu.

  • does it also the same ?

  • yesterday when it booted using lts it still did it

  • looking for the logs currently also see somehow your videocard is configured badly i gues, Vesa also comein…

    dont think its needed vesa …
    mmm you have a hybrid?

  • can you pastbin /etc/mkinitcpio.conf ?

  • I have nVidia GeForce GT730 4GB

    /etc/mkinitcpio.conf

    # vim:set ft=sh
    # MODULES
    # The following modules are loaded before any boot hooks are
    # run.  Advanced users may wish to specify all system modules
    # in this array.  For instance:
    #     MODULES="piix ide_disk reiserfs"
    MODULES=""
    
    # BINARIES
    # This setting includes any additional binaries a given user may
    # wish into the CPIO image.  This is run last, so it may be used to
    # override the actual binaries included by a given hook
    # BINARIES are dependency parsed, so you may safely ignore libraries
    BINARIES=""
    
    # FILES
    # This setting is similar to BINARIES above, however, files are added
    # as-is and are not parsed in any way.  This is useful for config files.
    FILES=""
    
    # HOOKS
    # This is the most important setting in this file.  The HOOKS control the
    # modules and scripts added to the image, and what happens at boot time.
    # Order is important, and it is recommended that you do not change the
    # order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
    # help on a given hook.
    # 'base' is _required_ unless you know precisely what you are doing.
    # 'udev' is _required_ in order to automatically load modules
    # 'filesystems' is _required_ unless you specify your fs modules in MODULES
    # Examples:
    ##   This setup specifies all modules in the MODULES setting above.
    ##   No raid, lvm2, or encrypted root is needed.
    #    HOOKS="base"
    #
    ##   This setup will autodetect all modules for your system and should
    ##   work as a sane default
    #    HOOKS="base udev autodetect block filesystems"
    #
    ##   This setup will generate a 'full' image which supports most systems.
    ##   No autodetection is done.
    #    HOOKS="base udev block filesystems"
    #
    ##   This setup assembles a pata mdadm array with an encrypted root FS.
    ##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
    #    HOOKS="base udev block mdadm encrypt filesystems"
    #
    ##   This setup loads an lvm2 volume group on a usb device.
    #    HOOKS="base udev block lvm2 filesystems"
    #
    ##   NOTE: If you have /usr on a separate partition, you MUST include the
    #    usr, fsck and shutdown hooks.
    HOOKS="base udev autodetect modconf block keyboard keymap resume filesystems fsck"
    
    # COMPRESSION
    # Use this to compress the initramfs image. By default, gzip compression
    # is used. Use 'cat' to create an uncompressed image.
    #COMPRESSION="gzip"
    #COMPRESSION="bzip2"
    #COMPRESSION="lzma"
    #COMPRESSION="xz"
    #COMPRESSION="lzop"
    #COMPRESSION="lz4"
    
    # COMPRESSION_OPTIONS
    # Additional options for the compressor
    #COMPRESSION_OPTIONS=""
    
    
  • btw I rebooted and picked lts and immediately the coredump starts running

  • you can stil come intoo settings of kde?

  • It trys to start then crashes

  • i know in .config hidden map there is kwinrc config file im looking for some stuf you can set to composition temporarely off or chage the opengl setting but dont find some samples

  • i saw something to log some info from kwin : qdbus org.kde.kwin /KWin supportInformation

  • what i know @Jeannie____ also got plasma but also crash a lot

kde163 plasma37 broken28 Posts 36Views 1620
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.