• SOLVED mount second hard drive


    i just did a fresh install of the openbox version. so far so good.

    but i cant mount my other hard drives?

    says “not authorized to perform this operation”

    i see the drives in pcmanfm

    thanks

  • i just did a fresh install of the openbox version. so far so good.

    but i cant mount my other hard drives?

    says “not authorized to perform this operation”

    i see the drives in pcmanfm

    thanks

  • Did you try to mount them via terminal?
    First, get devices list by:

    sudo fdisk -l
    

    You will get something like:

      
    /dev/sda1 2048 206847 102400 7 HPFS/NTFS/exFAT  
    /dev/sda2 206848 314574847 157184000 7 HPFS/NTFS/exFAT  
    /dev/sda3 \* 314574848 419424255 52424704 83 Linux  
    /dev/sda4 419425020 976769023 278672002 f W95 Ext'd (LBA)  
    /dev/sda5 419425083 798511103 189543010+ 83 Linux  
    /dev/sda6 798513152 955795455 78641152 7 HPFS/NTFS/exFAT  
    /dev/sda7 955797504 976769023 10485760 82 Linux swap / Solaris  
    
    

    Then, according to results, do something like:

    sudo mount /dev/sda6 /mnt/
    

    Where sda6 is your device to mount, and mnt is place, where you want to mount it.

    You can also add new entry to /etc/fstab file, to have those devices mounted on system start.

    If You want to have this feature in your filemanager, I guess you have to install some extension or library. In many not-so-raw DE’s it’s work out-of-the-box.

  • thanks @Alphanumerix

    i was able to temp mount my extra hard drives and access them.

    now i am trying to figure out how to automount on boot or being able to click on them in the file manager to mount them.

    i am using openbox so i imagine there is something i need to add to the autostart file.

  • Hi,

    You can automount them by adding a line for each in /etc/fstab: (replace the highlighted values with your own):> [b:1s9o2oi9]/mount-point[/b:1s9o2oi9] [b:1s9o2oi9]ext4[/b:1s9o2oi9] defaults,relatime,users,noauto,x-systemd.automount 0 0
    If it’s an SSD you should also add “discard” to the options. Let me know if you have any questions

    Best Regards,
    Dustin

  • megaman:
    Have You check this archwiki article? [https://wiki.archlinux.org/index.php/PCManFM][0]">[https://wiki.archlinux.org/index.php/PCManFM][1]
    Take a look at the two last sections. I believe they describe Your problem

    Also, running pcmanfm via terminal may show you some helpful messages where to search for solution.
    BTW: You are using regular PCManM, or PCManFM-QT? : )

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/PCManFM

  • i plugged in a usb drive and it picked it up and let me access it no problem but why such a problem with a internal drive?

    last resort i will just use fstab but they are more storage drives and not needed all the time. i prefer to just be able to mount them when i want.

    could this be a ownership permission issue?

    i tried some of the suggestions on the pcmanfm wiki with no luck.

    i am using just pcmanfm would qt work better with openbox?

    thanks for the help guys

  • @“lots.0.logs”:12ojean8 said:

    Hi,

    You can automount them by adding a line for each in /etc/fstab: (replace the highlighted values with your own):> [b:12ojean8]/mount-point[/b:12ojean8] [b:12ojean8]ext4[/b:12ojean8] defaults,relatime,users,noauto,x-systemd.automount 0 0
    If it’s an SSD you should also add “discard” to the options. Let me know if you have any questions

    Best Regards,
    Dustin

    thanks Dustin

    i went the fstab route and the drives are mounting.

  • You’re welcome

Posts 10Views 3298
Log in to reply