• Openvpn Problem


    After connecting to vpn using openvpn, the original IP address is not restored, even by doing a systemctl restart NetworkManager. Only a reboot fixes it. Any clues please?

    Umuntu Ngumuntu Ngabantu
    a person is a person through other people

  • Any ideas please?

    Umuntu Ngumuntu Ngabantu
    a person is a person through other people

  • Hi. @JonPaul
    Welcome to Antergos! 🙂

    It’s fairly difficult to help in a situation like this when there’s no config file posted.
    What authentication are you using?

    Have you done some preliminary investigation like having a look at the openvpn log files?
    Have you also had a look at ifconfig while your running OPENVPN and afterwards when you want to go back to your IP?
    What’s tap0 say?

    What TLS are you using? So for example, if your using TLS 1.* but your configuration is set up as 1.0, then it might affect your connectivity back to your IP.
    Actually, scratch that. I doubt that it would. It’d only affect your connection to the OPENVPN. Not back.

    Also, I am going to assume that you’ve set up OPENVPN according to the arch wiki at https://wiki.archlinux.org/index.php/OpenVPN#The_client_config_profile

    On the off chance that you haven’t, I’d urge you to do so according to that wiki.
    What were your ip addr show and eth0 when you investigated this?

    Also, have a look at the man pages of openvpn if you haven’t done so already.
    Most especially the SIGNALS section.
    SIGINT, SIGTERM Causes OpenVPN to exit gracefully
    While in the `man

    Letting us know that you’ve done some preliminary investigation with all those informations beforehand would’ve helped out a bit more in the preparatory sense.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Having troubles editing my post, so I’ll have to post here something in addition.

    While in the man pages do / then type in SIGNALS and hit ENTER.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Dear Modisc

    Thank you for the reply. I am using the config file provided by privatetunnel. I don’t want to post all of it because it has my certificates but they suggest using the command line sudo openvpn --config xxx.ovpn
    The first part of the ovpn file is
    setenv USERNAME "[email protected]"
    client
    dev tun
    remote uk-ln-001.privatetunnel.com 1194 udp
    remote uk-ln-001.privatetunnel.com 1194 udp
    remote uk-ln-001.privatetunnel.com 443 tcp
    remote uk-ln-001.privatetunnel.com 1194 udp
    remote uk-ln-001.privatetunnel.com 1194 udp
    remote uk-ln-001.privatetunnel.com 1194 udp
    remote uk-ln-001.privatetunnel.com 1194 udp
    remote uk-ln-001.privatetunnel.com 1194 udp
    remote-cert-tls server
    comp-lzo no
    auth SHA1
    nobind
    verb 3
    sndbuf 0
    rcvbuf 0
    socket-flags TCP_NODELAY

    I am just a regular user so I don’t really understand all of the settings…

    Umuntu Ngumuntu Ngabantu
    a person is a person through other people

  • So I made a script to stop,disable,enable,start NetworkManager. If I run it I can get my old IP address back and connect to sites that won’t allow VPN.

    Umuntu Ngumuntu Ngabantu
    a person is a person through other people

  • Hi @JonPaul 🙂

    So does this script work for you?
    I was suspecting that tun0 was not exiting gracefully and hence one of the reasons why I listed the command above from the man pages of openvpn.

    I would have been curious to know if it worked for you based on the idea that tun0 may not have been exiting gracefully.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hi @Modisc - I checked ifconfig before and after. tun0 does seem to exit OK. I am thinking that the problem might be with the browser rather than openvpn. I use firefox normally but if I open another browser after shutting down the vpn I can access the sites that block vpn…

    Umuntu Ngumuntu Ngabantu
    a person is a person through other people

  • @jonpaul eg chromium…

    Umuntu Ngumuntu Ngabantu
    a person is a person through other people

  • have you considered proxy set up configurations, then?

    any extensions like “uppersafe” that may or may not interfere?
    I’m just listing that one as an example only.

    other than that, I’m kind of stumped.
    Unless there is someone else that is more knowledgeable than I that hope fully could help you out in this, that’s about all I can think of.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hi Modisc
    Thanks for all your help. It seems running the script works OK so I am happy with that. The only site I have a problem with is BBC so it is not too much of a problem I guess!

    Umuntu Ngumuntu Ngabantu
    a person is a person through other people

openvpn7 Posts 11Views 387
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.