I had the same problem with every distro I’ve tried in the last few months. (about 10 different distros) Same problem every time no WiFi. I found this fix “completely by luck” and it worked on my Dell 3521 laptop. Hopefully it works for all of you. just follow my newbie instructions.
(I’m still a newbie too that’s why I’m posting this) Linux can be tricky.

Blocked WI-FI & BlueTooth devices
(system can’t find wireless devices)

Run as root (sudo su)

COMMANDS
(run separate, 1 line at a time)

rfkill unblock all

rfkill unblock wlan

rfkill unblock bluetooth uwb wimax wwan gps fm nfc

then run ip link and you should find your wireless
(device, card, adapter, module) whichever you choose to call it and it will look something like this.
(you have to look for it a lot more info than just this will appear)

wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000
link/ether 1c:3e:84:47:78:87 brd ff:ff:ff:ff:ff:ff

the WiFi adapter and IP address are in BOLD print

after that just set up your wireless connection as usual and it should work fine.
it worked for me and I hope it does for you. simple right?