• KDE battery not present


    On my notebook , a Tuxedo, which is certified linux compatible my KDE shows a strange effect with the battery.
    Often after startup it shows battery absent in the tray icon.
    It does display wether the charger is connected, but NO battery.

    But when i call upower -d all battery is there appearantly working properly in both conditions charging and discharging. Even the icon mane seems to be correct.

    When i log out and immideately log in the battery is ok.

    This strange behaviour does NOT occur under any other desktop like GNOME, Cinnamon or even Deepin.
    Someone who has an idea ?

    (It might be some kind of timing problem when starting)

    [email protected] ~]$ upower -d
    Device: /org/freedesktop/UPower/devices/line_power_AC
      native-path:          AC
      power supply:         yes
      updated:              Sa 03 Feb 2018 14:48:21 CET (26 seconds ago)
      has history:          no
      has statistics:       no
      line-power
        warning-level:       none
        online:              yes
        icon-name:          'ac-adapter-symbolic'
    
    Device: /org/freedesktop/UPower/devices/battery_BAT0
      native-path:          BAT0
      vendor:               Notebook
      model:                BAT
      serial:               0001
      power supply:         yes
      updated:              Sa 03 Feb 2018 14:48:22 CET (25 seconds ago)
      has history:          yes
      has statistics:       yes
      battery
        present:             yes
        rechargeable:        yes
        state:               charging
        warning-level:       none
        energy:              21,0234 Wh
        energy-empty:        0 Wh
        energy-full:         56,2992 Wh
        energy-full-design:  62,16 Wh
        energy-rate:         11,0445 W
        voltage:             11,53 V
        time to full:        3,2 hours
        percentage:          37%
        capacity:            90,5714%
        technology:          lithium-ion
        icon-name:          'battery-good-charging-symbolic'
      History (charge):
        1517665696  37,000  discharging
      History (rate):
        1517665701  11,044  charging
        1517665696  22,644  discharging
    
    Device: /org/freedesktop/UPower/devices/DisplayDevice
      power supply:         yes
      updated:              Sa 03 Feb 2018 14:48:21 CET (26 seconds ago)
      has history:          no
      has statistics:       no
      battery
        present:             yes
        state:               charging
        warning-level:       none
        energy:              21,0234 Wh
        energy-full:         56,2992 Wh
        energy-rate:         11,0445 W
        time to full:        3,2 hours
        percentage:          37%
        icon-name:          'battery-good-charging-symbolic'
    
    Daemon:
      daemon-version:  0.99.7
      on-battery:      no
      lid-is-closed:   no
      lid-is-present:  yes
      critical-action: HybridSleep
    [[email protected] ~]$ 
    
    
  • @paul-necas
    Did you activate the battery icon in the system tray settings?
    I run a Tuxedobook here too with plasma5 and I have the battery icon available.
    J.

  • @jeannie____
    Of Course. A Always have all icons enabled.!0_1517682669453_BattNOK.png 0_1517682680815_BattOK.png
    One pic with and one without detected battery.
    Now tested: This effect appears with or without EFI Boot.

kde159 battery19 absent1 Posts 3Views 334
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.