• Pamac 6.2.3 broken


    Just got the new update today, however, it is broken. I can open the application fine, however, I can’t 1) refresh the package database or 2) install any packages (gets stuck “Checking inter-conflicts”).

    Please fix.

    For now, I have reverted to 6.2.2 (command below if anyone else needs it).

    1. sudo su
    2. sudo pacman -U /var/cache/pacman/pamac-6.2.2-1-x86_64.pkg.tar.xz

    https://github.com/Antergos/antergos-packages/issues/288

  • The pamac version 6.2.3-2 is now available.

  • @terrs That was the one that broke. See my github comment thread. https://github.com/Antergos/antergos-packages/issues/288

  • True. This does not work correctly

  • @evan-washkow said in Pacman 6.2.3 broken:

    Just got the new update today, however, it is broken. I can open the application fine, however, I can’t 1) refresh the package database or 2) install any packages (gets stuck “Checking inter-conflicts”).

    Please fix.

    For now, I have reverted to 6.2.2 (command below if anyone else needs it).

    1. sudo su
    2. sudo pacman -U /var/cache/pacman/pamac-6.2.2-1-x86_64.pkg.tar.xz

    https://github.com/Antergos/antergos-packages/issues/288

    pacman is working (and it’s version 5.0.2-2)
    pamac is not pacman, it uses pacman though. I don’t use the functions you mentioned from pamac, i updated the system earlier today and i’m using version 6.2.2-1 too.

    Antegos team just pack pamac from source, doesn’t develop it, so we’ll need to wait untill pamac developers make a new release and wait for Antergos developers to pack it too.

  • For everyone who has this issue, but doesn’t have a cached version, I’ve uploaded it to my Google Drive, until it is fixed:

    https://drive.google.com/open?id=11TJcbxSRoJd0KnmfMmU_aWMyMmYda78C

  • yaourt pamac
    1 antergos/pamac 6.2.3-2 [installed]
        A GTK3 frontend for libalpm
    2 antergos/pamac-dev v6.2.2.git+692-1
        A GTK3 frontend for libalpm
    

    you can simple install dev version as it is not updated till now:

    sudo pacman -S pamac-dev

    If you do not have the cheched one aviable …

  • You can also downgrade to the previous release:

    sudo pacman -S --needed downgrade
    sudo downgrade pamac
    
  • I too downgrade to 6.2.2-1 because the 3-2 smells like burned oil.

  • Glad it’s not something on my end. After a re-install I started pulling out my hair.

    The downgrade is still not working for me however even after a reboot.

    sudo pacman -S --needed downgrade
    sudo downgrade pamac
    

    Am I supposed to add pamac to IgnorePkg (after the downgrade)?

    EDIT: Nvm downloading the supplied .tar.xz and installing that and banning the 6.2.3-2 version solved the problem. Packages install immediately without any issues.

  • I downgraded to previous version, it worked well.
    I also did NOT add pamac to ignorepkg.

  • Using IgnorePkg is a matter of personal taste.
    If not using it not marking pamac ignored, having other updates may be a bit difficult.
    And if using it marking pamac ignored, both pamac and pacman still warn you about bypassing an ignored update.

    So I chose to use it ignore pamac.

    EDIT: my original text was confusing, hopefully it is now clear! And fortunately the original pamac problem is now fixed so no need to ignore pamac.

  • Its not even letting me downgrade it its still giving me var lock error even i have removed it using rm and also tried rm -rf but it didn’t work.

  • @jatin
    Did you command

    sudo rm /var/lib/pacman/db.lck
    

    ?

  • Yes I did even now i downgraded it but still same condition nothing worked !

  • Still im getting same errors while sudo pacman -Syyu and while downloading something checking inter-conflicts

  • @jatin Try to restart the system and then do the downgrade.

  • it went back to 6.2.2.1 but still its showing same error
    But jokes apart many people would leave antergos because of this many people are not using forums or github and i also cannot wait for the fix so i think i have to switch OS

  • It’s a temporary problem you know that right? Antergos has nothing to do with it, as it’s a problem on paman caused by vala 0.38.6 and it’s being fixed.
    So changing OS, is like having an argue with your wife about tonight’s dinner and she wants fish, you want beef, so you ask for divorce.

  • I understand your frustrations, Pamac is not developed by Antergos, but by an external party. Updates can, sometimes, cause problems due to human error.
    The devs of Pamac have found the cause of the problem and they will release a new update very soon.

pacman111 broken32 6.2.31 Posts 64Views 4394
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.