• I cant modify backlight


    sudo ls /sys/class/backlight
    

    shows

    intel_backlight
    

    xbacklight -inc does nothing.

    I can modify it using xrandr but it “fake” backlight, only color changes.

    I can’t manage to change it manually in the brightness file, even being root and using tee to redirect my input to the file. no rights to do so.

    x86 intel driver is installed.

  • can you provide info about your hardware?

    inxi -Fxxc0

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in I cant modigy backlight:

    inxi -Fxxc0

    Here is the complete output:

    Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends
    System:    Host: archlinux Kernel: 4.14.15-1-ARCH x86_64 bits: 64 gcc: 7.2.1 Desktop: i3 4.14.1 dm: N/A
               Distro: Arch Linux
    Machine:   No /sys/class/dmi; using dmidecode: dmidecode is not installed.
    Battery    Using dmidecode: dmidecode is not installed.
    CPU:       Dual core Intel Core i7-5600U (-MT-MCP-) arch: Broadwell rev.4 cache: 4096 KB
               flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10379
               clock speeds: min/max: 500/3200 MHz 1: 3138 MHz 2: 3184 MHz 3: 3092 MHz 4: 3092 MHz
    Graphics:  Card-1: Intel HD Graphics 5500 bus-ID: 00:02.0 chip-ID: 8086:1616
               Card-2: Advanced Micro Devices [AMD/ATI] Opal PRO [Radeon R7 M260]
               bus-ID: 04:00.0 chip-ID: 1002:6605
               Display Server: N/A drivers: modesetting,ati,radeon (unloaded: vesa) tty size: 113x49
    Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller
               driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
               Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel bus-ID: 00:03.0 chip-ID: 8086:160c
               Sound: Advanced Linux Sound Architecture v: k4.14.15-1-ARCH
    Network:   Card-1: Intel Ethernet Connection (3) I218-LM
               driver: e1000e v: 3.2.6-k port: 6080 bus-ID: 00:19.0 chip-ID: 8086:15a2
               IF: enp0s25 state: down mac: 30:8d:99:c2:58:00
               Card-2: Intel Wireless 7265 driver: iwlwifi bus-ID: 03:00.0 chip-ID: 8086:095a
               IF: wlo1 state: up mac: 5c:e0:c5:7a:35:e1
    Drives:    HDD Total Size: 500.1GB (2.0% used)
               ID-1: /dev/sda model: ST500LM021 size: 500.1GB serial: W625H74Y
    Partition: ID-1: / size: 188G used: 5.2G (3%) fs: ext4 dev: /dev/sda6
               ID-2: /boot size: 96M used: 91M (95%) fs: vfat dev: /dev/sda2
               ID-3: swap-1 size: 4.63GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
    Sensors:   None detected - is lm-sensors installed and configured?
    Info:      Processes: 153 Uptime: 7:01 Memory: 2048.5/7855.5MB Init: systemd v: 236 Gcc sys: 7.2.1
               Client: Shell (fish running in urxvt) inxi: 2.3.56
    
  • hybrid graphics… aka PRIME:
    https://wiki.archlinux.org/index.php/PRIME

    so may you do not have installed both drivers? and lightdm is confused…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad

    Ty for helping. I believe that I don’t have lightdm (or any dm).

    I installed xf86-video-amdgpu and xf86-video-intel and rebooted.

    xrandr --listproviders
    

    Only shows one provider, which I think is a problem :

    Providers: number : 1
    Provider 0: id: 0x49 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 6 associated providers: 0 name:Intel
    

    EDIT: xbacklight works now

  • I believe that I don’t have lightdm (or any dm).

    i think i was mixing to different topics here 🤔
    Posting from smartphone while learning mathematics is not the best 😉

    but it looks i was right on the drivers!
    and i do not know if xrandr lists only the loaded one…

    I am glad to be helpfull to you !

    If you feel o.k. mark as solved please. If not proceed :

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad Indeed it is solved ! 🙂

backlight7 modigy1 Posts 7Views 336
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.