• lightdm crashes


    Having an issue with lightdm.

    Opened the PC this morning, and it was stuck in booting.
    Sshed into it, and I can see lightdm is crashing.
    Any idea why that is?

    0_1517477737189_Screenshot_2018-02-01_09-34-27.png

    I didn’t change any hardware and I didn’t install anything new since yesterday ( when it was working ).

  • system up to date? “Opened the PC” means resume from suspend? or power on from powered of?

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad Means booting normally. PC always gets powered down.

  • O.K. never have lightdm coredumping … may try to remove complete and reinstall to see if it is not caused by filecorruption.

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad I tried. I got gdm and lxdm to see if I can replace it, but both are not working.
    In the process I updated the nvidia drivers, and now I’m kind of stuck because I cannot get them to work.
    It’s probably cause the gpu card is old ( Geforce 7600GS , it needs 304 nvidia drivers ).
    I ordered a new GPU to see if getting latest nvidia drivers will fix it.

    In any case, what’s the process to completely remove lightdm and. either replace it with something else or re-install it?

    Thank you

  • @antouank said in lightdm crashes:

    Geforce 7600GS

    thats a legacy card as you can see here: http://www.nvidia.com/object/IO_32667.html
    http://www.nvidia.com/download/driverResults.aspx/123709/en-us

    say this one is last you can use: 304.137
    so one of this this one is needed for it:
    https://wiki.archlinux.org/index.php/NVIDIA#Unsupported_drivers
    but it looks like they are not aviable anymore, so you will be forced to use open source nouveau driver to get system bootup again to X!!!

    Most easy way should be using nvidia-installer package to went back to nouveau driver:

    sudo pacman -S nvidia-installer

    then run it:
    sudo nvidia-installer -n
    (-n, --nouveau Restores nouveau (open) nvidia driver)

    for reference look here:
    https://antergos.com/wiki/hardware/graphics/antergos-nvidia-installer-2/

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad I’ve already orderer a 1050. Thanks though.

    Regarding lightdm, how can you replace it with something else? I’ve tried gdm and lxdm and failed both times.

  • Easy

    • install the one you want
    • enable it to start on boot with systemd (force option to disable the before used one)
    sudo systemctl -f enable gdm
    

    replace gdm with the one you installed.

    but with your current graphic card you need to go back to nouveau first! X and any DM will not start with properitary Nvidia driver installed!
    When you get the new card start system on nouveau driver and use Nvidia-Installer to install the nividia driver and auto configure it:

    sudo nvidia-installer
    

    If it do not know your card force it

    sudo nvidia-installer -f
    

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad I thought to get nvidia you do pacman -S nvidia nvidia-utils and then sudo nvidia-xconfig.
    What else does nvidia-installer do?

  • I got the new card, installed the nvidia drivers ( nvidia-smi reports the card just fine ) for again I cannot launch a graphic environment.

    lightdm fails like before, and gdm flashes the screen for a few times and then gets stuck.
    I can see this in the logs GdmLocalDisplayFactory: maximum number of X display failures which I guess means that it tries to find a screen?
    I don’t get it.

    I ran nvidia-xconfig so set a new xorg.conf, but again the same.

    Any help at all??

    I cannot understand what’s the problem.

  • @antouank said in lightdm crashes:

    sudo nvidia-xconfig

    is creating a useless xorg.conf… nvidia-installer is checking packages and removing nouveau and also do the config files for nvidia.

    looks like accoundsservice is messing around on your system…but first i would remove /etc/X11/xorg.conf created by nvidia-xconfig …

    then:
    I uninstall gdm, remove /var/lib/AccountsService/users/gdm and reinstall gdm

    sudo systemctl disable gdm
    sudo pacman -R gdm 
    sudo rm /var/lib/AccountsService/users/gdm
    sudo pacman -S gdm
    

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • got the same issues
    I tried removeing nvidia drivers and booting with default
    can’t boot in graphical anymore
    since yesterday update

    4.13.2-1-zen - KDE Plasma 5.10.5 (Qt 5.9.1)
    i7-4820K 3900 - 32GB RAM - GTX 1060 6GB
    HDD 2000.4GB, SSD1 250.1GB, SSD2 480.1GB
    Init: systemd, zsh 5.4.2

  • removing nvidia properitary driver should be done with antergos nvidia-installer as it has the option to revert settings and drivers to make nouveau working at ease…
    sudo nvidia-installer -n
    you can start without X by following this:
    https://antergos.com/wiki/miscellaneous/howto-boot-without-graphical-environment/
    (for grub only)

    so you will be able to run commands.

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in lightdm crashes:

    sudo pacman -S gdm

    I did all that, removed the xorg.conf and ran nvidia-installer -f again to write a new one.

    Still same problem.

    ➜  ~ sudo systemctl status gdm
    ● gdm.service - GNOME Display Manager
       Loaded: loaded (/usr/lib/systemd/system/gdm.service; disabled; vendor preset: disabled)
       Active: active (running) since Sat 2018-02-03 15:42:03 EET; 11s ago
     Main PID: 831 (gdm)
        Tasks: 4 (limit: 4915)
       CGroup: /system.slice/gdm.service
               └─831 /usr/bin/gdm
    Φεβ 03 15:42:10 htpc gdm[831]: Child process -948 was already dead.
    Φεβ 03 15:42:10 htpc gdm[831]: Child process 937 was already dead.
    Φεβ 03 15:42:10 htpc gdm[831]: Unable to kill session worker process
    Φεβ 03 15:42:11 htpc gdm[831]: GdmDisplay: display lasted 1,265094 seconds
    Φεβ 03 15:42:11 htpc gdm[831]: Child process -978 was already dead.
    Φεβ 03 15:42:11 htpc gdm[831]: Child process 967 was already dead.
    Φεβ 03 15:42:11 htpc gdm[831]: Unable to kill session worker process
    Φεβ 03 15:42:12 htpc gdm[831]: GdmDisplay: display lasted 1,246818 seconds
    Φεβ 03 15:42:12 htpc gdm[831]: GdmLocalDisplayFactory: maximum number of X display failures rea
    Φεβ 03 15:42:12 htpc gdm[831]: Child process -1008 was already dead.
    
  • do you do a system update? there was some issue with kernel and nvidia drivers as i can see…

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • nvidia-installer gives me error

    Could not find a driver suitable for your graphic card

    Everything was working excellent until Feb 1st update

    WTH???
    I have 1060 and driver Nvidia 387.34-6 was excellent

    What can I do??
    I am default in win10 now!!😭

    4.13.2-1-zen - KDE Plasma 5.10.5 (Qt 5.9.1)
    i7-4820K 3900 - 32GB RAM - GTX 1060 6GB
    HDD 2000.4GB, SSD1 250.1GB, SSD2 480.1GB
    Init: systemd, zsh 5.4.2

  • @mbalino https://antergos.com/wiki/miscellaneous/howto-boot-without-graphical-environment/
    you can always use the force option nvidia-installer -f

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

lightdm115 crashes19 Posts 17Views 616
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.