• Cnchi unable to install Antergos


    Hi all,

    I’m currently trying to install Antergos using Cnchi and its refusing. Im getting the following error:

    ‘Cannot create download package list (metalinks)
    use error code 958106 for reference’

    tried updating Cnchi, got this error:

    [[email protected] ~]$ sudo pacman -Syu
    error: GPGME error: No data
    error: could not register ‘multilib’ database (database already registered)
    :: Synchronizing package databases…
    error: GPGME error: No data
    error: failed to update antergos (invalid or corrupted database (PGP signature))
    core is up to date
    extra is up to date
    community is up to date
    multilib is up to date
    error: database ‘antergos’ is not valid (invalid or corrupted database (PGP signature)).

    Any help would be appreciated.
    Cnchi version: 0.14.410
    Antergos Live ISO was downloaded 2 hours ago (so is most recent version)

  • @skyflex said in Cnchi unable to install Antergos:

    try again later would be the most common answear…
    can be an outdated mirror?

    But error: database ‘antergos’ is not valid (invalid or corrupted database (PGP signature)) links also to the possibility to https://antergos.com/wiki/uncategorized/update-error-involving-keyrings/
    also…

    so try this from terminal before starting installation:

    sudo pacman -Scc
    sudo pacman-key --refresh-keys
    sudo pacman -Syu
    

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • Yeah potentially.
    I’ve tried just rebooting the installation media a few times but nothing.

    What you suggested

    sudo pacman -Scc
    sudo pacman-key --refresh-keys
    sudo pacman -Syu

    when trying to run the ‘sudo pacman -Syu’ I get the same error as before.
    and it seems to be giving me a different error code each time.

  • I do not know about this code… it is supposed to say something to @developers

    And i have no clue at the moment what is causing the PGP error, but so far it says that the
    database for the antergos repository is not checkable caused by error from PGP signature…

    So what i would try is to revoke the keyring for pacman and check again…

    sudo su
    pacman -Sw antergos-keyring
    pacman -U /var/cache/pacman/pkg/antergos-keyring-20170524-1-any
    pacman -Syyu
    

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • @joekamprad said in Cnchi unable to install Antergos:

    I do not know about this code… it is supposed to say something to @developers

    And i have no clue at the moment what is causing the PGP error, but so far it says that the
    database for the antergos repository is not checkable caused by error from PGP signature…

    So what i would try is to revoke the keyring for pacman and check again…

    sudo su
    pacman -Sw antergos-keyring
    pacman -U /var/cache/pacman/pkg/antergos-keyring-20170524-1-any
    pacman -Syyu
    

    Yeah that didn’t work either, this is the response:

    [[email protected] ~]$ sudo su
    [[email protected] antergos]# pacman -Sw antergos-keyring
    error: GPGME error: No data
    error: could not register 'multilib' database (database already registered)
    error: database 'antergos' is not valid (invalid or corrupted database (PGP signature))
    [[email protected] antergos]# pacman -U /var/cache/pacman/pkg/antergos-keyring-20170524-1-any
    error: GPGME error: No data
    error: could not register 'multilib' database (database already registered)
    error: database 'antergos' is not valid (invalid or corrupted database (PGP signature))
    loading packages...
    error: '/var/cache/pacman/pkg/antergos-keyring-20170524-1-any': could not find or read package
    [[email protected] antergos]# pacman -Syyu
    error: GPGME error: No data
    error: could not register 'multilib' database (database already registered)
    :: Synchronizing package databases...
    error: GPGME error: No data
    error: failed to update antergos (invalid or corrupted database (PGP signature))
     core                     128.2 KiB  1282K/s 00:00 [######################] 100%
     extra                   1629.6 KiB  2.89M/s 00:01 [######################] 100%
     community                  4.1 MiB  3.41M/s 00:01 [######################] 100%
     multilib                 167.8 KiB  2.88M/s 00:00 [######################] 100%
    error: database 'antergos' is not valid (invalid or corrupted database (PGP signature))
    [[email protected] antergos]# 
    

    edit - This was also on a fresh iso boot media from another Mirror of the Live ISO
    i’ve tried differen’t options in all the installation options, apart from my boot which is just going on an SSD partition

  • sorry to jump into this post but i am experiencing same issue here in UK. been trying to install Antergos all day but getting same error…

    Antergos installer error:  cannot create download package list (metalinks). Please reference the following number when reporting this error 957825.
    

    This ref number changes each time I try to install

    I have also tried the suggestions above and get exact same output as OP.

    Should I create a new issue?

  • @fracmo2000 said in Cnchi unable to install Antergos:

    sorry to jump into this post but i am experiencing same issue here in UK. been trying to install Antergos all day but getting same error…

    Yep i’m UK too
    -edit: I’ve also tried to follow this forum post
    https://forum.antergos.com/topic/2859/solved-invalid-or-corrupted-database-pgp-signature/5
    with a similar issue (was posted a while ago) and tried making changes to the Mirrorlist but it made no difference, still gave the error: database ‘antergos’ is not valid…PGP signature

  • @skyflex thanks for reply, I’m still having problems so I created a new topic in case the issues are different…
    https://forum.antergos.com/topic/9086/xfce-install-error-cannot-create-download-package-list-metalinks
    I have tried with wireless and also network cable, with java included and without, but no joy

cnchi119 unable50 Posts 8Views 221
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.