• Could not satisfy dependencies error.


    But I’m confused by the output.

    :: Synchronizing package databases...
     antergos                                                178.4 KiB  1784K/s 00:00 [##############################################] 100%
     core                                                    127.5 KiB  2.90M/s 00:00 [##############################################] 100%
     extra                                                  1630.8 KiB  13.6M/s 00:00 [##############################################] 100%
     community                                                 4.1 MiB  19.7M/s 00:00 [##############################################] 100%
     multilib                                                167.8 KiB  3.49M/s 00:00 [##############################################] 100%
    :: Starting full system upgrade...
    :: Replace deepin-artwork-themes with community/deepin-desktop-schemas? [Y/n] y
    resolving dependencies...
    looking for conflicting packages...
    error: failed to prepare transaction (could not satisfy dependencies)
    :: antergos-deepin-meta: removing deepin-artwork-themes breaks dependency 'deepin-artwork-themes'
    

    But why? I’ve been avoiding this for while, and completing the other updates independently for a day or so now, but to me it’s a weird conflict.
    Why would it stop proceeding by saying it’ll “break” the very thing it’s trying to replace?

  • @mariol said in Could not satisfy dependencies error.:

    antergos-deepin-meta: removing deepin-artwork-themes breaks dependency 'deepin-artwork-themes

    caused by the dependencies of the antergos-deepin-meta package it needs to be changed to fit the new dependency.

    @developers needs to update the meta-package …

    as i can see from here 😉

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad Hadn’t realized we had a github. I’ll bookmark it! Thanks!

  • 0_1517419711128_Bildschirmfoto vom 2018-01-31 18-28-18.png

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • And if you want to, you can easily avoid problems like that in the future by removing that meta package, leaving behind all of the other packages that it relies on (its dependencies) by simply pasting this into your terminal: sudo pacman -Rdd antergos-deepin-meta. After that, you should be able to easily manage each of those packages individually as well as add/remove them whenver you want.

    Hope this helps @MarioL, and good luck!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

  • Today’s update to

    antergos-deepin-meta
    

    Has fixed this issue! This is now solved!

  • community fixed it ✌

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

error276 dependencies15 satisfy4 Posts 8Views 495
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.