• Can't get Wifi to work on new install


    Hello everyone.

    I am new to Linux and have installed Antergos on a spare HDD to learn the OS. I am having a hard time figuring out why I can’t get my wireless card to work. I have a TP-Link T8E PCI card. I have been searching the web for answers but nothing seems to help.

    This is what I get when I run lspci:

    05:00.0 Network controller: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter (rev 03)
    Subsystem: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter
    Kernel modules: bcma

    I have tried to install the broadcom-wl, bradcom-wl-dkms, and b43 drivers (not at once). The installs seems to go fine but once I restart the PC, nothing seems to load.

    This is the output of ip link

    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: enp9s1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether bc🇦🇪c5:42:59:a1 brd ff:ff:ff:ff:ff:ff

    Any help would be greatly appreciated!

  • Well, I got it working. For whatever reason I overlooked the need to install the linux-headers with the broadcom-wl-dkms drivers.

  • welcome @ antergos! 👍

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

wifi124 Posts 3Views 523
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.