• Switching language on Xfce


    I would like to switch the language to Esperanto. I have altered my .bashrc and my ~/.config/locale.conf to include export LANG=eo.utf8, and my .dmrc file to include Language=eo.utf8 and while bash has changed to Esperanto, I am so far unable to get the changes to reflect on Xfce.

    It’s reflected when I switch to KDE, but I want to use Xfce.

    waifu for laifu

  • You will need to regenerate locales:
    https://wiki.archlinux.org/index.php/Locale

    uncomment the one you want to add inside: /etc/locale.gen

    sudo nano /etc/locale.gen
    

    before:

    #eo UTF-8
    

    needs to look so:

    eo UTF-8
    

    then regenerate locales:

    sudo locale-gen
    

    after logout/reboot it should be aviable

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • I was feeling sure that I had already done all of that, but I just did it again to be sure. Xfce is still in English. And below is the output of the locale command:

    [[email protected] ~]$ locale
    LANG=eo.utf8
    LC_CTYPE="eo.utf8"
    LC_NUMERIC="eo.utf8"
    LC_TIME="eo.utf8"
    LC_COLLATE="eo.utf8"
    LC_MONETARY="eo.utf8"
    LC_MESSAGES="eo.utf8"
    LC_PAPER="eo.utf8"
    LC_NAME="eo.utf8"
    LC_ADDRESS="eo.utf8"
    LC_TELEPHONE="eo.utf8"
    LC_MEASUREMENT="eo.utf8"
    LC_IDENTIFICATION="eo.utf8"
    LC_ALL=
    

    Is there anything else I could be missing here?

    waifu for laifu

  • as far as i know xfce itself has no lang-switcher…

    But try this:

    sudo localectl set-locale LANG="eo.utf8"

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • This is the output of localectl. As I suspected, it’s already set. Bash is already in Esperanto.

    [[email protected] ~]$ localectl
       System Locale: LANG=eo.utf8
           VC Keymap: dvorak
          X11 Layout: us
         X11 Variant: dvorak
    

    So I don’t believe that step would change anything. I’ll try posting to the Xfce forums too.

    waifu for laifu

  • @luna4prez said in Switching language on Xfce:

    X11 Layout: us

    May try to change lightdm greeter to lightdm-gtk-greeter so you can change language on the run?

    sudo pacman -S lightdm-gtk-greeter lightdm-gtk-greeter-settings
    sudo nano /etc/lightdm/lightdm.conf
    

    change
    greeter-session=lightdm-webkit2-greeter
    to
    greeter-session=lightdm-gtk-greeter

    Save with [Ctrl+X]
    reboot, and change language before login to xfce…

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • I figured it out!
    I had been using lightdm-gtk-greeter all this time, but had no language picker option. I followed a somewhat-related troubleshooting thingy on the Arch Wiki and got not only the missing language switcher but also the missing power button.

    For future people, here is what I did exactly:

    sudo vim /etc/lightdm/lightdm-gtk-greeter.conf
    

    (or the text editor of your choice, I use vim but the mod here seems to recommend nano)
    I then added the following line to the end:

    indicators = ~host;~spacer;~clock;~spacer;~language;~session;~a11y;~power
    

    After rebooting and switching the language picker to eo.utf8, my system is now properly in Esperanto.
    Dankon por via helpo, joekamprad!

    waifu for laifu

  • Ĝi estis plezuro al mi 🌻

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @luna4prez said in Switching language on Xfce:

    the mod here seems to recommend nano

    Only because of its ease!

    vim is imho still the standard!

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

xfce61 language24 switching10 Posts 9Views 423
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.