• Update issue with webkitgtk (enchant dependency)


    I could not update webkitgtk due to the following error. Any solution? Thank you.

    https://s17.postimg.org/jx9ll7y0v/Screenshot_from_2018-01-25_10-44-44.png

  • if you do in terminal, and do sudo pacman -Syu , and possible pastebin in a service would be more clear…

    also give output of pacman -Qi webkitgtk

  • $ pacman -Qi webkitgtk
    Name            : webkitgtk
    Version         : 2.4.11-7
    Description     : Legacy Web content engine for GTK+ 3
    Architecture    : x86_64
    URL             : https://webkitgtk.org/
    Licenses        : custom
    Groups          : None
    Provides        : webkitgtk3=2.4.11  libwebkit3=2.4.11
    Depends On      : libxt  libxslt  sqlite  libsoup  enchant  libgl  geoclue2
                      gst-plugins-base-libs  libsecret  libwebp  harfbuzz-icu  gtk3
    Optional Deps   : gst-plugins-base: free media decoding [installed]
                      gst-plugins-good: media decoding [installed]
                      gst-libav: nonfree media decoding [installed]
                      gtk2: Netscape plugin support [installed]
    Required By     : None
    Optional For    : None
    Conflicts With  : webkitgtk3  libwebkit3
    Replaces        : webkitgtk3  libwebkit3
    Installed Size  : 43.95 MiB
    Packager        : Unknown Packager
    Build Date      : Fri 22 Dec 2017 23:12:29 CET
    Install Date    : Fri 22 Dec 2017 23:18:29 CET
    Install Reason  : Installed as a dependency for another package
    Install Script  : Yes
    Validated By    : None
    
    
  • And pacman -Syua gives:

    yaourt -Syua
    :: Synchronising package databases...
     antergos is up to date
     core is up to date
     extra is up to date
     community is up to date
     multilib is up to date
      gstreamer0.10-bad : Orphan 
      gstreamer0.10-bad-plugins : Orphan 
      gstreamer0.10-ffmpeg : Orphan 
      gstreamer0.10-ugly : Orphan 
      gstreamer0.10-ugly-plugins : Orphan 
     Foreign packages: / 69 / 69
    
    ==> Package upgrade only (new release):
    aur/webkitgtk 2.4.11-7 7 -> 11
    
    ==> Continue upgrade ? [Y/n]
    ==> [V]iew package detail   [M]anually select packages
    ==> --------------------------------------------------
    ==> 
    
    ==> Downloading webkitgtk PKGBUILD from AUR...
    x .SRCINFO
    x PKGBUILD
    x enchant-2.x.patch
    x icu59.patch
    x pkgconfig-enchant-2.patch
    x webkitgtk-2.4.9-abs.patch
    x webkitgtk.install
    germanfr commented on 2017-12-30 08:30			 
    
    Scimmia commented on 2017-12-30 08:48			 
    
    Batou commented on 2018-01-02 02:58			 
    
    Thermi commented on 2018-01-11 12:40			 
    
    yan12125 commented on 2018-01-22 15:05			 
    
    webkitgtk 2.4.11-11  (2018-01-23 05:08)
    ( Unsupported package: Potentially dangerous ! )
    ==> Edit PKGBUILD ? [Y/n] ("A" to abort)
    ==> ------------------------------------
    ==> n
    
    ==> WARNING: This PKGBUILD describes a split package.
    ==> Specific package options are unknown
    ==> webkitgtk dependencies:
     - libxt (already installed)
     - libxslt (already installed)
     - sqlite (already installed)
     - libsoup (already installed)
     - libgl (already installed)
     - geoclue2 (already installed)
     - gst-plugins-base-libs (already installed)
     - libsecret (already installed)
     - libwebp (already installed)
     - harfbuzz-icu (already installed)
     - gtk3 (already installed) [makedepend]
     - gtk2 (already installed) [makedepend]
     - gperf (already installed) [makedepend]
     - gobject-introspection (already installed) [makedepend]
     - python2 (already installed) [makedepend]
     - mesa (already installed) [makedepend]
     - ruby (already installed) [makedepend]
     - enchant>=2.2 (building from AUR)
    
    
    ==> Edit webkitgtk.install ? [Y/n] ("A" to abort)
    ==> ---------------------------------------------
    ==> n
    
    ==> Continue building webkitgtk ? [Y/n]
    ==> -----------------------------------
    ==> 
    
    ==> Building and installing package
    ==> Install or build missing dependencies for webkitgtk:
    error: target not found: enchant>=2.2
    ==> Restart building webkitgtk ? [y/N]
    
    
  • what is pacman -Qdt ? does show webkitgtk there… then remove webkitgtk by sudo pacman -R webkitgtk

    if its needed by a program it will not remove unles you force anyway

    webkitgtk is kinda old. mayby its replaced already?

  • also it tolds required by noe probably remove it

  • @ringo32 said in Update issue with webkitgtk (enchant dependency):

    sudo pacman -R webkitgtk

    Ok thank you I removed it. Honestly I do not remember why I had it installed. LOL

  • probably installed with a package ‘enchant’ but removed webkitgtk as depency i gues so it died , if you see pacman -Qdt it had no owner anymore

  • Oh yeah, Yaourt is no pacman ; i use yaourt -Syua to update my aur package but i tend not to mix it up 🙂

    yaourt is pacman frontend to use aur…

  • well…I am not too diligent. Thank you anyway.

dependency20 enchant1 webkitgtk1 Posts 11Views 645
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.