• Font on Qt applications (Antergos 18.1)


    Hey,

    How can I change the default font on Qt5 applications (e.g. QupZilla browser)? Changing font settings either on the system (Cinnamon) or on the app itself doesn’t do anything. I’m using a fresh Antergos installation with Adwaita controls theme. Right now the default font for all Qt5 applications is a Serif font (see the image below), but why is that? My other computers with older Antergos installations have nice Sans Serif fonts on all Qt5 apps.

    It seems that this problem occurs only on the latest Antergos ISO-release (version 18.1), but I can’t figure out which configuration file(s) should I edit to fix the font?

    I don’t know if this is related to the font problem but I noticed several (apparent) leftover files and folders in my home directory right after finishing Antergos installation. These files probably don’t belong to a fresh Cinnamon installation?

    ~/.config/i3
    ~/.config/i3status
    ~/.config/lxterminal
    ~/.config/nitrogen
    ~/.config/openbox
    ~/.config/plank
    ~/.config/qtcurve
    ~/.config/razor
    ~/.config/terminology
    ~/.config/tint2
    ~/.config/volumeicon
    ~/.config/chromium-flags.conf
    ~/.config/compton.conf
    ~/.config/conky.conf
    ~/.config/kdeglobals
    ~/.config/Trolltech.conf
    ~/.config/yad.conf
    

    These same files can also be found inside the system’s skeleton directory (/etc/skel) and root’s home folder (/root).

    Here is a font comparison showing QupZilla (which is a Qt application) on latest Antergos ISO-release (the top image) and on older Antergos installation (the bottom image).

    QupZilla Font

  • @gladiator said in Font on Qt applications (Antergos 18.1):

    How can I change the default font on Qt5 applications (e.g. QupZilla browser)? Changing font settings either on the system (Cinnamon) or on the app itself doesn’t do anything…

    Font settings for Qt applications aren’t controlled by Gtk font settings tools. In Gtk-based DEs they may be set | changed with qt5ct utility:

    sudo pacman -Syu qt5ct
    

    Beware: never install and never use qt5ct in Kde. Otherwise, it’ll override all Kde font settings.

    To be able to use qt5ct in Gtk-based DEs make sure that QT_QPA_PLATFORMTHEME environment variable is set to qt5ct.

    It may be done in different ways. For example, to make the QT_QPA_PLATFORMTHEME variable available system-wide (for all users, including root), append to existing /etc/environment file:

    QT_QPA_PLATFORMTHEME=qt5ct
    

    This question was already answered here.

    I don’t use QupZilla, so cannot say anything about it.

  • @just Thank you very much, the fonts are now fixed 🙂 Changing Fonts settings in Qt5 Configuration Tool (qt5ct) did the trick. I had already flicked through the qt5ct settings earlier but the Fonts tab only showed the current font size so I thought I couldn’t change the actual typeface. This time I was brave enough to actually click the edit button (…) which opened the font selection window… I feel dumb 😁 Anyways, thank you, just, for your great help.

applications30 font27 18.12 Posts 3Views 550
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.