• Problems with one specific external monitor


    Hey there everyone. I have an external ASUS monitor that I connect to my laptop (Dell XPS 15 9550) which dual boots W10 and Antergos. I’ve had issues in the past with the monitor being buggy with scaling, since my laptop screen is 4k but the monitor is only 1080p. Thankfully, most of the weirdness is fixed with a simple reboot or relogin. However, for the past week or so, something happened to where Antergos won’t recognize the monitor anymore; as in, it doesn’t even turn on when plugged in. I’ve tested other monitors, and they all work fine, but for some reason it will no longer recognize this particular one. But there is even more weirdness.

    I am using GDM as my display manager for gnome, and at the login screen, GDM will recognize and power up the monitor, but as soon as I login in, it refuses to connect. If I try to switch displays through the gnome settings, my screen will flash, and it looks like it is trying to connect, but it fails, forcing me back to single display mode. If I keep it running in single display mode and leave the monitor plugged in, my laptop screen will periodically flash and spaz out.

    I have tried reinstalling gnome, wayland, and gdm. I have tried using nvidia and nouveau drivers, but nothing seems to work. I was reading up on possible solutions, and most things refer to using xrandr to address issues. From what I understand though, xrandr doesn’t work with wayland, so unless I am incorrect, that is a dead end.

    Anyway, I know this is a weird problem, but I wanted to see if any of you had any ideas of what I might do to fix it.

    Thanks!

    EDIT: I shot a quick video to illustrate the problem. Not sure if it helps, but hopefully it clarifies what is happening.
    https://photos.app.goo.gl/MPtcpAmbt4foy4Km2

  • UPDATE:

    I was able to isolate the issue to what I believe to be a wayland problem. I’m not too familiar with how Gnome does its hybrid wayland/xorg configuration, but after installing the gnome xorg fallback, the monitor worked fine. I just ended up removing gnome, and reinstalling it. Whatever the issue is, it was fixed during reinstall. I suppose you can mark this solved!

    Thanks guys!

monitor43 external16 specific7 Posts 2Views 285
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.