• [Solved] Unable to install Antergos. No network activity?


    Hello, all. Going to attempt to provide as much detail as possible to save as much time as possible.

    I have attempted installation from both minimal ISO and full live ISO. Both give me the same problem when I attempt to install Antergos. No internet connection detected. My motherboard has no wifi capability (an old ASUS ROG motherboard, Maximus VI Hero).

    In the Live environment, my wired connection is detected. But I am unable to proceed. Opening Chromium and attempting to go to Google gives me “There is no internet connection.”

    I have Googled and attempted the following steps:

    Attempting to identify ethernet controller hardware.
    Output of:
    sudo lspci -v

    Returned ethernet information of:
    Ethernet controller: Intel Corporation Ethernet Connection I217-V (rev 04)
    Subsystem: ASUSTeK Computer Inc. Ethernet Connection I217-V
    Flags: bus master, fast devsel, latency 0, IRQ 29
    Memory at f5100000 (32-bit, non-prefetchable) [size=128K]
    Memory at f5139000 (32-bit, non-prefetchable) [size=4K]
    I/O ports at f040 [size=32]
    Capabilities: [c8] Power Management version 2
    Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [e0] PCI Advanced Features
    Kernel driver in use: e1000e
    Kernel modules: e1000e

    Using this knowledge, I did not believe that the solutions I found would help me. But no loss in trying, I reckon, outside of time.

    Attempted:
    sudo modprobe -r tg3
    sudo modprobe broadcom
    sudo modprobe tg3

    No change, obviously. Because I don’t believe I have a Broadcom ethernet controller.

    Attempted:
    sudo modprobe brcmsmac

    No change.

    Invocation:
    iwconfig

    Returned:
    lo no wireless extensions.

    eno1 no wireless extensions.

    Invocation:
    ip link

    Returned:
    1: lo: <LOOPBACK, UP, LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

    2: eno1: <BROADCAST, MULTICAST, UP, LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 74:d0:2b:7f:5a:70 brd ff:ff:ff:ff:ff:ff

    With this information, attempted:
    sudo ip link set74:d0:2b:7f:5a:70 up

    Didn’t work.
    Error: argument “74:d0:2b:7f:5a:70” is wrong: “dev” not a valid ifname

    I imagine, because it clearly states its already up… and obviously I’m using the wrong name. Corrected my input, just incase I’m a dumbass, to:
    sudo ip link set eno1 up

    It ate it. No feedback, nothing telling me anything was broken.
    I attempted to load google.com and instead of immediately telling me “No internet connection”, it now simply hangs. Indefinitely. And I am still unable to proceed with installation because it says I have no Internet connection.

    I don’t know what to do at this point. Never encountered an issue like this before. Please help me. 😞

    I am typing this from my MBP via wifi, so I had to type ALL the output from my desktop by hand. lol

  • @ Any admin.

    Did I post this in the right section?

  • @mariol said in [Problem] Unable to install Antergos. No network activity?:

    2: eno1: <BROADCAST, MULTICAST, UP, LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 74:d0:2b:7f:5a:70 brd ff:ff:ff:ff:ff:ff

    shows device is up, and 74:d0:2b:7f:5a:70 is the MAC dress of the device…

    dmesg | grep e1000e
    

    will give you something like this:

    [   16.402749] e1000e: Intel(R) PRO/1000 Network Driver - 3.2.6-k
    [   16.402750] e1000e: Copyright(c) 1999 - 2015 Intel Corporation.
    [   16.403311] e1000e 0000:00:19.0: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
    [   16.609822] e1000e 0000:00:19.0 eth0: (PCI Express:2.5GT/s:Width x1) 00:23:ae:79:fc:51
    [   16.609831] e1000e 0000:00:19.0 eth0: Intel(R) PRO/1000 Network Connection
    [   16.609864] e1000e 0000:00:19.0 eth0: MAC: 8, PHY: 8, PBA No: 8021FF-0FF
    [   16.714917] e1000e 0000:00:19.0 enp0s25: renamed from eth0
    [   18.607581] e1000e: enp0s25 NIC Link is Up 100 Mbps Full Duplex, Flow Control: Rx/Tx
    [   18.607690] e1000e 0000:00:19.0 enp0s25: 10/100 speed: disabling TSO
    
    ifconfig -a
    

    will give big info about all networkdevices, and you will see if you get a ip-adress.

    And you should have a look into networks-settings from upper right menu (gnome-control-center) and go to network there you can setup everything…

    0_1516560104705_Bildschirmfoto vom 2018-01-21 19-39-44.png

    It looks more that your problem is not that device is not working, it is may the connection to internet itself not working, you can try disable ipv6…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @mariol Command
    ping 8.8.8.8
    shows if the internet connection is working. If that works, then DNS is the problem.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @joekamprad
    dmesg | grep e1000e

    Returned very similar results to yours… but mines included this line:
    (uninitialized): registered PHC clock
    Just under the line that says “Interrupt Throttling Rate”.
    I also do not have a land that says anything about “disabling TSO” at the end.
    Shall I type up the full results?

    EDIT 1:
    Disabled IPv6. A Chromium attempt to pull up Google, gives me “Resolving Host”, then “There is no Internet connection”.

    EDIT 2:
    ifconfig -a

    Returned:
    eno1: flags=4163<UP, BROADCAST, RUNNING, MULTICAST> mtu 1500
    inet6 fe80::11da:3562:ada8:56a7 prefixlen 64 scopeid 0x20<link>
    inet6 2601:5cc:4402:6b71:2544:bc3:209b:940b prefixlen 64 scopeid 0x0<global>
    ether 74:d0:2b:7f:5a:70 txqueuelen 1000 (Ethernet)
    RX packets 768 bytes 110828 (108.2 KiB)
    RX errors 0 dropped 8 overruns 0 frame 0
    TX packets 1810 bytes 182895 (178.6 KiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
    device interrupt 20 memory 0xf5100000-f5120000

    lo: flags=73<UP,LOOPBACK, RUNNING> mtu 65536
    inet 127.0.0.1 netmask 255.0.0.0
    inet6 ::1 prefixlen 128 scopeid 0x10<host>
    loop txqueuelen 1000 (Local Loopback)
    RX packets 4824 bytes 357276 (348.9 KiB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 4824 bytes 357276 (348.9 KiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    Sorry about spacing and formatting. I am typing by hand, and none of my indentations and spaces seem to be translating correctly.

  • @manuel
    ping 8.8.8.8

    returned:
    connect: Network is unreachable

    EDIT 1:
    Under Details for my wired connection in the Settings menu it shows values for Link speed, IP address (seemingly an IPv6 address), and Hardware Address.
    DNS is blank.

  • @mariol said in [Problem] Unable to install Antergos. No network activity?:

    Disabled IPv6. A Chromium attempt to pull up Google, gives me “Resolving Host”, then “There is no Internet connection”.

    There is no Internet connection

    Then check Router first

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad

    Router is on.
    This MBP is connecting to this website, using wifi through the same router.

    Attempting router power cycle…

    EDIT 1:
    Power cycle complete. Internet connectivity restored for MBP, and cell phone… Same symptoms persist.

    I’m puzzled.

    I don’t know if Antergos has a DNS cache or not for sure… I’m on a Live USB, but a shot in the dark…

    Restarting nscd…?
    systemctl restart nscd

    No change.

    What the hell is going?
    ip link show dev eth0

    Return.
    Device “eth0” does not exist.

    Fair enough.
    ip link show dev eno1

    Return.
    2: eno1: <BROADCAST, MULTICAST,UP, LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 74:d0:2b:7f:5a:70 brd ff:ff:ff:ff:ff:ff

    I already confirmed this. Spinning in circles. Speaking of spinning in circles. Drill this b*tch.
    drill www.google.com @8.8.8.8

    Return.
    bash: drill: command not found

    EDIT 2:
    If you can’t drill you must dig…
    dig www.google.com @8.8.8.8

    Return.
    ; <<>> DiG 9.11.2 <<>> www.google.com @8.8.8.8
    ; ; global options: +cmd
    ; ; connection timed out; no servers could be reached

    I’m trying man, I’m really trying. I can’t figure this out.
    I simply can’t establish a connection to DNS. Power cycled router. Router says it has internet connection. Why can’t I reach anything?

  • I can see that lan only get ipv6 adress, usually it will get ipv4 only or both…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad I’m East Coast U.S. It’s late. I’ll come back to this tomorrow night. 😞

  • we will get this working !

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad I don’t understand what happened. I tried again today, using the minimal installer… and suddenly I have NO network issue, and it’s installing normally.

    The only thing that I did before reattempting the installation, was install Antergos to a VirtualBox VM, on a secondary ssd I had.

    I don’t understand. I did not do anything differently this time.
    The image I’m using is the same one. I used the exact same USB boot media, from before.

    I didn’t change anything at all. Why is it working all of sudden? I feel like I have been robbed an opportunity to learn.

    I mean, given the nature of the problem (DNS troubles, despite having a connection), could it be this was a change on the network side, and not mine? And if so, what ultra-obscure situation could cause this?

    I’ll marked this solved, if ANYONE can give me a theory of some sort.
    🙂

  • could be a DNS problem on side of you ISP also… and may they solve it, or you get a new IP and with it updated connection…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @mariol
    Maybe it was just the ultimate cure of everything, shutdown and reboot? 😉

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

cant install3 no internet1 Posts 14Views 878
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.