• Steam on WINE will not login


    Hi all,

    So I like to run Steam under a wine prefix to give me access to all my games. Typically I do this through PlayOnLinux and it works like a charm (on Lubuntu anyways), but with Antergos (or Manjaro for that matter) I can’t get it to work. I install Steam with the POL prefix and everything works until I try to login. I type my username and password and I press login and it just hangs there indefinitely. It’s supposed to do Steam Guard but that prompt never shows up and eventually I have to kill the process or sometimes it’ll kill itself. I have not been able to find any post that’s had a similar issue. Any help would be appreciated. I tried the no dwrite fix to no avail. Thanks!

  • I don’t use POL, Wine, but this guy managed to play Age of Empires 2 on Arch, maybe there are some useful tips there:

    https://pedronveloso.com/how-to-run-age-of-empires-2-hd-on-arch-linux-steam-version/

    I think is not worth the trouble, but if want of course you could try. Usually there are guides on Steam’s forum, go to the game’s forum and search for Wine or Playonlinux and you probably will find some people that made it work.

    I don’t like the idea of Wine because if everyone use wine there will be no point of porting a game/software to Linux, so I don’t use it. If the developers don’t care about Linux I usually don’t care about their game/software.

  • @ssspacez said in Steam on WINE will not login:

    this guy managed to play Age of Empires 2 on Arch

    I play Age 2 HD but without steam, using SmartSteamEmu

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @fernandomaroto Just see you are using correct version of wine this is what people make mistake while configuring wine versions look at steam on winehq make sure its not saying garbage or bronze select wine version saying gold or silver or if that is not available see the tested version.

    I checked it for steam its 2.15 staging and Age of empires is 1.9.13 .

    Age of empire

  • sorry for age of empires 2 its 1.9.13

  • I had this problem as well. I fixed it by uninstalling some fonts. Try bumping your ulimit and also try checking the number of open file handles.

    You can read my post here on it if you want more detail: http://vaughanhilts.me/blog/2018/02/16/steam-hanging-on-clicking-login-wine-staging.html

    In my case, uninstalling Google Fonts package was enough to get me going. You can see lsof to check what wineserver is doing on your machine.

steam59 wineplayonlinux2 Posts 6Views 180
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.