• How to update less often?


    I get new updates almost everyday, can I set it to update every 3 or 5 days?

  • It would appear to be in add/remove software - > preferences. Change the number of hours.

  • as spinnekop said you can change it in add/remove software - > preferences.

    attached a pic, showing the option.

    0_1516368792745_2018-01-19 14_32_06-DeepinBildschirmfoto_20180119143013.png - Windows-Fotoanzeige.jpg

  • or dont start the updater start te pactray manually or something, i use just checkupdates in script to use as notify if i want o update once a week

  • better do updates once a week, and take some time to do it, take a look to what gets updated and take care if something like kernel or drivers get updated, if so read the news first:

    https://antergos.com/blog/category/package-advisories/

    https://www.archlinux.org/news/

  • @joekamprad said in How to update less often?:

    better do updates once a week

    I follow this advice from you for some time now and i don’t regret it! But i’m also thinking of delaying another week, i mean updating every 2 weeks, what do you think about it?

  • I’ve read once that delaying updates just a bit, 1 or 2 days for example would be good because sometimes there are typos in the package code that the devs correct fast and upload a new version correcting the typos(like forgetting to close a }) or they discover a minor bug right after uploading the package, fix it quickly and upload it again.

  • @fernandomaroto i would say: try and error ;)

  • @joekamprad I’ll try it, 1 update > 2 weeks

  • @fernandomaroto
    Here’s a small script for doing it, best to be written into your ~/.bashrc.

    MyUpdater()  # Keep updating system about every two weeks
    {
        local update_interval_days=14
        local dayfile="$HOME/.dayfile"
        local daynow=$(date +%j | sed 's|^[0]*||g')
    
        if [ ! -f "$dayfile" ] ; then
            echo $daynow > "$dayfile"
        fi
        local dayprev=$(cat "$dayfile")
        if [ $daynow -ge $((dayprev + update_interval_days)) ] || [ $daynow -lt $dayprev ] ; then
            pamac-updater
            echo $daynow > "$dayfile"
        else
            echo "no update needed"
        fi
    }
    MyUpdater
    

    EDIT: 22.1.2018: fixed this script, $daynow initialization was wrong.

  • @manuel said in How to update less often?:

    MyUpdater() # Keep updating system about every two weeks
    {
    local update_interval_days=14
    local dayfile="$HOME/.dayfile"
    local daynow=$(date +%j | sed ‘s|0||g’)

    if [ ! -f "$dayfile" ] ; then
        echo $daynow > "$dayfile"
    fi
    local dayprev=$(cat "$dayfile")
    if [ $daynow -ge $((dayprev + update_interval_days)) ] || [ $daynow -lt $dayprev ] ; then
        pamac-updater
        echo $daynow > "$dayfile"
    else
        echo "no update needed"
    fi
    

    }
    MyUpdater

    thanks, i’ll try it right away!

  • Guys, you made my day! Why not to switch tu Ubuntu? :)))))))))))))

  • @manuel I changed it a little, added fancy colors and only enabled echo messages.

    MyUpdater()  # Keep updating system about every two weeks
    {
    Red='\033[0;31m'          # Red
    Green='\033[0;32m'        # Green
    
        local update_interval_days=14
        local dayfile="$HOME/.dayfile"
        local daynow=$(date +%j | sed 's|0||g')
    
        if [ ! -f "$dayfile" ] ; then
            echo $daynow > "$dayfile"
        fi
        local dayprev=$(cat "$dayfile")
        if [ $daynow -ge $((dayprev + update_interval_days)) ] || [ $daynow -lt $dayprev ] ; then
            echo "$Red Update needed"
         #   #echo $daynow > "$dayfile"
        else
            echo "$Green No update needed"
        fi
    }
    MyUpdater
    

    @manuel are you sure the “if” condition will work all the time? For instance, if the config file has day 31, then it will recommend to update next day 1, right? (because both conditions are separeted by OR so if one of them is true it will recommend update, at least is what my brain is thinking here. hehehe

  • @fernandomaroto said in How to update less often?:

    I changed it a little, added fancy colors and only enabled echo messages.

    Nice coloring!
    But you probably accidentally commented out the essential

    echo $daynow > "$dayfile"
    

    line.

    The “if” should mostly work OK, because $daynow is based on the “day of the year”. The last testing part of the “if” is used when the year changes, and then, once a year, it may update sooner than 14 days.

  • @manuel said in How to update less often?:

    But you probably accidentally commented out the essential
    echo $daynow > “$dayfile”

    oops!

    $daynow is based on the “day of the year”

    That makes sense now to me.

    Thank you very much for the script.

  • if you atleast looks at archlinux blogs , most worse parts they wil mention it, 1 a 2 weeks wait for update is not bad, if you do 3 month is another story whatever. then you knever know what the issue can be

    also managing pacnew’s further? memyself removed the notifierfrom panelalso dont have pamac anymore i use tkpacman, love that debian style looks 🐧

  • on my main desktop i update about every week but on my HTPC it doesnt get as much love and gets updated about every 2 months lol. never had an issue yet 😆

  • if you atleast looks at archlinux blogs

    Why are you saying this? I asked @joekamprad for his opinion. I read archlinux wiki/forums a lot.

    @megaman said in How to update less often?:

    on my main desktop i update about every week but on my HTPC it doesnt get as much love and gets updated about every 2 months lol. never had an issue yet 😆

    I also never had problems updating a notebook every 3 months or so. As long as we know the “magic”, that means refresh-init, refresh-keys etc we are fine. I just don’t know if that would cause the system to break at some point (i don’t care about the notebook, but i care about my pc).

  • @fernandomaroto i never sweat a break because i have my OS on a SSD and all my files on a regular HD. so if anything really bad happened it would be easy to reinstall which i dont mind anyway. nice to get a fresh install from time to time.

    the only time my system ever broke on a ARCH related OS was when i was on Manjaro years ago. it did it twice and thats what brought me to Antergos. best move ever :)

  • @manuel
    the file is being overwriten, i guess the if condition is not working. Are you sure the variable need quotes?

    if [ ! -f "$dayfile" ] ; then
        echo $daynow > "$dayfile"
    fi
    

    usually create if conditions using double brackets, that’s how i learned, studying the old Pacbang installer, not sure if it’s better, only how i learned.

Posts 34Views 2143
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.