• cannot format local device


    Everytime i want to format my usb stick an error message appears : Cannot format local device.

  • @oussama.ah95
    What program/command do you use for formatting? How do you use it?

  • @manuel I tried it without a command, i use deepin DE.
    a screenshot :
    0_1516298031849_DeepinScreenshot_20180118185320.png

  • @oussama.ah95
    For formatting you could try program gparted. It is a very capable program (e.g. it can wipe any drive!), so please be very careful to format the correct drive!

    EDIT: And you need root permissions to do formatting… (that may have been the failure reason originally).

  • @manuel I know it, I used it with ubuntu before migrating to Anertgos.
    So it is a deepin problem ?
    Thank you :D

  • @oussama.ah95 See my EDIT above, root permissions are needed.

  • @manuel
    Thank you manuel :D
    I noticed also that i cannot anymore create a booteable usb drive with Deepin boot maker, It doesn’t show me the usb drive to select it :(

  • @oussama.ah95
    Maybe @Keegan would like to participate into this conversation?

    Have you tried to put the USB drive into another port?

    If that doesn’t help, you could try one of the best cures for most strange problems, reboot. ;: - )

  • @manuel yes, I changed the port and even the best cure doesn’t help me.
    The problem persists.

  • @oussama.ah95
    If gparted doesn’t help and the stick is not recognized anymore, then sorry, I’m out of ideas for now.

    Are you sure the stick is not broken? Not often, but sometimes they break surprisingly easily.

    Maybe @Keegan or someone more knowledgeable about Deepin can help you more.

  • @manuel
    I can’t format it with gparted also, i can only unmount it.
    I hopse so and Thank you manuel :D

  • @oussama.ah95
    Well, just got an idea.
    But note that it wipes everything from the stick…

    In gparted, can you create a new partition table into the stick? Either gpt or msdos, doesn’t matter which. It is in one of the menus (device?) in gparted. Sorry, I currently don’t have English locale in my system…

    And if that works, then you can create any partitions to the stick and format them (using gparted).

  • @manuel I can only unmount or manage flags
    0_1516301094096_DeepinScreenshot_20180118194423.png

  • @oussama.ah95
    You only need to unmount it first. Then you can format it.

  • @oussama.ah95
    When you put the stick into a USB port, it will be visible to the system, but (usually) not mounted.
    When you click the stick icon in the file manager, the stick is automatically mounted to a folder.
    When doing dramatic changes in a stick (like formatting), it cannot be mounted.
    You can unmount the stick also in the file manager (at least in Thunar/Xfce).

  • Unmount and click Device or Partition(I don’t remember wich one) on the top menus, then create a new something, I think a new partition table or something like that, choose msdos, and try again.

    More info here: https://gparted.org/display-doc.php?name=help-manual

  • @oussama-ah95

    If you have installed a boot media onto the stick before it has something like a mbr on the beginning… you need to clear the stick complete to repartition it…

    you can use dd for it like this:

    (be aware of dd it is a systemkiller!)

    erase mbr section:

    sudo dd if=/dev/zero of=/dev/sdX bs=512 count=1
    

    where sdX needs to be replaced with your device : (may /dev/sdb???)

    0_1516308618376_Bildschirmfoto vom 2018-01-18 21-50-04.png

    if you run this command with wrong device name it will not boot anymore!)

  • Sorry for not showing up until now, but I’m finally here for the party!

    I have personally never ran into this problem on Deepin, but that’s not to say it couldn’t happen. Just out of curiosity, what type of USB is that @oussama-ah95?

    Thanks!

  • Change the sdc1 to sdb1 in this example here:

    http://en.proft.me/2015/08/25/how-format-usb-arch-linuxubuntu-command-line/

    If this does not work, try in another computer, or ask a friend to format it elsewhere. Then come back and tell us.

device27 format6 Posts 19Views 709
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.