• Meta what now! (Removing meta package orphans meta packages)


    I currently had to reinstall my Desktop. To get the system like I want i had to remove the meta packages. To my surprise this removed most of my packages dependencies. Is there any way to fix this without reinstalling the meta packages? I dont use lightdm or lightlocker. I’d rather not have gnome-extensions in a pkg either.

    Take a look at my laptop (Installed pre meta):

    [[email protected] Crypt]$ sudo pacman -Rns $(pacman -Qtdq)
    [sudo] password for anders: 
    checking dependencies...
    :: tlp optionally requires lsb-release: Display LSB release version in tlp-stat
    :: vlc optionally requires portaudio: for portaudio support
    
    Packages (69) espeak-1:1.48.04-1  libgssglue-0.4-2  lsb-release-1.4-14  oniguruma-6.7.0-1  portaudio-190600_20161030-1  python-babel-2.5.1-1  python-docutils-0.14-1  python-imagesize-0.7.1-2
                  python-jinja-2.10-1  python-markupsafe-1.0-1  python-pygments-2.2.0-1  python-pytz-2017.3-1  python-snowballstemmer-1.2.1-2  python-sphinx-alabaster-theme-0.7.10-1  python-sphinx_rtd_theme-0.2.4-1
                  python-sphinxcontrib-websupport-1.0.1-1  python-sqlalchemy-1.2.0-1  python-whoosh-2.7.4-2  python2-asn1crypto-0.24.0-1  python2-backports-1.0-1  python2-backports.functools_lru_cache-1.4-2
                  python2-beaker-1.8.1-2  python2-cffi-1.11.2-1  python2-cheroot-6.0.0-1  python2-cherrypy-13.1.0-1  python2-cryptography-2.1.4-1  python2-enum34-1.1.6-1  python2-ipaddress-1.0.19-1
                  python2-jaraco-2017.11.25-1  python2-jinja-2.10-1  python2-mako-1.0.7-1  python2-markupsafe-1.0-1  python2-more-itertools-3.1.0-1  python2-pecan-1.2.1-3  python2-ply-3.10-1  python2-portend-2.2-1
                  python2-prettytable-0.7.2-8  python2-pycparser-2.18-1  python2-pyopenssl-17.5.0-1  python2-pytz-2017.3-1  python2-singledispatch-3.4.0.3-2  python2-tempora-1.9-1  python2-webob-1.7.4-1
                  python2-werkzeug-0.13-1  ruby-2.5.0-1  smpeg2-1:2.0.0-2  xf86miscproto-0.9.3-1  brltty-5.5-3  ceph-12.2.2-4  chrpath-0.16-1  ctpl-0.3.4-2  dkms-2.5-1  doxygen-1.8.13-3
                  extra-cmake-modules-5.41.0-1  fcgi-2.4.0-13  gtkspell-2.0.16-6  jq-1.5-5  lib32-libtxc_dxtn-1.0.1-5  lib32-smpeg2-2.0.0-2  libgit2-1:0.26.0-1  libtracker-sparql-1.12.3-1  libxfont-1.5.3-1
                  libxxf86misc-1.0.3-2  lua51-5.1.5-6  pipewire-0.1.7-1  python-sphinx-1.6.5-2  rdesktop-1.8.3-3  remmina-1:1.2.0rcgit.24-1  ruby-bundler-1.16.1-2
    
    Total Removed Size:  473,08 MiB
    
    :: Do you want to remove these packages? [Y/n] n
    
    

    Pretty much what you’d expect from 2 years use… But then take a look at my newly installed desktop…

    [sudo] password for anders: 
    checking dependencies...
    :: gnome-shell optionally requires gnome-control-center: System settings
    :: gnome-shell optionally requires evolution-data-server: Evolution calendar integration
    :: libmagick optionally requires libraw: DNG support
    :: qt5-webkit optionally requires gst-plugins-good: Webm codec support
    :: webkit2gtk optionally requires gst-plugins-good: media decoding
    
    Packages (216) aalib-1.4rc5-12  appstream-glib-0.7.4-1  archlinux-appstream-data-20171217-1  babl-0.1.38-1  cdrdao-1.2.3-10  cdrtools-3.02a09-1  cheese-3.26.0-1  clutter-gst-3.0.24-1  clutter-gtk-1.8.4-1
                   colord-gtk-0.1.26+5+ga9d9c91-1  djvulibre-3.5.27-3  dleyna-connector-dbus-0.3.0-1  dleyna-core-0.6.0-1  dleyna-renderer-0.6.0-1  dleyna-server-0.6.0-1  dmxproto-2.3.1-3  dvd+rw-tools-7.1-7
                   evince-3.26.0+14+g2a499547-1  evolution-3.26.4-1  evolution-data-server-3.26.4-1  exempi-2.4.3+2+g65a8492-1  exiv2-0.26-2  folks-0.11.4-1  gcab-0.7+16+g4bc4be1-1  gegl-0.3.26-1
                   gfbgraph-0.2.3+10+gbc03c1f-1  gmime3-3.2.0-1  gnome-autoar-0.2.2-1  gnome-color-manager-3.26.0+3+g3620f9b-1  gnome-control-center-3.26.2+14+g5ac6a0da6-1  gnome-online-miners-3.26.0-1  gom-0.3.3-1
                   grilo-0.3.4-1  grilo-plugins-0.3.5-1  gspell-1.6.1-2  gssdp-1.0.2-1  gst-plugins-good-1.12.4-1  gtk-engine-murrine-0.98.2-2  gtkmm3-3.22.2+2+g3002ed86-1  gtksourceview3-3.24.6-1
                   gtkspell3-3.0.9-2  gupnp-1.0.2+4+g47b1010-1  gupnp-av-0.12.10-1  gupnp-dlna-0.10.5-2  hunspell-en_GB-2017.01.22-2  hunspell-en_US-2017.01.22-2  libao-1.2.2-1  libchamplain-0.12.16-1
                   libcryptui-3.12.2+24+gd5e5bc5-1  libcue-2.1.0-1  libdmapsharing-2.9.39-1  libdmx-1.1.3-1  libgepub-0.5.2-1  libgexiv2-0.10.7-1  libgnomekbd-3.26.0-1  libgrss-0.7.0+16+g971c421-1  libgsf-1.14.42-1
                   libgxps-0.3.0-1  libibus-1.5.17-1  libiptcdata-1.0.4-3  libmad-0.15.1b-7  libmediaart-1.9.4-1  libnautilus-extension-3.26.2-2  libosinfo-1.1.0-1  libpeas-1.22.0-1  libphonenumber-8.8.9-1
                   libpst-0.6.71-2  libpwquality-1.4.0-1  libquvi-0.9.4-4  libquvi-scripts-0.9.20131130-3  libraw-0.18.6-1  libshout-1:2.4.1-3  libspectre-0.2.8-1  libspiro-1:0.5.20150702-1  libstemmer-0+337-2
                   libxxf86dga-1.1.4-1  libyaml-0.1.7-1  libytnef-1.9.2-2  libzapojit-0.0.3+11+g840627d-2  lua-5.3.4-2  lua52-5.2.4-2  lua52-bitop-1.0.2-8  lua52-expat-1.3.0-3  lua52-lpeg-1.0.1-1
                   lua52-luajson-1.3.4-1  lua52-socket-20160311-1  nautilus-3.26.2-2  nautilus-sendto-3.8.6-1  numix-icon-theme-1:0.r1974-1  oniguruma-6.7.0-1  openvpn-2.4.4-1  osinfo-db-20170813-1
                   pkcs11-helper-1.22-2  poppler-glib-0.61.1-1  pptpclient-1.9.0-1  protobuf-3.5.1.1-1  python-babel-2.5.1-1  python-docutils-0.14-1  python-imagesize-0.7.1-2  python-jinja-2.10-1
                   python-markupsafe-1.0-1  python-pygments-2.2.0-1  python-pytz-2017.3-1  python-snowballstemmer-1.2.1-2  python-sphinx-alabaster-theme-0.7.10-1  python-sphinx_rtd_theme-0.2.4-1
                   python-sphinxcontrib-websupport-1.0.1-1  python-sqlalchemy-1.2.0-1  python-whoosh-2.7.4-2  python-xdg-0.25-4  shared-color-targets-0.1.7-1  t1lib-5.1.2-6  taglib-1.11.1-1  telepathy-idle-0.2.0-2
                   telepathy-logger-0.8.2-2  telepathy-mission-control-5.16.4-2  totem-plparser-3.26.0-1  tracker-2.0.2-1  tracker-miners-2.0.3-1  vte3-0.50.2-1  wavpack-5.1.0-1  xf86dgaproto-2.1-3
                   xf86miscproto-0.9.3-1  xorg-appres-1.0.4-1  xorg-xmodmap-1.0.9-1  xorg-xrandr-1.5.0-1  zip-3.0-7  antergos-gnome-defaults-list-1.0-1  antergos-wallpapers-0.7-3  baobab-3.26.1-1  brasero-3.12.2-2
                   chrpath-0.16-1  dconf-editor-3.26.2-1  doxygen-1.8.13-3  eog-3.26.2-1  extra-cmake-modules-5.41.0-1  ffmpegthumbnailer-2.2.0-1  file-roller-3.26.2-1  gedit-3.22.1+1+gd21912e3e-1
                   gnome-backgrounds-3.26.2-1  gnome-calculator-3.26.0-1  gnome-calendar-3.26.2+19+g954c48d7-1  gnome-contacts-3.26+3+g643f622-1  gnome-disk-utility-3.26.2-1  gnome-documents-3.26.1-1
                   gnome-font-viewer-3.26.0-1  gnome-logs-3.26.2-1  gnome-maps-3.26.2-1  gnome-music-3.26.1-1  gnome-photos-3.26.3-1  gnome-screenshot-3.26.0-1  gnome-sound-recorder-3.24.0.1+8+g0b8e221-1
                   gnome-system-monitor-3.26.0+1+g97b9578d-1  gnome-terminal-3.26.2-1  gnome-tweak-tool-3.26.4-1  gnome-weather-3.26.0-1  go-pie-2:1.9.2-3  go-tools-2:1.9+2247+5d2fd3cc-1  gstreamer-vaapi-1.12.4-1
                   hunspell-de-20161207-1  hunspell-el-0.9-2  hunspell-en-2017.01.22-2  hunspell-es-1:2.2-1  hunspell-fr-6.0.2-1  hunspell-he-1.4-1  hunspell-hu-1.6.1-3  hunspell-it-2.4-5  hunspell-nl-2.10g-2
                   hunspell-pl-20171208-1  hunspell-ro-3.3.10-1  jq-1.5-5  libxxf86misc-1.0.3-2  network-manager-applet-1.8.11dev+7+ga52ccb2f-1  networkmanager-openvpn-1.8.1dev+10+ge4d8cda-2
                   networkmanager-pptp-1.2.4-3  numix-frost-themes-3.6.6-1  numix-icon-theme-square-1:0.r83_9-1  pamac-6.2.2-1  pavucontrol-3.0-4  polari-3.26.2-1  python-psutil-5.4.1-1  python-sphinx-1.6.5-2
                   qt5-styleplugins-5.0.0.20170311-4  qt5ct-0.34-2  squashfs-tools-4.3-4  totem-3.26.0+1+g4e309671-1  transmission-gtk-2.92-7  xdg-user-dirs-gtk-0.10+9+g5b7efc6-1
                   xf86-video-fbdev-0.4.4+12+ge0bce0d-1  xf86-video-vesa-2.3.4-4  xorg-iceauth-1.0.7-1  xorg-sessreg-1.1.1-1  xorg-smproxy-1.0.6-1  xorg-x11perf-1.6.0-1  xorg-xbacklight-1.2.1-1  xorg-xcmsdb-1.0.5-1
                   xorg-xcursorgen-1.0.6-1  xorg-xdpyinfo-1.3.2-1  xorg-xdriinfo-1.0.5-2  xorg-xev-1.2.2-1  xorg-xgamma-1.0.6-1  xorg-xinit-1.3.4-4  xorg-xinput-1.6.2-1  xorg-xkbevd-1.1.4-1  xorg-xkbutils-1.0.4-2
                   xorg-xkill-1.0.4-1  xorg-xlsatoms-1.1.2-1  xorg-xlsclients-1.1.3-1  xorg-xpr-1.0.4-2  xorg-xrefresh-1.0.5-1  xorg-xsetroot-1.1.1-2  xorg-xvinfo-1.1.3-1  xorg-xwd-1.0.6-1  xorg-xwininfo-1.1.3-1
                   xorg-xwud-1.0.4-2  xscreensaver-5.38-1
    
    Total Removed Size:  1135,28 MiB
    
    :: Do you want to remove these packages? [Y/n] n
    [[email protected] ~]$ 
    
    

    This is insane… I just finished setting it up 😕

    This cant be the “future”, if there’s a way to avoid this during install i wish it would be documented, and if not. I cant use it 😞 ?

    There’s a way to remove the meta package and keep

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @izznogooood

    to install all packages from antergos-gnome-meta without installing it you can:
    sudo pacman -S $(LANG=C pacman -Si antergos-gnome-meta |sed -n '/Depends\ On/,/:/p'|sed '$d'|cut -d: -f2 |tr -d '>=[0-9]') --needed

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • Thank you!

    Noted and saved.

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @fernandomaroto

    I’m sorry to report that did not yield any result. It looks like it just list packages, the orphans remain.

    [[email protected] ~]$ sudo pacman -S $(LANG=C pacman -Si antergos-gnome-meta |sed -n '/Depends\ On/,/:/p'|sed '$d'|cut -d: -f2 |tr -d '>=[0-9]') --needed
    warning: antergos-gnome-defaults-list-1.0-1 is up to date -- skipping
    warning: baobab-3.26.1-1 is up to date -- skipping
    warning: brasero-3.12.2-2 is up to date -- skipping
    warning: evince-3.26.0+14+g2a499547-1 is up to date -- skipping
    warning: eog-3.26.2-1 is up to date -- skipping
    warning: file-roller-3.26.2-1 is up to date -- skipping
    warning: gedit-3.22.1+1+gd21912e3e-1 is up to date -- skipping
    warning: gnome-backgrounds-3.26.2-1 is up to date -- skipping
    warning: gnome-calculator-3.26.0-1 is up to date -- skipping
    warning: gnome-calendar-3.26.2+19+g954c48d7-1 is up to date -- skipping
    warning: gnome-contacts-3.26+3+g643f622-1 is up to date -- skipping
    warning: gnome-control-center-3.26.2+14+g5ac6a0da6-1 is up to date -- skipping
    warning: gnome-documents-3.26.1-1 is up to date -- skipping
    warning: gnome-disk-utility-3.26.2-1 is up to date -- skipping
    warning: gnome-font-viewer-3.26.0-1 is up to date -- skipping
    warning: gnome-keyring-1:3.27.2-1 is up to date -- skipping
    warning: gnome-logs-3.26.2-1 is up to date -- skipping
    warning: gnome-maps-3.26.2-1 is up to date -- skipping
    warning: gnome-music-3.26.1-1 is up to date -- skipping
    warning: gnome-photos-3.26.3-1 is up to date -- skipping
    warning: gnome-screenshot-3.26.0-1 is up to date -- skipping
    warning: gnome-shell-3.26.2+9+ga3736d3a3-1 is up to date -- skipping
    warning: gnome-sound-recorder-3.24.0.1+8+g0b8e221-1 is up to date -- skipping
    warning: gnome-system-monitor-3.26.0+1+g97b9578d-1 is up to date -- skipping
    warning: gnome-terminal-3.26.2-1 is up to date -- skipping
    warning: gnome-themes-standard-3.22.3+13+ga993fdc0-1 is up to date -- skipping
    warning: gnome-tweak-tool-3.26.4-1 is up to date -- skipping
    warning: gnome-weather-3.26.0-1 is up to date -- skipping
    warning: gvfs-google-1.34.1+11+gad63dfb7-1 is up to date -- skipping
    warning: gvfs-mtp-1.34.1+11+gad63dfb7-1 is up to date -- skipping
    warning: gvfs-smb-1.34.1+11+gad63dfb7-1 is up to date -- skipping
    warning: hicolor-icon-theme-0.17-1 is up to date -- skipping
    warning: libgnome-keyring-3.12.0-2 is up to date -- skipping
    warning: nautilus-3.26.2-2 is up to date -- skipping
    warning: network-manager-applet-1.8.11dev+7+ga52ccb2f-1 is up to date -- skipping
    warning: networkmanager-openvpn-1.8.1dev+10+ge4d8cda-2 is up to date -- skipping
    warning: networkmanager-pptp-1.2.4-3 is up to date -- skipping
    warning: pamac-6.2.2-1 is up to date -- skipping
    warning: polari-3.26.2-1 is up to date -- skipping
    warning: python-pysmbc-1.0.15.8-1 is up to date -- skipping
    error: target not found: qtct
    warning: seahorse-3.20.0+105+gb31e32fe-1 is up to date -- skipping
    warning: totem-3.26.0+1+g4e309671-1 is up to date -- skipping
    warning: transmission-gtk-2.92-7 is up to date -- skipping
    warning: xdg-user-dirs-gtk-0.10+9+g5b7efc6-1 is up to date -- skipping
    warning: xscreensaver-5.38-1 is up to date -- skipping
    [[email protected] ~]$
    

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @izznogooood said in Meta what now!:

    m sorry to report that did not yield any result. It looks like it just list packages, the orphans remain.

    Ok, it seems the packages remain installed, isn’t that what you wanted?
    I have to leave now, but i’ll come back later.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @fernandomaroto said in Meta what now!:

    Ok, it seems the packages remain installed, isn’t that what you wanted?
    I have to leave now, but i’ll come back later.

    Yes and no.

    The packages are installed but they are all orphans, like no one asked them to be installed and they are considered leftovers. Thats not the case. It would be like “sudo apt autoremove” and it removes Xorg and Gnome.

    I am a patient man, and appreciate the help :), so dont worry about that.

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • I just use sudo pacman -Rdd META_PACKAGE. This will remove the meta package without removing any of it’s dependencies, leaving them completely untouched.

    Hope that helps and good luck!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

  • Just so we are talking about the same thing, i removed the meta’s and only that. No other packages got removed, they just got orphaned.

    Well, yes next time it will ;), but its to late for that now… I all ready removed them with pacman -R. I am guessing reinstalling it and then removing with your cmd is an option.

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @izznogooood
    Ok, i created a theory here, but i guess no one tested it 😛

    for the entire command before simply add --asexplicit and let us see how it goes. This could be a solution (workaround) to all those meta packages problems

    so:

    sudo pacman -S $(LANG=C pacman -Si antergos-gnome-meta |sed -n '/Depends\ On/,/:/p'|sed '$d'|cut -d: -f2 |tr -d '>=[0-9]') --needed --asexplicit
    

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @fernandomaroto said in Meta what now!:

    sudo pacman -S $(LANG=C pacman -Si antergos-gnome-meta |sed -n ‘/Depends\ On/,/:/p’|sed ‘$d’|cut -d: -f2 |tr -d ‘>=[0-9]’) --needed --asexplicit

    Sorry, did not work.

    [[email protected] ~]$ sudo pacman -S $(LANG=C pacman -Si antergos-gnome-meta |sed -n '/Depends\ On/,/:/p'|sed '$d'|cut -d: -f2 |tr -d '>=[0-9]') --needed --asexplicit
    [sudo] password for anders: 
    warning: antergos-gnome-defaults-list-1.0-1 is up to date -- skipping
    warning: baobab-3.26.1-1 is up to date -- skipping
    warning: brasero-3.12.2-2 is up to date -- skipping
    warning: evince-3.26.0+14+g2a499547-1 is up to date -- skipping
    warning: eog-3.26.2-1 is up to date -- skipping
    warning: file-roller-3.26.2-1 is up to date -- skipping
    warning: gedit-3.22.1+1+gd21912e3e-1 is up to date -- skipping
    warning: gnome-backgrounds-3.26.2-1 is up to date -- skipping
    warning: gnome-calculator-3.26.0-1 is up to date -- skipping
    warning: gnome-calendar-3.26.2+19+g954c48d7-1 is up to date -- skipping
    warning: gnome-contacts-3.26+3+g643f622-1 is up to date -- skipping
    warning: gnome-control-center-3.26.2+14+g5ac6a0da6-1 is up to date -- skipping
    warning: gnome-documents-3.26.1-1 is up to date -- skipping
    warning: gnome-disk-utility-3.26.2-1 is up to date -- skipping
    warning: gnome-font-viewer-3.26.0-1 is up to date -- skipping
    warning: gnome-keyring-1:3.27.2-1 is up to date -- skipping
    warning: gnome-logs-3.26.2-1 is up to date -- skipping
    warning: gnome-maps-3.26.2-1 is up to date -- skipping
    warning: gnome-music-3.26.1-1 is up to date -- skipping
    warning: gnome-photos-3.26.3-1 is up to date -- skipping
    warning: gnome-screenshot-3.26.0-1 is up to date -- skipping
    warning: gnome-shell-3.26.2+9+ga3736d3a3-1 is up to date -- skipping
    warning: gnome-sound-recorder-3.24.0.1+8+g0b8e221-1 is up to date -- skipping
    warning: gnome-system-monitor-3.26.0+1+g97b9578d-1 is up to date -- skipping
    warning: gnome-terminal-3.26.2-1 is up to date -- skipping
    warning: gnome-themes-standard-3.22.3+13+ga993fdc0-1 is up to date -- skipping
    warning: gnome-tweak-tool-3.26.4-1 is up to date -- skipping
    warning: gnome-weather-3.26.0-1 is up to date -- skipping
    warning: gvfs-google-1.34.1+11+gad63dfb7-1 is up to date -- skipping
    warning: gvfs-mtp-1.34.1+11+gad63dfb7-1 is up to date -- skipping
    warning: gvfs-smb-1.34.1+11+gad63dfb7-1 is up to date -- skipping
    warning: hicolor-icon-theme-0.17-1 is up to date -- skipping
    warning: libgnome-keyring-3.12.0-2 is up to date -- skipping
    warning: nautilus-3.26.2-2 is up to date -- skipping
    warning: network-manager-applet-1.8.11dev+7+ga52ccb2f-1 is up to date -- skipping
    warning: networkmanager-openvpn-1.8.1dev+10+ge4d8cda-2 is up to date -- skipping
    warning: networkmanager-pptp-1.2.4-3 is up to date -- skipping
    warning: pamac-6.2.2-1 is up to date -- skipping
    warning: polari-3.26.2-1 is up to date -- skipping
    warning: python-pysmbc-1.0.15.8-1 is up to date -- skipping
    error: target not found: qtct
    warning: seahorse-3.20.0+105+gb31e32fe-1 is up to date -- skipping
    warning: totem-3.26.0+1+g4e309671-1 is up to date -- skipping
    warning: transmission-gtk-2.92-8 is up to date -- skipping
    warning: xdg-user-dirs-gtk-0.10+9+g5b7efc6-1 is up to date -- skipping
    warning: xscreensaver-5.38-1 is up to date -- skipping
    [[email protected] ~]$ sudo pacman -Rns $(pacman -Qtdq)
    checking dependencies...
    :: gnome-shell optionally requires gnome-control-center: System settings
    :: gnome-shell optionally requires evolution-data-server: Evolution calendar integration
    :: libmagick optionally requires libraw: DNG support
    :: qt5-webkit optionally requires gst-plugins-good: Webm codec support
    :: webkit2gtk optionally requires gst-plugins-good: media decoding
    
    Packages (215) aalib-1.4rc5-12  appstream-glib-0.7.4-1  archlinux-appstream-data-20171217-1  babl-0.1.38-1  cdrdao-1.2.3-10  cdrtools-3.02a09-1  cheese-3.26.0-1  clutter-gst-3.0.24-1
                   clutter-gtk-1.8.4-1  colord-gtk-0.1.26+5+ga9d9c91-1  djvulibre-3.5.27-3  dleyna-connector-dbus-0.3.0-1  dleyna-core-0.6.0-1  dleyna-renderer-0.6.0-1  dleyna-server-0.6.0-1
                   dmxproto-2.3.1-3  dvd+rw-tools-7.1-7  evince-3.26.0+14+g2a499547-1  evolution-3.26.4-1  evolution-data-server-3.26.4-1  exempi-2.4.3+2+g65a8492-1  exiv2-0.26-2  folks-0.11.4-1
                   gcab-0.7+16+g4bc4be1-1  gegl-0.3.26-1  gfbgraph-0.2.3+10+gbc03c1f-1  gmime3-3.2.0-1  gnome-autoar-0.2.2-1  gnome-color-manager-3.26.0+3+g3620f9b-1
                   gnome-control-center-3.26.2+14+g5ac6a0da6-1  gnome-online-miners-3.26.0-1  gom-0.3.3-1  grilo-0.3.4-1  grilo-plugins-0.3.5-1  gspell-1.6.1-2  gssdp-1.0.2-1
                   gst-plugins-good-1.12.4-1  gtk-engine-murrine-0.98.2-2  gtkmm3-3.22.2+2+g3002ed86-1  gtksourceview3-3.24.6-1  gtkspell3-3.0.9-2  gupnp-1.0.2+4+g47b1010-1  gupnp-av-0.12.10-1
                   gupnp-dlna-0.10.5-2  hunspell-en_GB-2017.01.22-2  hunspell-en_US-2017.01.22-2  libao-1.2.2-1  libchamplain-0.12.16-1  libcryptui-3.12.2+24+gd5e5bc5-1  libcue-2.1.0-1
                   libdmapsharing-2.9.39-1  libdmx-1.1.3-1  libgepub-0.5.2-1  libgexiv2-0.10.7-1  libgnomekbd-3.26.0-1  libgrss-0.7.0+16+g971c421-1  libgsf-1.14.42-1  libgxps-0.3.0-1
                   libibus-1.5.17-1  libiptcdata-1.0.4-3  libmad-0.15.1b-7  libmediaart-1.9.4-1  libnautilus-extension-3.26.2-2  libosinfo-1.1.0-1  libpeas-1.22.0-1  libphonenumber-8.8.9-1
                   libpst-0.6.71-2  libpwquality-1.4.0-1  libquvi-0.9.4-4  libquvi-scripts-0.9.20131130-3  libraw-0.18.6-1  libshout-1:2.4.1-3  libspectre-0.2.8-1  libspiro-1:0.5.20150702-1
                   libstemmer-0+337-2  libxxf86dga-1.1.4-1  libyaml-0.1.7-1  libytnef-1.9.2-2  libzapojit-0.0.3+11+g840627d-2  lua-5.3.4-2  lua52-5.2.4-2  lua52-bitop-1.0.2-8
                   lua52-expat-1.3.0-3  lua52-lpeg-1.0.1-1  lua52-luajson-1.3.4-1  lua52-socket-20160311-1  nautilus-3.26.2-2  nautilus-sendto-3.8.6-1  numix-icon-theme-1:0.r1974-1
                   oniguruma-6.7.0-1  openvpn-2.4.4-1  osinfo-db-20170813-1  pkcs11-helper-1.22-2  poppler-glib-0.61.1-1  pptpclient-1.9.0-1  protobuf-3.5.1.1-1  python-babel-2.5.1-1
                   python-docutils-0.14-1  python-imagesize-0.7.1-2  python-jinja-2.10-1  python-markupsafe-1.0-1  python-pygments-2.2.0-1  python-pytz-2017.3-1  python-snowballstemmer-1.2.1-2
                   python-sphinx-alabaster-theme-0.7.10-1  python-sphinx_rtd_theme-0.2.4-1  python-sphinxcontrib-websupport-1.0.1-1  python-sqlalchemy-1.2.1-1  python-whoosh-2.7.4-2
                   python-xdg-0.25-4  shared-color-targets-0.1.7-1  t1lib-5.1.2-6  taglib-1.11.1-1  telepathy-idle-0.2.0-2  telepathy-logger-0.8.2-2  telepathy-mission-control-5.16.4-2
                   totem-plparser-3.26.0-1  tracker-2.0.2-1  tracker-miners-2.0.3-1  vte3-0.50.2-1  wavpack-5.1.0-1  xf86dgaproto-2.1-3  xf86miscproto-0.9.3-1  xorg-appres-1.0.4-1
                   xorg-xmodmap-1.0.9-1  xorg-xrandr-1.5.0-1  zip-3.0-7  antergos-gnome-defaults-list-1.0-1  antergos-wallpapers-0.7-3  baobab-3.26.1-1  brasero-3.12.2-2  chrpath-0.16-1
                   dconf-editor-3.26.2-1  doxygen-1.8.13-3  eog-3.26.2-1  extra-cmake-modules-5.42.0-1  ffmpegthumbnailer-2.2.0-1  file-roller-3.26.2-1  gedit-3.22.1+1+gd21912e3e-1
                   gnome-backgrounds-3.26.2-1  gnome-calculator-3.26.0-1  gnome-calendar-3.26.2+19+g954c48d7-1  gnome-contacts-3.26+3+g643f622-1  gnome-disk-utility-3.26.2-1
                   gnome-documents-3.26.1-1  gnome-font-viewer-3.26.0-1  gnome-logs-3.26.2-1  gnome-maps-3.26.2-1  gnome-music-3.26.1-1  gnome-photos-3.26.3-1  gnome-screenshot-3.26.0-1
                   gnome-sound-recorder-3.24.0.1+8+g0b8e221-1  gnome-system-monitor-3.26.0+1+g97b9578d-1  gnome-terminal-3.26.2-1  gnome-tweak-tool-3.26.4-1  gnome-weather-3.26.0-1
                   go-pie-2:1.9.2-3  go-tools-2:1.9+2247+5d2fd3cc-1  gstreamer-vaapi-1.12.4-1  hunspell-de-20161207-1  hunspell-el-0.9-2  hunspell-en-2017.01.22-2  hunspell-es-1:2.2-1
                   hunspell-fr-6.0.2-1  hunspell-he-1.4-1  hunspell-hu-1.6.1-3  hunspell-it-2.4-5  hunspell-nl-2.10g-2  hunspell-pl-20171208-1  hunspell-ro-3.3.10-1  jq-1.5-5
                   libxxf86misc-1.0.3-2  network-manager-applet-1.8.11dev+7+ga52ccb2f-1  networkmanager-openvpn-1.8.1dev+10+ge4d8cda-2  networkmanager-pptp-1.2.4-3  numix-frost-themes-3.6.6-1
                   numix-icon-theme-square-1:0.r83_9-1  pamac-6.2.2-1  pavucontrol-3.0-4  polari-3.26.2-1  python-psutil-5.4.1-1  python-sphinx-1.6.5-2  qt5-styleplugins-5.0.0.20170311-4
                   qt5ct-0.34-2  totem-3.26.0+1+g4e309671-1  transmission-gtk-2.92-8  xdg-user-dirs-gtk-0.10+9+g5b7efc6-1  xf86-video-fbdev-0.4.4+12+ge0bce0d-1  xf86-video-vesa-2.3.4-4
                   xorg-iceauth-1.0.7-1  xorg-sessreg-1.1.1-1  xorg-smproxy-1.0.6-1  xorg-x11perf-1.6.0-1  xorg-xbacklight-1.2.1-1  xorg-xcmsdb-1.0.5-1  xorg-xcursorgen-1.0.6-1
                   xorg-xdpyinfo-1.3.2-1  xorg-xdriinfo-1.0.5-2  xorg-xev-1.2.2-1  xorg-xgamma-1.0.6-1  xorg-xinit-1.3.4-4  xorg-xinput-1.6.2-1  xorg-xkbevd-1.1.4-1  xorg-xkbutils-1.0.4-2
                   xorg-xkill-1.0.4-1  xorg-xlsatoms-1.1.2-1  xorg-xlsclients-1.1.3-1  xorg-xpr-1.0.4-2  xorg-xrefresh-1.0.5-1  xorg-xsetroot-1.1.1-2  xorg-xvinfo-1.1.3-1  xorg-xwd-1.0.6-1
                   xorg-xwininfo-1.1.3-1  xorg-xwud-1.0.4-2  xscreensaver-5.38-1
    
    Total Removed Size:  1135,05 MiB
    
    :: Do you want to remove these packages? [Y/n] n
    [[email protected] ~]$ 
    
    

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @izznogooood said in Meta what now!:

    sudo pacman -S $(LANG=C pacman -Si antergos-gnome-meta |sed -n ‘/Depends\ On/,/:/p’|sed ‘$d’|cut -d: -f2 |tr -d ‘>=[0-9]’) --needed --asexplicit

    right, because they are already installed.
    can you try the command bellow please?

    sudo pacman -D $(LANG=C pacman -Si antergos-gnome-meta |sed -n ‘/Depends\ On/,/:/p’|sed ‘$d’|cut -d: -f2 |tr -d ‘>=[0-9]’) --asexplicit
    

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @fernandomaroto said in Meta what now!:

    sudo pacman -D $(LANG=C pacman -Si antergos-gnome-meta |sed -n ‘/Depends\ On/,/:/p’|sed ‘$d’|cut -d: -f2 |tr -d ‘>=[0-9]’) --asexplicit

    [[email protected] ~]$ sudo pacman -D $(LANG=C pacman -Si antergos-gnome-meta |sed -n ‘/Depends\ On/,/:/p’|sed ‘$d’|cut -d: -f2 |tr -d ‘>=[0-9]’) --asexplicit
    sed: -e expression #1, char 1: unknown command: `�'
    sed: -e expression #1, char 1: unknown command: `�'
    [sudo] password for anders: 
    [[email protected] ~]$
    

    There’s an error so I aborted… Thanks guys I appreciate the help. This is not the end of the world, I just learned I am not a fan of meta-packages ;).

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @izznogooood

    The site formated the text.
    sudo pacman -D $(LANG=C pacman -Si antergos-gnome-meta |sed -n '/Depends\ On/,/:/p'|sed '$d'|cut -d: -f2 |tr -d '>=[0-9]') --asexplicit

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • Bingo!

    [[email protected] ~]$ sudo pacman -D $(LANG=C pacman -Si antergos-gnome-meta |sed -n '/Depends\ On/,/:/p'|sed '$d'|cut -d: -f2 |tr -d '>=[0-9]') --asexplicit
    [sudo] password for anders: 
    Sorry, try again.
    [sudo] password for anders: 
    antergos-gnome-defaults-list: install reason has been set to 'explicitly installed'
    baobab: install reason has been set to 'explicitly installed'
    brasero: install reason has been set to 'explicitly installed'
    evince: install reason has been set to 'explicitly installed'
    eog: install reason has been set to 'explicitly installed'
    file-roller: install reason has been set to 'explicitly installed'
    gedit: install reason has been set to 'explicitly installed'
    gnome-backgrounds: install reason has been set to 'explicitly installed'
    gnome-calculator: install reason has been set to 'explicitly installed'
    gnome-calendar: install reason has been set to 'explicitly installed'
    gnome-contacts: install reason has been set to 'explicitly installed'
    gnome-control-center: install reason has been set to 'explicitly installed'
    gnome-documents: install reason has been set to 'explicitly installed'
    gnome-disk-utility: install reason has been set to 'explicitly installed'
    gnome-font-viewer: install reason has been set to 'explicitly installed'
    gnome-keyring: install reason has been set to 'explicitly installed'
    gnome-logs: install reason has been set to 'explicitly installed'
    gnome-maps: install reason has been set to 'explicitly installed'
    gnome-music: install reason has been set to 'explicitly installed'
    gnome-photos: install reason has been set to 'explicitly installed'
    gnome-screenshot: install reason has been set to 'explicitly installed'
    gnome-shell: install reason has been set to 'explicitly installed'
    error: could not set install reason for package gnome-shell-extensions (could not find or read package)
    error: could not set install reason for package gnome-shell-extension-dash-to-dock (could not find or read package)
    error: could not set install reason for package gnome-shell-extension-status-menu-buttons (could not find or read package)
    gnome-sound-recorder: install reason has been set to 'explicitly installed'
    gnome-system-monitor: install reason has been set to 'explicitly installed'
    gnome-terminal: install reason has been set to 'explicitly installed'
    gnome-themes-standard: install reason has been set to 'explicitly installed'
    gnome-tweak-tool: install reason has been set to 'explicitly installed'
    gnome-weather: install reason has been set to 'explicitly installed'
    gvfs-google: install reason has been set to 'explicitly installed'
    gvfs-mtp: install reason has been set to 'explicitly installed'
    gvfs-smb: install reason has been set to 'explicitly installed'
    hicolor-icon-theme: install reason has been set to 'explicitly installed'
    libgnome-keyring: install reason has been set to 'explicitly installed'
    nautilus: install reason has been set to 'explicitly installed'
    network-manager-applet: install reason has been set to 'explicitly installed'
    networkmanager-openvpn: install reason has been set to 'explicitly installed'
    networkmanager-pptp: install reason has been set to 'explicitly installed'
    pamac: install reason has been set to 'explicitly installed'
    polari: install reason has been set to 'explicitly installed'
    python-pysmbc: install reason has been set to 'explicitly installed'
    error: could not set install reason for package qtct (could not find or read package)
    seahorse: install reason has been set to 'explicitly installed'
    totem: install reason has been set to 'explicitly installed'
    transmission-gtk: install reason has been set to 'explicitly installed'
    xdg-user-dirs-gtk: install reason has been set to 'explicitly installed'
    xscreensaver: install reason has been set to 'explicitly installed'
    [[email protected] ~]$ sudo pacman -Rns $(pacman -Qtdq)
    checking dependencies...
    
    Packages (81) dmxproto-2.3.1-3  gtk-engine-murrine-0.98.2-2  hunspell-en_GB-2017.01.22-2  hunspell-en_US-2017.01.22-2  libdmx-1.1.3-1  libxxf86dga-1.1.4-1  numix-icon-theme-1:0.r1974-1
                  oniguruma-6.7.0-1  python-babel-2.5.1-1  python-docutils-0.14-1  python-imagesize-0.7.1-2  python-jinja-2.10-1  python-markupsafe-1.0-1  python-pygments-2.2.0-1
                  python-pytz-2017.3-1  python-snowballstemmer-1.2.1-2  python-sphinx-alabaster-theme-0.7.10-1  python-sphinx_rtd_theme-0.2.4-1  python-sphinxcontrib-websupport-1.0.1-1
                  python-sqlalchemy-1.2.1-1  python-whoosh-2.7.4-2  xf86dgaproto-2.1-3  xf86miscproto-0.9.3-1  xorg-xmodmap-1.0.9-1  xorg-xrandr-1.5.0-1  antergos-wallpapers-0.7-3  chrpath-0.16-1
                  dconf-editor-3.26.2-1  doxygen-1.8.13-3  extra-cmake-modules-5.42.0-1  ffmpegthumbnailer-2.2.0-1  go-pie-2:1.9.2-3  go-tools-2:1.9+2247+5d2fd3cc-1  gstreamer-vaapi-1.12.4-1
                  hunspell-de-20161207-1  hunspell-el-0.9-2  hunspell-en-2017.01.22-2  hunspell-es-1:2.2-1  hunspell-fr-6.0.2-1  hunspell-he-1.4-1  hunspell-hu-1.6.1-3  hunspell-it-2.4-5
                  hunspell-nl-2.10g-2  hunspell-pl-20171208-1  hunspell-ro-3.3.10-1  jq-1.5-5  libxxf86misc-1.0.3-2  numix-frost-themes-3.6.6-1  numix-icon-theme-square-1:0.r83_9-1
                  pavucontrol-3.0-4  python-psutil-5.4.1-1  python-sphinx-1.6.5-2  qt5-styleplugins-5.0.0.20170311-4  qt5ct-0.34-2  xf86-video-fbdev-0.4.4+12+ge0bce0d-1  xf86-video-vesa-2.3.4-4
                  xorg-iceauth-1.0.7-1  xorg-sessreg-1.1.1-1  xorg-smproxy-1.0.6-1  xorg-x11perf-1.6.0-1  xorg-xbacklight-1.2.1-1  xorg-xcmsdb-1.0.5-1  xorg-xcursorgen-1.0.6-1
                  xorg-xdpyinfo-1.3.2-1  xorg-xdriinfo-1.0.5-2  xorg-xev-1.2.2-1  xorg-xgamma-1.0.6-1  xorg-xinit-1.3.4-4  xorg-xinput-1.6.2-1  xorg-xkbevd-1.1.4-1  xorg-xkbutils-1.0.4-2
                  xorg-xkill-1.0.4-1  xorg-xlsatoms-1.1.2-1  xorg-xlsclients-1.1.3-1  xorg-xpr-1.0.4-2  xorg-xrefresh-1.0.5-1  xorg-xsetroot-1.1.1-2  xorg-xvinfo-1.1.3-1  xorg-xwd-1.0.6-1
                  xorg-xwininfo-1.1.3-1  xorg-xwud-1.0.4-2
    
    Total Removed Size:  603,40 MiB
    
    :: Do you want to remove these packages? [Y/n] n
    [[email protected] ~]$
    

    I’ll figure out which second meta I removed through bash-history and apply the same cmd.

    There are mad pacman / sed skillz in this community, thanks guys!

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @izznogooood said in Meta what now! (Removing meta package orphans meta packages):

    There are mad pacman / sed skillz in this community, thanks guys!

    hehehe, i do a lot of trials and errors here, sometimes usefull stuff pops up.
    I’m glad you fix your issue 😛

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

Posts 15Views 378
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.