• Locale problems after install


    Hi!

    Thats my first post here, I am new to Antergos and i’d like to tell about the problem I encountered during my first install.

    For starters, I do not consider myself as IT pro, and I had only very limited experience with Linux in my life.

    I did followed all the install steps in cnchi and successfully installed Antergos on t470s from the first time. During install I chose my country -Russia and Russian as language (its increadebly silly, i’d never do that 10 years ago, but I guess I got too lazy). But after install I could not log in to the system, it kept telling me that the password is wrong.

    Long story short, (after I changed root and users passwds from live os USB several times) it turned out that my password was right, but cnchi build me a system without any kind of Latin language/keyboard, and I simply couldn’t type it in. It took me about 3 hours to find and fix the problem during witch I learned a lot about how Linux handle languages in general, but it is not an expirience for light hearted, without en_UTF-8 every output from cli i got was broken fonts, no reading "man"s, even nano interface was broken.

    I see here several points for improvement:

    Cnchi should not let user configure system without at least some kind of English/Latin.

    In the login window there is no way to tell what you are typing, no option to reveal password no indicator of language.

    Hope this would be of help
    Cheers)

  • @i6mael
    Hi!
    That’s known by @developers, i’m sure they’re working on it.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • The only solution for that is, always install as English. And never use locale chars in passwords.

    I NEVER install in another language, because after the install, it’s time to configure everything.

    Any message or any thing you have to search the web for help, if it’s in English, you’re probably ok. If it’s in another language… good luck!

    So the password should always be like this: mYp…w0r8!

    This chars are present in the same location in most keyboards and you should check those in the Russian keyboard. But in the install you should pick a simple password for root and user.

    I might install Antergos in Portuguese again soon, because once I did it and had so many problems, I spend a week trying to forget those. Now I can’t remember what it was.

  • @casquinhas said in Locale problems after install:

    I might install Antergos in Portuguese again soon

    i had no problem with portuguese install.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @fernandomaroto I’m installing it now. Oracle VBOX has that strange problem that installs Antergos to the end, no problems and then, reboot and soon as kernel starts, stops working and says it has a problem.

    Since I did not figure out what is the problem, I installed Boxes that is a virtualization program and already installed Antergos in English and reboot and it WORKS!

    Now, onto Portuguese install… brb.

    Ok, looks that Boxes is a bit slower than VBOX but since it works, who cares!!!

  • @casquinhas said in Locale problems after install:

    Oracle VBOX has that strange problem that installs Antergos to the end, no problems and then, reboot and soon as kernel starts, stops working and says it has a problem

    for VBox you need to be sure to install everything it needs.
    If you install virtualboc with dkms, you should also install dkms and linux-headers (or linux-lts-headers for LTS kernel)
    Also be sure not to install host-dkms if you’re running as guest, nor guest-dkms if you’re running as host.

    I don’t like Boxes, i faced many problems like installed systems with no sound, no internet etc.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @fernandomaroto said in Locale problems after install:

    @casquinhas said in Locale problems after install:

    I might install Antergos in Portuguese again soon

    i had no problem with portuguese install.

    The Portuguese with Portuguese (not Brasilian) keyboard, installed the English keyboard.
    And many string are not translated, so there’s work to do. Do you know who’s translating it to Portuguese or how to do it? I also could do some, that are pretty easy to do and should be translated.

    But the install went straight forward, with no more issues this time. Boxes is slow but works. (seen some replies to fix VBOX problems, so let me check that out).

  • @fernandomaroto said in Locale problems after install:

    @casquinhas said in Locale problems after install:

    Oracle VBOX has that strange problem that installs Antergos to the end, no problems and then, reboot and soon as kernel starts, stops working and says it has a problem

    for VBox you need to be sure to install everything it needs.
    If you install virtualboc with dkms, you should also install dkms and linux-headers (or linux-lts-headers for LTS kernel)
    Also be sure not to install host-dkms if you’re running as guest, nor guest-dkms if you’re running as host.

    I don’t like Boxes, i faced many problems like installed systems with no sound, no internet etc.

    Decided to remove VirtualBox first and install again… and now works.
    Now I don’t know what was the problem! LOL!
    Anyway thanks for the tip but I could not use or verify if it works.
    Well, I’m happy it works, it’s faster than Boxes, that I will keep here just in case… hehehehhee

  • @casquinhas said in Locale problems after install:

    Do you know who’s translating it to Portuguese or how to do it?

    No idea! About language problem may be related with a tip i gave to @karasu to add english support, but maybe he set english before portuguese… In this case its worth you check the file /etc/X11/xorg.conf.d/00-keyboard.conf
    i suspect your is Option "XkbLayout" "us,pt"

    If it’sOption "XkbLayout" "us" then something is very wrong!

    @karasu, i guess the english layout should come first for non latin keyboards only… (to prevent those login problems)

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • [[email protected] xorg.conf.d]$ cat /etc/X11/xorg.conf.d/00-keyboard.conf

    Written by systemd-localed(8), read by systemd-localed and Xorg. It’s

    probably wise not to edit this file manually. Use localectl(1) to

    instruct systemd-localed to update it.

    Section "InputClass"
    Identifier "system-keyboard"
    MatchIsKeyboard "on"
    Option “XkbLayout” "us"
    EndSection
    [[email protected] xorg.conf.d]$

    And it’s read-only. Nice. But I always install on my machines the English keyboard and language. Then I change to PT if I want it by:

    setxkbmap -layout pt

    But on my VM installed where I choose Portuguese, it’s PT:

    Option “XkbLayout” “pt”

    But I open Terminal and it’s English. Go figure.

  • @casquinhas
    Do you mean the interface is english?

    ok, so you can check:
    /etc/locale.conf
    /etc/locale.gen

    *if you need to change these above after you’ll need to run:
    sudo locale-gen

    for keyboard just in case:
    /etc/vconsole.conf

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • [[email protected] etc]# cat locale.conf
    LANG=en_US.UTF-8
    LC_COLLATE=en_US.UTF-8
    [[email protected] etc]# cat locale.gen|grep -v "#"
    en_US.UTF-8 UTF-8
    [[email protected] etc]# locale-gen
    Generating locales…
    en_US.UTF-8… done
    Generation complete.
    [[email protected] etc]# cat vconsole.conf
    KEYMAP=pt
    [[email protected] etc]#

    Reboot but keyboard stays in EN. I set PT keyboard with:

    [[email protected] etc]# setxkbmap pt
    [[email protected] etc]# çãó

    Notice some Portuguese chars after the setxkbmap. Works but not on reboots.

  • @casquinhas said in Locale problems after install:

    [[email protected] etc]# cat locale.conf
    LANG=en_US.UTF-8
    LC_COLLATE=en_US.UTF-8
    [[email protected] etc]# cat locale.gen|grep -v "#"
    en_US.UTF-8 UTF-8

    those should be portuguese too
    cat locale.gen
    pt_BR.UTF-8 UTF-8

    cat /etc/locale.conf
    LANG=pt_BR.UTF-8
    LC_COLLATE=pt_BR.UTF-8

    You’ll need to change to your portuguese country
    you can check the wiki https://wiki.archlinux.org/index.php/Locale

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

locale7 Posts 13Views 376
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.