• Grub Problem

    OK, it may work now, you can reboot without the stick.

  • And if it doesn’t still work, can you get the BIOS see the boot options as before?

  • @manuel
    it works! thank you a lot !
    i have antergos in the efi options but i dont have memtest
    and i don’t have windows in grub options

  • @oussama.ah95
    Great to hear!

    But I just noticed one issue with the grub-install command you just did.
    You probably can fix it with a single command (in normal boot, no USB):

    sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=antergos_grub

    There was one too many efi word… sorry about that (shouldn’t work so late…). This command should fix the Windows in the grub (famous last words… ;)).

  • @manuel
    but the last command didnt fix the windows

  • @oussama.ah95

    Strange. But we are not without ideas just yet…
    You can write a file /boot/grub/custom.cfg with the following contents:

    menuentry "Windows" {
      set file=/EFI/Microsoft/Boot/bootmgfw.efi
      insmod fat
      search --set=root --file $file
      chainloader $file

    It should give a new boot GRUB entry “Windows”, and selecting that should boot to Windows.

  • Sorry, I must go now. But if you have more issues, I’ll be here tomorrow. And others can help you, too. :)

  • @manuel thank you manuel :D
    I’ll try to add the windows entry

    i have an other question how can i add memtest to the efi boot options like we did to antergos ?

  • @manuel and do you know why i have 2 EFI folders?
    one with only antergos and the other with the EFI options that i had before setting the bios to default ?
    Could we load the bios menu with tje forst EFI folder that contains all my previous bios entry?

  • @oussama.ah95
    I think you can safely delete E:\EFI\EFI folder.
    You could still check that folders E:\EFI\antergos_grub and E:\EFI\EFI\antergos_grub have about the same files.

    It was created in the first attempt of grub-install command, the line had option --efi-directory=/boot/efi/EFI.
    The second grub-install attempt put grub’s efi info into the right place (into /boot/efi).

    Oh, and now you should do

    sudo grub-mkconfig -o /boot/grub/grub.cfg

    in your existing Antergos install. I was too tired yesterday to notice you still need to do that to have Windows in Antergos’s boot menu.

    EDIT: Seems that memtest is not enabled by default, and TBH I’ve never used it in Antergos. There is a memtest86+ package in official repos, and memtest86-efi in AUR packages. Maybe one of them would work (although please note that AUR packages are not officially supported and are made by any user that wants to offer a package).

  • @manuel
    Thank you manuel , you saved me!

    i deleted mentest and i reinstalled it and i can find it in the efi options now :D

  • @oussama.ah95
    Thanks and great to hear it works now!
    And if you feel this is solved, could you please mark the thread as such, with a button below. :)

  • @manuel unfortunately, i started windows 10 then i shutdown my pc.
    After 2 hours i wanted to log in with antergos but suddenly my pc boots automatically to windows. I entered to the bios menu to change the order but i didn"t found the antergos_grub and memtest86 again :( .
    I have only windows boot manager, do i have to mount it everytime i start windows 10 ?

  • @oussama.ah95
    Hmm… What is your machine’s exact model?

    It is a known fact that e.g. some HP machines tend to boot only to Windows unless some trick is used to work around that.

  • @manuel

    lenovo ideapad 500-15isk i7-6500u

  • This post is deleted!
  • @manuel I think that the bios doesn’t load files from the correct location because when i fix it last time it didn’t load memtest so i had to delete it and reinstall it to find it in efi boot options

  • @oussama.ah95
    It may be that Windows or Lenovo somehow deletes external boot files (mainly *.efi files) from the EFI partition, that would explain why Antergos boot stuff disappears after a reboot or shutdown.

    Can you check what files there currently are under E:\EFI, and are they now different from the time when Antergos was working OK?

  • @manuel
    i’ve already checked


grub127 Posts 62Views 3037
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.