• Grub Problem


    Hello,

    I entred to BIOS menu and clicked to load default options and after that my pc logs automatically to Windows 10.

    I re-entered to BIOS to change boot menu but i didnt find antergos_grub anymore.
    I logged to W10 and i did diskpart and assigned to boot partition (FAT) to E: and i found that there is a folder called antergos_grub but i dont find it in grub.

    Help me please.

  • @oussama.ah95 Are Antergos and windows on the same disk or separate disks?

  • @Janxinz On the same disk, i had antergos with windows 10 (dual boot)

  • @oussama.ah95 When you open BIOS and select boot order does it show your separate partitions?

  • @Janxinz now it shows me only one option, but before loading the optimized options i had 2 options
    1)antergos_grub
    2)windows 10

    i forget to mention that upgrated windows today i found in the net that windows could be the reason

  • @oussama.ah95 If you go to Disk management in Windows and look at your partition, does antergos partition have a disk letter assigned to it? Your Windows is identified as E: according to your post.

  • @oussama.ah95 My apologies for asking one liners, Im just trying to rule out variables. I had similar problem when I did my first dual boot 🙂

  • @Janxinz , no antergos doesnt have a letter assigned to it
    i followed this to tutorial to check if my grub were deleted or not and i assigned the EFI partition to E:
    windows letter is 😄
    http://linuxbsdos.com/2015/09/05/how-to-delete-grub-files-from-a-boot-efi-partition-in-windows-10/

  • @oussama.ah95 So now you have an EFI partition that has no grub loader folder in it? That may be why it isnt showing up in your boot options. I recommend re-installing from USB.

    1. Install Antergos
    2. Once complete restart and disconnect USB
    3. Go into BIOS and re-order boot order to be:
      antergos_grub
      windows 10
    4. Save & Exit then see if it loads up grub
    5. Select Antergos and when you are logged in open a terminal and run:
      sudo grub-mkconfig -o /boot/grub/grub.cfg (Shout out to @manuel for helping me with this) this will allow you to select windows from grub menu on boot

    If you dont want to re-install we can try something else.

  • @Janxinz thanks you but i don’t want to re-install it i have many softwares installed …

  • Im thinking you need to copy all of the /boot/ and sub-folders and files to target partition (EFI E: for grub) then reboot and see if it shows up again in BIOS.

  • @oussama.ah95
    Hi there!
    Could you show the output of command:

    lsblk -f
    

    You can do it by booting with the USB stick and running that command in the terminal.
    Later (during the “stick” boot) could you please show the output of:

    mount /dev/sda1 /mnt  # change /dev/sda1 to be your EFI partition!
    find /mnt/boot -iname \*.efi -exec ls -l {} \;
    

    The EFI partition is the one with vfat FSTYPE.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel

    NAME   FSTYPE  LABEL       UUID                                 MOUNTPOINT
    loop0  squashf                                                  /run/archiso/sfs
    sda                                                             
    ├─sda1 ntfs    Recovery    B61008B310087C9D                     
    ├─sda2 vfat                560B-8395                            
    ├─sda3                                                          
    ├─sda4 ntfs                8A9814B49814A0AD                     
    ├─sda5 ntfs                124E2EFD4E2ED8ED                     
    ├─sda6 ntfs    Nouveau nom CCF008FFF008F18E                     
    ├─sda7 swap                1ef84f7a-825a-4dcb-abcf-70e9e229df6c 
    ├─sda8 ext4                cd5cb14d-1872-4fe3-8d66-56992a506015 
    └─sda9 ext4                f94620b6-8ec3-46b7-9ce9-74f70242fc15 
    sdb                                                             
    └─sdb1 vfat    ANTERGOS    1A13-2C2E                            /run/archiso/boosr0                                                             
    
    

    in my case the commands you gave could fix the problem ?

  • @Janxinz thanks, reinstalling is easier than copying with wiindows commands

  • @oussama.ah95
    No, it just shows what you have currently.
    And you partition seems to be /dev/sda2.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel
    the output of the second command

    find /mnt/boot -iname \*.efi -exec ls -l {} \;
    find: ‘/mnt/boot’: No such file or directory
    
    
  • @oussama.ah95
    Did you run these both commands:

    mount /dev/sda2 /mnt
    find /mnt/boot -iname \*.efi -exec ls -l {} \;
    

    Maybe you need to add sudo in front of the first command…

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel
    yes i did it with su
    but the second fails

  • @oussama.ah95
    Before setting the bios to default i had memtest in boot entry too but now i dont have it

  • @oussama.ah95
    So what does the following show:

    mount /dev/sda2 /mnt  # if not done already
    ls -la /mnt/boot
    

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

grub103 Posts 62Views 1579
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.