• @fernandomaroto
    Thanks, it was in root-image/etc/systemd/system. But maybe Joe’s changes fix the issue.

    @joekamprad
    OK, I’ll wait a bit. Probably will test tomorrow, if that’s OK for you. ;)

  • build.sh:

    # Enable services
            mkarchiso ${verbose} -w "${work_dir}" -C "${pacman_conf}" -D "${install_dir}" \
                -r 'systemctl -fq enable pacman-init NetworkManager livecd vboxservice NetworkManager-wait-online systemd-networkd' run
    
  • @manuel do what ever you want to do !!! this is free and open source ;)

  • @joekamprad Nice! already building it with my script… :)
    (Virtual machines are so useful…)

    EDIT: the same error as before, maybe my script has a problem…

    1. try is working nicely! testing it right now…
      0_1515957762724_Screenshot from 2018-01-14 19-22-18.png
  • @joekamprad
    Now a new error:

    error: target not found: usb-utils
    

    And here are the last lines before error:

    >>> Installing packages from /home/me/github-tools/builddir/antergos-rescue/packages/30-system.packages...
    
    [mkarchiso] INFO: Configuration settings
    [mkarchiso] INFO:                   Command:   install
    [mkarchiso] INFO:              Architecture:   x86_64
    [mkarchiso] INFO:         Working directory:   work
    [mkarchiso] INFO:    Installation directory:   arch
    [mkarchiso] INFO:        Pacman config file:   work/pacman.conf
    [mkarchiso] INFO:                  Packages:   expect git gksu pamac pkgfile powerpill reflector sudo unrar unzip wget xdg-user-dirs-gtk xz glances htop partimage grsync rsync deja-dup python2-boto memtest86+ inxi hddtemp usb-utils mesa-demos xorg-xrandr file lm_sensors xsensors ddrescue testdisk
    
    [mkarchiso] INFO: Installing packages to 'work/root-image/'...
    ==> Creating install root at work/root-image
    ==> Installing packages to work/root-image
    :: Synchronizing package databases...
     antergos is up to date
     core is up to date
     extra is up to date
     community is up to date
     multilib is up to date
    warning: xz-5.2.3-1 is up to date -- skipping
    warning: memtest86+-5.01-2 is up to date -- skipping
    error: target not found: usb-utils
    warning: file-5.32-1 is up to date -- skipping
    ==> ERROR: Failed to install packages to new root
    
  • @manuel said in antergos :rescue the antergos swiss-knive live-iso:

    Now a new error:
    error: target not found: usb-utils

    sorry i was tinkering again at the moment… usb-utils do not exist as a package :(

  • @joekamprad No problem. Are you doing something major now, should I wait? :)

  • I try to add memtest boot entry… but i think it will need some more configuration…
    today is over 📆 i can not read more code today ;)

  • This is great. The live start on Antergos (might Arch and others), has a small partition and it’s hard to increase that.

    It’s really important to have a RESCUE dedicated solution, because I needed this weekend as I f##cked my Antergos install, when I was “playing” with grub and boot and EFI stuff.

    Yes, sh!t. It was bad, boot gone, so no booting. Started live Antergos, I was able to read the partition, so I copied all my data out to another hard drive, including photos, videos, my Thunderbird POP3 mails, etc.

    Then I messed it even more, but I don’t remember how. It was totally screwed. I did enjoy running “testdrive” (recovery program) and a few other tools and recovering all files, like in a real disaster.

    Anyway, last two weeks I had also recovered a few hard drives, those with real hard disk sector errors and I did recover some info on a few. One HD could not even be recognized, so no luck on the most important of all.

    “testdrive” is important to backup the data into an image and then work on the image, not the failed hd.

    So sh!t happens. Yes, I had no backup because I like to live on the edge. Crazy me.

  • @casquinhas said in antergos :rescue the antergos swiss-knive live-iso:

    This is great. The live start on Antergos (might Arch and others), has a small partition and it’s hard to increase that.

    Do you mean cow_spacesize?

  • @joekamprad
    Just for fun tried to build antergos-rescue again, but seems that you didn’t yet finish your changes.
    Anyway, the output just before the error was:

    [mkarchiso] INFO: Packages installed successfully!
    
    [mkarchiso] INFO: Configuration settings
    [mkarchiso] INFO:                   Command:   run
    [mkarchiso] INFO:              Architecture:   x86_64
    [mkarchiso] INFO:         Working directory:   work
    [mkarchiso] INFO:    Installation directory:   arch
    [mkarchiso] INFO:               Run command:   mkinitcpio -c /etc/mkinitcpio-archiso.conf -k /boot/vmlinuz-linux -g /boot/archiso.img
    
    ==> Starting build: 4.14.13-1-ARCH
      -> Running build hook: [base]
      -> Running build hook: [udev]
      -> Running build hook: [archiso]
      -> Running build hook: [block]
    ==> WARNING: Possibly missing firmware for module: aic94xx
    ==> WARNING: Possibly missing firmware for module: wd719x
      -> Running build hook: [keyboard]
    ==> Generating module dependencies
    ==> Creating xz-compressed initcpio image: /boot/archiso.img
    bsdcpio: Failed to set default locale
    ==> Image generation successful
    >>> Mkinitcpio done!
    
    [mkarchiso] INFO: Configuration settings
    [mkarchiso] INFO:                   Command:   run
    [mkarchiso] INFO:              Architecture:   x86_64
    [mkarchiso] INFO:         Working directory:   work
    [mkarchiso] INFO:    Installation directory:   arch
    [mkarchiso] INFO:               Run command:   systemctl -fq enable pacman-init NetworkManager livecd vboxservice NetworkManager-wait-online systemd-networkd
    
    Failed to enable unit, unit pacman-init.service does not exist.
    

    Hope that helps. :)

  • @manuel i will see if unit is available inside started liveiso.
    As i can build here completely without this error…

  • @joekamprad
    Then it is possible that my script has some error… I’m using the same script that I sent here yesterday.

  • @manuel my log shows:

    
    [mkarchiso] INFO: Configuration settings
    [mkarchiso] INFO:                   Command:   run
    [mkarchiso] INFO:              Architecture:   x86_64
    [mkarchiso] INFO:         Working directory:   work
    [mkarchiso] INFO:    Installation directory:   arch
    [mkarchiso] INFO:               Run command:   systemctl -fq enable pacman-init 
    
  • @joekamprad
    Do you have a script that you use for building all of this, including the cloning of github repos? I could compare it to mine…

  • No i do it manual, as this are only some easy steps…
    But may take a look to antergos-iso master and the build.sh there it includes this inside
    https://github.com/Antergos/antergos-iso/blob/master/configs/antergos/build.sh

Posts 341Views 20324
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.