• antergos :rescue the antergos swiss-knive live-iso


    @joekamprad
    I know VM is not sensible for using it, but can be used for some testing.
    Maybe I dare to test it on my main machine… 😱 ☠

  • @joekamprad said in antergos :rescue the antergos swiss-knive live-iso:

    EFI bootscreen has no opptions to choose lang and keys at all, and on Bios you need to choose keyboard first then it works… but i just start to get into this (it should be enhance for main ISO also)

    On issues with VirtualMachines: i think as the rescue ISO makes no real sence running inside a VM, i will not care about issues related to VM ;)

    Of course not everybody has a spare laptop or desktop. I do have one that I can test this but it’s still important to test it on a VM. Sometimes I do it also on VM’s but lately I’ve been using only real hardware because it’s a computer I can look on and use a keyboard. I can put it to install shit and continue to use my main laptop.
    I’ve installed in the last days Solus, Antergos, Antergos::rescue and CentOS. I take not on things that do not work on one and test on another. And this old Toshiba with less than 2gb of ram and a strange ATI Radeon, is perfect to stress anything you want. Nvidia? Nahh, that’s for kids. Real men use ATI because on the first wrong key, it puts you on fire.

    Hehehhe… well, it’s kinda late here now, 22:55 so tomorrow I’ll download it with a cable, not on wifi where I’m now, because I finally connected my Draytek and I don’t have an extra networking cable. Love this Draytek 2830n.

    In Portugal my ISP now has routers that the configuration is not on 192.168.1.1… no, they think it’s better to logon on their website, use a webpage that is on their server to configure my router at home. This is very strange because these guys are really good at internet shit and things, and now they make this crap, I don’t understand.

    So the ISP router is now only used to bring internet home and connects to the Draytek, where I can configure all the crap I need.

    By the way, almost forgot, tried to recover an SSD from a friend today with ::rescue and it did not worked.

    Lol I was not going to write anything else about it but of course it was not ::rescue problem. The SSD is really dead, dead as it can be, not even smartinfo it read on it. It’s a brick now. And he runs a coffee shop… no backups.

    About a month ago, I warned him again, let’s do a backup plan, Veeam Endpoint Backup doing backups everyday and maybe Cobian for the database and send it to my remote server. I have this solution working on several sites, for years now working with a few disasters and recovery’s done.

    Have you ever heard about KingFast SSD drives? 2 years and a few months, an SSD dead. Wow.

  • @manuel said in antergos :rescue the antergos swiss-knive live-iso:

    @joekamprad
    I know VM is not sensible for using it, but can be used for some testing.
    Maybe I dare to test it on my main machine… 😱 ☠

    No. Please no. Don’t. You will get a virus. The distro hop virus.

    But if you do it, you’re welcome to join the “Distro Hop Anonymous” aka DHA to help you on the recovery.

  • @casquinhasjr
    I’m already in Antergos Anonymous (AA)… ;)

  • My identity is identified and validated by all data octopi.
    BUT may it is pure Science-Fiction ?

  • there are some config refreshes on serverside… will be done in 60 Minutes

  • side is up again and a new beta release is uploading also:

    http://antergos.kamprad.net/antergos-rescue/release/antergos-rescue-2018-4-27-X-x86_64.iso
    http://antergos.kamprad.net/antergos-rescue/release/antergos-rescue-2018-4-27-X-x86_64.sha512

    Includes NOW

    • inxi
    • custom cfg generator from @manuel
    • Antergos installer from menu not autostarting anymore!
    • WIKI is starting per default (needs to figure out how to remove tis asking to create a password, or using another browser
    • desktop files (custom starter) needs some adjustment
    • menu is fine but too big
  • @joekamprad said in antergos :rescue the antergos swiss-knive live-iso:

    http://antergos.kamprad.net/wiki/doku.php?id=custom_grub_cfg_generator

    antergos-customcfg @manuel

    Me like a lot the wiki. Pretty nice. Well, only download the ISO now, putting it onto my work horse pen now to test it tomorrow and see how it goes. It will be on the Toshiba with 2 gigs of slow RAM and a hot Core i5 or i3, I don’t really know what processor is hosted there and I don’t care too.
    The only thing I know is that I cannot wait to get my hands on a Thinkpad like T400, T410, T420 or T430 to finally have some peace and silence.
    No more Asus, Toshiba, Acer, anything! Except Lenovo Thinkpads. So tired of this Acer too, damn it. What a crap.
    Well, work day tomorrow so, I’ll be doing my way.
    Just heard now a video I’m watching talk about Cubes… I cannot install Cubes on any laptop, except the Thinkpad R61 I have. But that is being used by my current wife. So I have to get a Thinkpad for my own pleasure.

  • @casquinhas said in antergos :rescue the antergos swiss-knive live-iso:

    But that is being used by my current wife. So I have to get a Thinkpad for my own pleasure.

    😂

    https://www.dokuwiki.org/dokuwiki

    I was searching a lot and testing many but dokuwiki is very slick and minimalistic, and also after using it, i find it is used a lot over the net…

    The only strange thing is that you need to create a link in an existing artikel to create a new one… but there is surely an extension to get this working…

  • @joekamprad wow, that wiki looks nice. That’s what we need, simple, easy to edit and small footprint, without a database is even better.
    Just have my pen recorded and ready to boot up tomorrow:

    [[email protected] Downloads]# dd bs=1M oflag=sync status=progress of=/dev/sdd if=antergos-rescue-2018-4-27-X-x86_64.iso 
    1557135360 bytes (1.6 GB, 1.5 GiB) copied, 200 s, 7.8 MB/s 
    1490+1 records in
    1490+1 records out
    1563197440 bytes (1.6 GB, 1.5 GiB) copied, 200.981 s, 7.8 MB/s
    [[email protected] Downloads]# sync
    [[email protected] Downloads]# eject /dev/sdd
    

    The way I love it, using dd that is “copy and convert” that is CC plus one alphabetic letter.

    Hum, I was thinking about something, I’m cracking the shit out of Antergos on the laptop, so I could use some tools in a “real” disaster. Believe me, I’m good at crashing stuff without any possibility of a clean return.

    This way it will be fun. Let me sleep over it. I can do so much… “rm -R” can do wonderful things… and if this do not work, I will install “Internet Explorer”. That’s pretty much the same as remove the cpu fan and smash the cpu with a drill on steroids.

    Like the President of California used to say ‘I’ll be back’.

  • 0_1524953274774_Bildschirmfoto vom 2018-04-29 00-07-45.png
    👆🏼
    this is a funny person!

  • Just a thought… I installed Deepin a while ago (the full distro), and they are adding such a rescue boot to grub. It’s basically a rescue CD in squashfs format on your drive that is set to use a separate (known stable) kernel. That way you can always boot the rescue directly from your harddrive without having to burn some iso or wait forever for the rescue to load. And easy to update with new versions, just replace the squashfs and kernel files. Would be awesome to see something like that come as standard in the antergos installer!

  • @stingray454
    Something quite similar can be done by saving the downloaded Antergos ISO file to a directory, e.g. /ISO, and writing the following contents to file /boot/grub/custom.cfg:

    menuentry 'Boot from file antergos-18.4-x86_64.iso' {
        set isofile=/ISO/antergos-18.4-x86_64.iso
        search --no-floppy --set=root --file $isofile
        probe -u $root --set=uuid
        set img_dev=/dev/disk/by-uuid/$uuid
        loopback loop $isofile
        linux (loop)/arch/boot/vmlinuz img_dev=$img_dev img_loop=$isofile
        initrd (loop)/arch/boot/archiso.img
    }
    

    Now when you reboot, you’ll have a new entry and may select it to boot to the ISO installer.

  • @joekamprad said in antergos :rescue the antergos swiss-knive live-iso:

    just build a new rescue_: ISO including latest cnchi by default… and latest kernel python e.t.c…

    http://antergos.kamprad.net/antergos-rescue/release/antergos-rescue-2018-4-29-x86_64.iso
    http://antergos.kamprad.net/antergos-rescue/release/antergos-rescue-2018-4-29-x86_64.sha512

    Glad you have a new version because I could not test the previous version today. Disaster hit me today.

    As I promised I would do a rm -R * on Antergos install. I did it, and it was fun seeing it die… a few message boxes with random chars, and then no more mouse or anything, just the desktop.

    But antergos::rescue did not connected my wifi and I could not get internet because I had no cable and nowhere to get help, as I don’t know how to configure it just by memory.

    So, ok I did not have too much time to play with it, but if I could get internet I would had installed Antergos from the ::rescue image.

    So back to zero. Will get the ISO again and if I don’t get wifi, I’ll try to configure it.

    And @joekamprad I’m not as funny as this gorgeous lady https://www.youtube.com/watch?v=_vH3DMdkYds

    Full video here https://www.youtube.com/watch?v=AxISB26avpw

    This is what I call funny.

  • So anyone knows how can I put to work the wifi out of the box in the live boot?

    lspci -k|grep -i network
    02:00.0 Network controller: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express) (rev 01)
    
    # get device ID
    ip link
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: enp9s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 1000
        link/ether c8:0a:a9:15:3e:de brd ff:ff:ff:ff:ff:ff
    3: wlp2s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noqueue state DOWN mode DEFAULT group default qlen 1000
        link/ether 8e:af:ae:94:a8:eb brd ff:ff:ff:ff:ff:ff
    
    lspci -vnn
    02:00.0 Network controller [0280]: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express) [168c:002a] (rev 01)
    	Subsystem: Foxconn International, Inc. T77H047.31 802.11bgn Wireless Half-size Mini PCIe Card [AR9283] [105b:e01f]
    	Flags: bus master, fast devsel, latency 0, IRQ 16
    	Memory at f8500000 (64-bit, non-prefetchable) [size=64K]
    	Capabilities: <access denied>
    	Kernel driver in use: ath9k
    	Kernel modules: ath9k
    
  • @casquinhas said in antergos :rescue the antergos swiss-knive live-iso:

    Qualcomm Atheros AR928X

    should be aviable with the kernel… may you do not get where to choose inside Live? does it work inside Antergos ISO?

Posts 341Views 20411
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.