• antergos :rescue the antergos swiss-knive live-iso


    [ 😉 ]On pressure of community [/ 😉 ]
    i decide to take the cup and start up developing a rescue-cd for antergos, as we discuss before, and @Keegan want to start before!
    Bild Text

    NOW HERE!

    • Start up to give me any information you have just in mind!
    • Any suggestions on wich software should be on it?
    • have any code by hand? give it here!
    • howto’s yes! i will need to add this to the handbook onto the Live-Iso

    Sourcecode is already aviable here:
    https://github.com/killajoe/antergos-rescue
    (feel free to fork or contribute at github!)

    Website up and running:
    http://kamprad.net/Downloads/antergos-rescue/

    Downloadpage is up:
    http://kamprad.net/Downloads/antergos-rescue/release/

    List of included (not jet) apps:
    https://github.com/killajoe/antergos-rescue/edit/master/packages.list

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • first release is only for testing… it is failing to create vmlinuz image for EFI… i do not know why at the moment…

    https://github.com/killajoe/antergos-rescue/issues/1

    0_1515936879060_Bildschirmfoto vom 2018-01-14 14-33-44.png

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad
    My compliments to you friend!
    So let’s tart! 😛

    Any suggestions on wich software should be on it?

    gparted
    antivírus

    Will be it gnome desktop? Otherwise we need to think on more common packages too, like text editor and file managers too.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @joekamprad
    Hi!
    I tried to make the iso, but it unfortunately failed.
    While doing

    sudo ./build.sh build
    

    it seemed to build successfully for a long time, but ended with an error (a translation, not accurate…):

    cp: status of file '/home/me/github-tools/builddir/antergos-rescue/gsettings/*.gschema.override' cannot be read: No such file or directory
    

    and the directory

    /home/me/github-tools/builddir/antergos-rescue/gsettings
    

    really is missing…

    By the way, I made a script to do all the things since the howto on the web page seemed to contain some typos…

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel said in antergos :rescue the antergos swiss-knive live-iso:

    /home/me/github-tools/builddir/antergos-rescue/gsettings/

    this is a rest of dust inside build.sh gsettings.override do not work, this settings are done from
    /configs/antergos-rescue/root-image/etc/lightdm/Xsession

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @fernandomaroto i will start with gnome desktop… and i will add clamav but first some research on a good way to include… will need a script to update antivirus database e.t.c.

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @manuel what typos do you find? commands are only examples, but i find two old names i just change to antergos-rescue 😉

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in antergos :rescue the antergos swiss-knive live-iso:

    @fernandomaroto i will start with gnome desktop… and i will add clamav but first some research on a good way to include… will need a script to update antivirus database e.t.c.

    https://forum.antergos.com/topic/8939/script-to-use-clamav

    Since is being runned on the liveiso it won’t require a password to run the “refresh database”

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @joekamprad
    To clarify about the typos, maybe it is easiest just to show the script I made. It should be able to clone gits and build the whole thing (at least as far as I got before the error).

    Please note that this script is only for the initial build, it does not handle rebuilds at all.

    #!/bin/bash
    #
    # Build script for the Antergos-rescue USB Live ISO.
    #
    #  $Id: antergos-rescue.bash,v 1.1 2018/01/14 14:41:38 me Exp $
    
    
    EnvPrepare()
    {
        local editor
        if [ "$EDITOR" = "" ] ; then
            for editor in exo-open xdg-open # add you favourite editors here!
            do
                if [ -x /usr/bin/$editor ] ; then
                    EDITOR=$editor
                    break
                fi
            done
        fi
        if [ "$(id -u)" != "1000" ] ; then
            # In Antergos the default sudoer id is 1000, may be different for you!
            sudo()
            {
                su -c "$*"
            }
        fi
    }
    
    RequiredPackages()
    {
        sudo pacman -S --needed \
              git arch-install-scripts \
              dosfstools libisoburn mkinitcpio-nfs-utils \
              make patch squashfs-tools wget cpio gfxboot
    }
    
    StartHere()
    {
        EnvPrepare   # this may be commented out, probably not important to most people
        
        RequiredPackages
    
        local rootdir="$HOME/github-tools"
        local rescuedir="$rootdir/antergos-rescue"
        local gfxbootdir="$rootdir/antergos-gfxboot"
        local builddir="$rootdir/builddir"
        local pwd="$PWD"
        local answer
        local tmpfile="$rootdir/tmpfile.$$"
        local version
    
        mkdir -p "$builddir" "$rescuedir" "$gfxbootdir"
    
        # clone antergos-rescue:
        cd "$rootdir"
        git clone https://github.com/killajoe/antergos-rescue.git
        cd "$rescuedir"
        sudo make install
        cp -R /usr/share/antergos-rescue/configs/antergos-rescue/ "$builddir"
    
        # clone antergos-gfxboot:
        cd "$rootdir"
        git clone https://github.com/killajoe/antergos-gfxboot.git
        cd "$gfxbootdir"
        read -p "Want to edit isolinux.cfg before running make (y|N)?" answer
        case "$answer" in
            "y"|"Y") $EDITOR data/isolinux.cfg ;;
        esac
        make
        cp -R isolinux "$builddir"
    
        # download openfonts:
        cd "$rootdir"
        wget -O "$tmpfile" https://www.archlinux.org/packages/community/any/opendesktop-fonts/
        version=$(grep softwareVersion "$tmpfile" | sed 's|^.*content="\([0-9\.\-]*\).*$|\1|')
        rm -f "$tmpfile"
        wget -q -O opendesktop-fonts-"$version"-any.pkg.tar.xz \
             https://www.archlinux.org/packages/community/any/opendesktop-fonts/download/
        cp opendesktop-fonts-"$version"-any.pkg.tar.xz "$builddir"
    
        # build antergos-rescue:
        cd "$builddir"/antergos-rescue
        sudo ./build.sh build
    
        cd "$pwd"
    }
    
    StartHere
    

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @fernandomaroto thanks!

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @manuel may it is possible to include your script together with build.sh to make it more simple ?

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad
    Why not. Although my script is just using build2.sh after cloning required git repos and downloading open fonts, and doing those things in certain (configurable) directories.

    Well it probably is not that hard to integrate them, but I don’t know much about your build2.sh, it is doing quite many things…

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel build2.sh is only for testing new features for build.sh so you will need to use build.sh 😉

    the build.sh is made mostly by @karasu i only fork it and change to fit.

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • http://kamprad.net/Downloads/antergos-rescue/release/antergos-rescue-18.1-2-x86_64.iso

    i was able to build here 🙂 but forget to change boot entries for BIOS boot menu (grub), so only fully working under EFI…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • I don’t know if there’s a software that fix the greeter/display manager, but I think is a mechanical thing that could be automated. It doesn’t need to be for all of them because there are a lot of display managers and Desktop Environments, starting with a fix for the 2 or 3 most used would be helpful for most people.

    The same for GRUB, there are a lot of possibilities so, initially just the 2 or 3 most common configurations would be helpful too.

    It doesn’t need to solve everyone’s problems, just the most common ones, because fixing everything for everyone would require a huge amount of work and time to make.

    And there’s no need to rush this project, I know this kind of thing is not easy and take some time.

  • @ssspacez yes this project is learning by doing and will need some time to get usefull 😉 but already have a working ISO is a good start!
    But it will be easy to integrate new stuff for each release, and get step by step to what we want!

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad
    I tried to build it again, with different errors (used build.sh this time). The errors were:

    
    ==> Starting build: 4.14.13-1-ARCH
      -> Running build hook: [base]
      -> Running build hook: [udev]
      -> Running build hook: [archiso]
      -> Running build hook: [block]
    ==> WARNING: Possibly missing firmware for module: aic94xx
    ==> WARNING: Possibly missing firmware for module: wd719x
      -> Running build hook: [keyboard]
    ==> Generating module dependencies
    ==> Creating xz-compressed initcpio image: /boot/archiso.img
    bsdcpio: Failed to set default locale
    ==> Image generation successful
    >>> Mkinitcpio done!
    
    [mkarchiso] INFO: Configuration settings
    [mkarchiso] INFO:                   Command:   run
    [mkarchiso] INFO:              Architecture:   x86_64
    [mkarchiso] INFO:         Working directory:   work
    [mkarchiso] INFO:    Installation directory:   arch
    [mkarchiso] INFO:               Run command:   systemctl -fq enable pacman-init NetworkManager livecd vboxservice NetworkManager-wait-online systemd-networkd
    
    Failed to enable unit, unit pacman-init.service does not exist.
    

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel the file is missing at:

    For archiso
    /airootfs/etc/systemd/system

    For antergos-iso
    /root-image/etc/systemd/system

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @manuel o.k. never get this one here … but i do change the sources on the run locally first, and push them later when i know that they are working…

    So better wait for try to build again, till i finish tinkering the source 😉

    and thank you for contributing here!!!

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

Posts 339Views 9202
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.