• Black screen after resuming from suspend with nvidia drivers


    Hi

    Every time I switch from a tty to lightdm (by pressing ctrl+alt+f7), my screen seems to fade out and stays black until I manually restart my monitor. This also happens whenever my desktop resumes from suspend mode. I was thinking it might be related to power issues, but the problem only occurs with the nvidia drivers and not with nouveau drivers. So I think it must be related to nvidia drivers or maybe a bad configuration. I’ve had this issues with debian based distributions in the past too. I’ve also tried using the nvidia-installer package, but that doesn’t help either. Some other problems I’m having are graphical glitches and a lot of messages that desktop effects were reloaded due to a graphical reset or something like that. I’m using KDE Plasma 5 as my desktop environment and lightdm as my display manager, but I’ve had similar issues with sddm and I’m pretty sure it’s not related to the display manager. I have removed the /etc/X11/xorg.conf file, but that didn’t make any difference either.

    Some useful information:
    GPU: Nvidia GTX 760 (OEM version)
    Nvidia driver version: 387.34

    Is there anything I can try to fix this? I can post log files if necessary, but I didn’t see anything suspicious myself.

  • Looking up your issue on the web brings some reults that say it’s a lightdm problem.
    You might want to try a different display manager.
    J.

  • Thanks for your reply!

    I will try using sddm and see of that fixes the issue.

  • I’ve tried both sddm and gdm, but I’m still having the exact same issue.

nvidia150 black68 suspend45 resuming3 Posts 4Views 512
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.