• Correct way to address /tmp size limit limit / resource exhausted


    Sometimes when installing software, the /tmp folder gets full to it’s size limit. On a system with 8gb of ram this is 4gb default.

    I have hardly ever seen swap used, the ram is rarely ever completely filled with xfce desktop. I think the mate task manger might show the /tmp folder instead of swap but with the multiload NG plugin for xfce4, I believe the background lighter green readout for ram shows /tmp use. Correct me if I’m wrong please.

    I ended up messing up the antergos install that was having that issue, and ‘solved’ the problem while I was having to reinstall anyways by setting /tmp as it’s own partition when running through cnchi, and I take that preventative measure now.

    You probably shouldn’t resize partitions your system while its running (not even sure that’s possible) but I’ve read several variations of answers to this question.

    Proactively seek to give of yourself and to bring only benefit to your peers and community.

  • @Moe_Narrow

    1 - The simplest workaround for this is rebooting, it will clean tmp and you will be able to install more packages.

    2 - You can choose another folder for tmp in Pamac preferences

    3 - Increase the size of tmp with a command line, read Arch documentation about it

    I don’t like the way this tmp thing is, but this is how it works.

  • the other way is to not use RAM for tmpfs:

    Disable automatic mount
    Under systemd, /tmp is automatically mounted as a tmpfs even though no entry is specified in /etc/fstab.

    To disable the automatic mount, run:

    sudo systemctl mask tmp.mount

    Files will no longer be stored in a tmpfs, but on the block device instead. The /tmp contents will now be preserved between reboots, which might not be the desired behavior. To regain the previous behavior and clean the /tmp folder automatically when restarting, consider using tmpfiles.d:

    sudo nano /etc/tmpfiles.d/tmp.conf
    insert this:

    # see tmpfiles.d(5)
    # always enable /tmp folder cleaning
    D! /tmp 1777 root root 0
    
    # remove files in /var/tmp older than 10 days
    D /var/tmp 1777 root root 10d
    
    # namespace mountpoints (PrivateTmp=yes) are excluded from removal
    x /tmp/systemd-private-*
    x /var/tmp/systemd-private-*
    X /tmp/systemd-private-*/tmp
    X /var/tmp/systemd-private-*/tmp
    

    save with [Ctrl+X]

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

size6 address2 tmp1 limit1 Posts 4Views 70
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.