• Can't upgrade, could not satisfy dependencies


    Currently I am not able to upgrade my system. I am getting this error:

    :: Starting full system upgrade...
    resolving dependencies...
    looking for conflicting packages...
    error: failed to prepare transaction (could not satisfy dependencies)
    :: ffmpeg0.10: installing libx264 (2:152.20171224-1) breaks dependency 'libx264.so=148-64'
    

    Any ideas?
    J.

  • Hi,

    i found this topic. Looks like the problem you have.

    https://bbs.archlinux.org/viewtopic.php?id=233473

    Linux ist das beste Betriebssystem (Albert Einstein)

  • Removing ffmpeg0.10, upgrading and reinstalling ffpmeg0.10 fixed it.
    J.

  • I had the same issue and wondering, do I need ffmpeg 0.10?

  • FFmpeg is a complete, cross-platform solution to record, convert and stream audio and video. It includes libavcodec - the leading audio/video codec library.

    So if you don’t use it in command line it might be used by a tool e.G. to convert music or play videos.

    Linux ist das beste Betriebssystem (Albert Einstein)

  • @Citroen said in Can't upgrade, could not satisfy dependencies:

    I had the same issue and wondering, do I need ffmpeg 0.10?

    Yes, it’s a dependency for many programs like @pseudonym said in other words;

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • I know, but I just don’t run any of these apps…

    Required by (66)

    barco-clickshare
    bonita-bpm-community-bin (requires ffmpeg-compat)
    bonita-studio-community-bin (requires ffmpeg-compat)
    cabrio-git (requires ffmpeg-compat)
    curlew (requires ffmpeg-compat)
    d2vwitch-git (requires libavformat.so)
    d2vwitch-git (requires libavutil.so)
    d2vwitch-git (requires libavcodec.so)
    dolphin-emu-git (requires libswscale.so)
    dolphin-emu-git (requires libavcodec.so)
    dolphin-emu-git (requires libavformat.so)
    dolphin-emu-git (requires libavutil.so)
    dolphin-emu-ishiiruka-git (requires libavformat.so)
    dolphin-emu-ishiiruka-git (requires libavutil.so)
    dolphin-emu-ishiiruka-git (requires libswscale.so)
    dolphin-emu-ishiiruka-git (requires libavcodec.so)
    ffmpeg-compat-pc (requires ffmpeg-compat)
    ffms2-git (requires libswscale.so)
    ffms2-git (requires libavcodec.so)
    ffms2-git (requires libavformat.so)
    ffms2-git (requires libavutil.so)
    ffms2000-git (requires libavcodec.so)
    ffms2000-git (requires libswscale.so)
    ffms2000-git (requires libavformat.so)
    ffms2000-git (requires libavutil.so)
    instantreality (requires ffmpeg-compat)
    motion-mmal (requires ffmpeg-compat)
    motion-mrdave-git (requires ffmpeg-compat)
    retroarch-git (requires libavcodec.so)
    retroarch-git (requires libswscale.so)
    retroarch-git (requires libavformat.so)
    retroarch-git (requires libavutil.so)
    retroarch-git (requires libswresample.so)
    retroarch-rbp (requires libswscale.so)
    retroarch-rbp (requires libavcodec.so)
    retroarch-rbp (requires libavformat.so)
    retroarch-rbp (requires libswresample.so)
    retroarch-rbp (requires libavutil.so)
    rpcs3-git (requires libavutil.so)
    rpcs3-git (requires libswresample.so)
    rpcs3-git (requires libswscale.so)
    rpcs3-git (requires libavcodec.so)
    rpcs3-git (requires libavformat.so)
    spotify (optional)
    spotify-legacy
    spotify-stable (optional)
    spotify094 (requires ffmpeg-compat) (optional)
    spotio (optional)
    vapoursynth-git (requires libavcodec.so) (optional)
    vapoursynth-git (requires libavutil.so) (make)
    vapoursynth-git (requires libavcodec.so) (make)
    vapoursynth-git (requires libavformat.so) (optional)
    vapoursynth-git (requires libavformat.so) (make)
    vapoursynth-git (requires libavutil.so) (optional)
    vapoursynth-plugin-d2vsource-git (requires libavcodec.so)
    vapoursynth-plugin-d2vsource-git (requires libavformat.so)
    vapoursynth-plugin-d2vsource-git (requires libavutil.so)
    vapoursynth-plugin-lsmashsource-git (requires libswscale.so)
    vapoursynth-plugin-lsmashsource-git (requires libavcodec.so)
    vapoursynth-plugin-lsmashsource-git (requires libavformat.so)
    vapoursynth-plugin-lsmashsource-git (requires libavutil.so)
    wxsvg
    x264-git (requires libavcodec.so)
    x264-git (requires libavformat.so)
    x264-git (requires libavutil.so)
    x264-git (requires libswscale.so)
  • @Citroen If none of your music/video players and sound/video/image converters don’t use it as dependency then i guess you can remove it. Anyway is such a small package.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • I know it is small, but I was curious how it ended up on my system since it is part of the AUR.
    But I am fine now. 😉

  • @Citroen said in Can't upgrade, could not satisfy dependencies:

    I know it is small, but I was curious how it ended up on my system since it is part of the AUR.
    But I am fine now. 😉

    You could uninstall and see how your system will behaviour. If something goes wrong, you’ll know what could be the culprit and simply reinstall it if needed.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

Posts 10Views 1107
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.