• Antergos freezing [RAM Problem]


    Hello,
    I am using Antergos wih Deepin DE.
    This isthe fourth time my antergos deeping freezes, this time i was installing Webstrom from the jetbrains toolbox.
    After rebooting my pc, and reinstalling webstorm it didnt freeze.
    Could you please help ?
    i’ll give you the log file here :
    https://drive.google.com/open?id=1NPNkaNQnjNdVY7t2MFiNs_FLA9L6I6rC

  • @oussama.ah95
    I had previously used the deepin desktop and I think it uses a lot of ram, progressively more over time… I’m not sure what to make of the log file, but you would be wise to look at your system resources with a system monitor and maybe you’ll see an indication that something is going wrong before it freezes.

    Proactively seek to give of yourself and to bring only benefit to your peers and community.

  • @Moe_Narrow
    Thanks for replying,

    But i have 16GB of RAM

  • @oussama.ah95 said in Antergos freezing:

    Webstrom from the jetbrains toolbox

    i would bet to graphics hickup and not deepin producing the freezing…

    Jan 08 18:24:13 lenovo kernel: [drm:wait_panel_status [i915]] *ERROR* PPS state mismatch
    Jan 08 18:24:13 lenovo kernel: [drm:wait_panel_status [i915]] *ERROR* PPS state mismatch
    Jan 08 18:24:13 lenovo kernel: [drm:wait_panel_status [i915]] *ERROR* PPS state mismatch
    Jan 08 21:33:09 lenovo kernel: [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=192409 end=192410) time 161 us, min 1073, max 1079, scanline start 1071, end 1082
    

    i do not know what this is but spamming a lot fails:

    Jan 08 18:24:26 lenovo daemon/launcher[603]: manager.go:259: queryPkgName failed: Manager.desktopPkgMap is nil
    

    fail on touchpad too:

    Jan 08 18:24:29 lenovo daemon/inputdevices[682]: touchpad.go:409: [enablePalmDetect] failed to enable: 12 false libinput unsupported palm detect setting
    Jan 08 18:24:29 lenovo daemon/inputdevices[682]: touchpad.go:420: [setPalmDimensions] failed to set: 12 6 50 libinput unsupported palm detect setting
    

    deepin traces also:
    https://paste2.org/mY12Eadc

    uh! and this looks bad:
    https://paste2.org/3zBz3DwC

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad
    Hello do you know how can i fix it ?
    this hapened also when i was installing Android Studio.
    I think the touchpad failure is a result because when it happens : everything freezes even the mouse cursor

  • will need some more info about your system:

    DE (Desktop environment)

    and the output of:

    inxi -F -x
    

    command not found?

    sudo pacman -S inxi

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad
    Oh yea I’ve seen that before, on a friend’s system running antergos. He built his computer and It would get some stuck pixels and about 5 minutes later it would usually freeze. It’s usually an issue specific to certain hardware.

    @oussama-ah95
    I never had any luck with anbox, android studio, any of it. I tried to install all that stuff to find something that worked and then for some reason I couldn’t boot the next day. That was a fun ~8 hours of trying to rescue my system.

    Proactively seek to give of yourself and to bring only benefit to your peers and community.

  • I can confirm that I had the same issue last week after installing Anbox on my XFCE machine, I reinstalled everything after I thrown Anbox off to avoid any irritation.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • @joekamprad

    The first time it happened when i added a new 8GB RAM card and reinstalled antergos.
    and i was installing Android Studio it happened.

    The output:

    System:    Host: lenovo Kernel: 4.14.12-1-ARCH x86_64 bits: 64 gcc: 7.2.1 Desktop: Gnome  (Gtk 3.22.26)
               Distro: Antergos Linux
    Machine:   Device: laptop System: LENOVO product: 80NT v: Lenovo ideapad 500-15ISK serial: N/A
               Mobo: LENOVO model: Lenovo ideapad 5 v: No DPK serial: N/A
               UEFI: LENOVO v: CFCN24WW(V1.06) date: 04/15/2016
    Battery    BAT1: charge: 6.4 Wh 18.7% condition: 34.2/39.7 Wh (86%) model: LENOVO PABAS0241231 status: Charging
    CPU:       Dual core Intel Core i7-6500U (-MT-MCP-) arch: Skylake rev.3 cache: 4096 KB
               flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10372
               clock speeds: max: 3100 MHz 1: 2600 MHz 2: 2600 MHz 3: 2600 MHz 4: 2600 MHz
    Graphics:  Card-1: Intel HD Graphics 520 bus-ID: 00:02.0
               Card-2: Advanced Micro Devices [AMD/ATI] Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445]
               bus-ID: 01:00.0
               Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting (unloaded: fbdev,vesa)
               Resolution: [email protected]
               OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
               version: 4.5 Mesa 17.3.1 Direct Render: Yes
    Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
               Sound: Advanced Linux Sound Architecture v: k4.14.12-1-ARCH
    Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
               driver: r8169 port: 3000 bus-ID: 02:00.0
               IF: enp2s0 state: down mac: 1c:39:47:2b:15:4c
               Card-2: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi bus-ID: 03:00.0
               IF: wlp3s0 state: up mac: e0:94:67:75:72:e5
    Drives:    HDD Total Size: 1000.2GB (47.5% used)
               ID-1: /dev/sda model: ST1000LM014 size: 1000.2GB
    Partition: ID-1: / size: 106G used: 20G (20%) fs: ext4 dev: /dev/sda9
               ID-2: /home size: 92G used: 15G (16%) fs: ext4 dev: /dev/sda8
               ID-3: swap-1 size: 8.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
    Sensors:   System Temperatures: cpu: 35.5C mobo: N/A gpu: 32.0
               Fan Speeds (in rpm): cpu: N/A
    Info:      Processes: 192 Uptime: 23:15 Memory: 3171.4/15959.9MB Init: systemd Gcc sys: 7.2.1
               Client: Shell (bash 4.4.121) inxi: 2.3.53 
    

    @Moe_Narrow
    Android Studio works for me, i dont think android studio is the reason…

    @Bryanpwo should i format my pc again ?

  • I will take a look to related issues with your device, may there is a need to get some special configuration.

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad
    Thank you very much

  • @oussama.ah95 said in Antergos freezing:

    Lenovo ideapad 500-15ISK

    do you have drivers for discrete and legacy graphics installed?

    xf86-video-amdgpu
    xf86-video-intel

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @oussama.ah95 said in Antergos freezing:

    Skylake

    The i915 DRM driver is known to cause various GPU hangs, crashes and even full system freezes. It might be necessary to disable hardware acceleration to workaround these issues. One solution is to use the following Xorg configuration.

    sudo nano /etc/X11/xorg.conf.d/20-intel.conf
    
    Section "Device"
    	Identifier  "Intel Graphics"
    	Driver      "intel"
    	Option	    "DRI"	"false"
    EndSection
    

    Otherwise, specific applications such as Chromium and Firefox browsers can be instructed to disable hardware rendering directly.

    Another option that seems to work for some users is to add the i915.enable_rc6=0 kernel boot parameter, which will cause the CPU/GPU to remain in high-power modes, but seems to resolve most cases of GPU hangs and system freezes.

    Note: If the system appears to hang after “Loading Initial Ramdisk”, make sure that the IGD aperture size in BIOS is less than 4GB.
    from:
    https://wiki.archlinux.org/index.php/Intel_graphics#Skylake_support

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Thanks @joekamprad
    No, I forget to install them after formating.
    Should i install them ?
    As i mentioned earlier, it hapened for the first time after i added the RAM card and it happens when i am downloading large softwares.

    could it be a RAM problem since pacman download files to RAM ?

  • Ram is used by tempfs /tmp is using the ram… so yes

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • May try do a ram test?

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad
    how can i test my ram ?

  • @oussama-ah95
    https://wiki.archlinux.org/index.php/Stress_Test
    I hope it gets you further, although don’t rule out Android Studio, yet. That it works for you, does not mean it maybe is messing the system up in the background.

    *Just a note and don’t take this too personal, I’m only saying this also for all users, try to be as complete to discribe your problem. In this case we later found out you bought new RAM. Again don’t take this as an attack, or anything, but if we knew from the beginning we could immediately look in that direction.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • @Bryanpwo
    Thank you for your answer,
    Sorry if forget ti mention it

  • I would do a ramtest from liveiso like systemrescuecd http://www.system-rescue-cd.org

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

Posts 28Views 1040
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.