• Change desktop language in gnome-shell for 1 user


    Hi,

    I’ve been using Antergos for a couple of years now on my personal laptop. On this PC, English is the default language and only 1 user is configured.

    Now I also installed Antergos on my family PC which has 5 users. My family speaks Dutch, but for practical reasons I would like to install English for my personal account.

    When I open the “language & Regions” settings, Dutch is selected.
    When I click on the list and start typing “en”, it says “no languages found”

    I tried to look in pacman for gnome language packs, but couldn’t find any package…

    On the internet I have been searching for gnome-shell language packs but couldn’t find any solution.

    How can I set the language to English for my session only?

    Many thanks in advance,

    Geert

  • i am not sure at the moment… but to have languages aviable you need to have them enabled inside /etc/locale.gen and generating locales…

    sudo nano /etc/locale.gen
    

    uncomment the languages you want to use:

    #niu_NZ UTF-8  
    #nl_AW UTF-8  
    #nl_BE.UTF-8 UTF-8  
    #nl_BE ISO-8859-1
    nl_NL.UTF-8 UTF-8  
    nl_NL ISO-8859-1  
    [email protected] ISO-8859-15 
    #nn_NO.UTF-8 UTF-8  
    #nn_NO ISO-8859-1  
    #nr_ZA UTF-8
    

    save file [Ctrl+X]

    and generate:

    sudo locale-gen
    

    0_1515547199399_Bildschirmfoto vom 2018-01-10 02-18-11.png

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

language22 gnome-shell13 Posts 2Views 42
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.