• Touchpad doesnt work


    Hello, I have a laptop “Chuwi Lapbook Air 14”, as soon as the laptop arrives, what I did was format it to remove windows and install linux.

    I tried a lot of Linux distro, but none of them even started, when I put the USB to install the system, the screen remained in black with a script in the center.

    Here comes the important thing.

    I finally found this Distro, and I really liked its aesthetics. I tried to install it, and it’s the only one that works on my laptop, although I did not do it finally. The first thing I did was to enter the trial version to see if everything was fine, but no, the touch panel does not work.

    What can happen

  • Did you update the installed Windows version on your machine or did you remove it immediately. The thing is, that mostly, when you buy a Windows computer, it updates not only Windows, but also the necessary firmware. Therefore it is wise, on new machines, to leave a small space reserved on your HDD or SDD for the installed system, so you can easily update the hardware.
    So it’s better to put Windows back on and go to the manufacturer’s site for the driver update, than install Antergos next to Windows and leave it like that for at least a year or more.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • I am currently using windows, so when I tried to install antergos, I already had windows installed and I had it updated because it was the one I used.

    I explained badly in the 1st message, when the laptop arrived, I formatted it and tried to install linux, but none of it worked for me, so I reinstalled windows because I needed it working at the moment.

    The following week I tried again with antergos testing its trial version, so the windows drivers are all updated. But the touchpad does not work.

  • I dug up (https://medium.com/@edoardop/archlinux-on-my-chuwi-lapbook-14-1-with-bonus-opinions-that-werentrequested-bcd6fcd05a88)
    I hope it gives you enough info.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • Thanks for the help, but it did not help me much, he just says it does not work but he does not say the solution.

    I searched a lot for google but I did not find anything, my last hope is that someone knows something

  • The article is an experience review from first hand. I directed you to the article, because apparantly the manufacturer of the touchpad, is exclusively working with Windows drivers.
    I don’t want to be rude or anything, but the problem in your case is a very rare and specific hardware problem.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • Oh, then nothing, bad luck, thanks for everything.

    Anyway windows is very good in it, only that I liked more the aesthetics and minimalism of linux.

  • I know it’s not an ideal circumstance, but why don’t you use a mouse? The rest of Antergos is fully functioning on it, from what I read.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

touchpad40 Posts 8Views 635
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.