• Pamac is great, when it works


    I’m having some issues with Pamac, sometimes weird things happen:

    • search can’t find packages, in the repositories and/or AUR
    • search find packages in the repositories and not AUR but AUR is enabled
    • after trying to search, the window freezes and the cursor keeps rotating like it’s reading and after a while a pop-up shows up asking to force close it
    • sometimes it gets extremely slow and a pop-up shows up asking to force close it
    • I can’t update the database or install anything because it says there’s another package manager opened and actually there’s not

    Probably more things happen that I don’t remember now, I’m not sure if it’s something I’ve installed/removed or some random command line I typed that breaked something, who knows. Rebooted and closed session multiple times, I even tried this sudo rm /var/lib/pacman/db.lck and this not solved anything. I’m actually tired of trying figuring this out so I came here.

    Any ideas? Is it just me or Pamac is more buggy recently?

  • Are you sure you didn’t try another package manager and maybe removed not everything of it, Pamac is running without any problems on four machine over here. Try to reinstall pamac otherwise.

    Thinkpad E570 Intel core i5 (Kaby lake)
    8 GB RAM
    256 GB SSD + 1 TB HDD
    Intel HD Graphics

  • @Bryanpwo

    I reinstalled and rebooted and it’s working, for now… But this happened with Manjaro too a few weeks ago, those issues doesn’t happen everytime, it’s like a lottery, everytime I open Pamac I’m not sure if it will work, sometimes it does, sometimes it doesn’t, it’s weird.

  • Good news it worked, if it happens again and when it’s not a bug, you can install the AUR version instead. It still works with the Antergos repo, so you won’t miss out on anything.

    Thinkpad E570 Intel core i5 (Kaby lake)
    8 GB RAM
    256 GB SSD + 1 TB HDD
    Intel HD Graphics

  • @ssspacez said

    I can’t update the database or install anything because it says there’s another package manager opened and actually there’s not

    May I ask if you are using Gnome and have also installed their updates app? I don t remember the name, it s the gnome app store which is also an updater.
    If so, it runs silently and because it starts up slower than pamac, then, this might be the issue.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch said in Pamac is great, when it works:

    @ssspacez said

    I can’t anything because it says there’s another package manager opened and actually there’s not

    May I ask if you are using Gnome and have also installed their updates app? I don t remember the name, it s the gnome app store which is also an updater.
    If so, it runs silently and because it starts up slower than pamac, then, this might be the issue.

    I think you are talking about GNOME Software(gnome-software), but no, I don’t have it installed. I’m removing GNOME and Openbox and trying to just have Xfce installed, maybe something conflicted. This issue just happend again after I removed antergos-openbox-meta, which broke a lot of things by the way but I fixed them(or I think I fixed them).

    As I’m switching Desktop Environments a few things are breaking and I’m fixing them, like the lightdm-webkit2-greeter, greeters have a hard time when you switch DEs, stuff usually breaks. Maybe Pamac is not liking this switching too, some conflicts, dependencies and configurations are breaking in the middle of this process. It’s always a mess switching DEs, is better backing up things and doing a fresh install with another DE. I made this mistake a few times, it gets old… is a bit irritating I may say.

  • @ssspacez said in Pamac is great, when it works:

    This issue just happend again after I removed antergos-openbox-meta

    LANG=C pacman -Si antergos-openbox-meta |sed -n '/Depends\ On/,/:/p'|sed '$d'|cut -d: -f2 |tr -d '>=[0-9]'

    The command above will show you the “dependencies” that you uninstalled

    arandr  conky  conky-manager  file-roller  galculator  gmrun  gnome-disk-utility  gnome-mplayer  gpicview  gsimplecal  gvfs-google  gvfs-mtp  gvfs-smb  kalu  lxappearance-obconf-gtk  lxinput-gtk  lxmenu-data  lxtask-gtk  lxsession  lxterminal  mousepad  nitrogen  network-manager-applet  networkmanager-openvpn  networkmanager-pptp  notify-osd  obconf  obkey  oblogout  oblogout-numix-theme  obmenu  openbox  openbox-menu  parcellite  pcmanfm  plank  plank-theme-numix  polkit-gnome  pragha  python-pysmbc  python-xdg  qtct  scrot  tint  transmission-gtk  udiskie  volumeicon  waldorf-ui-theme  xdg-user-dirs-gtk  xfburn
    

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • Well… Too late :), I formatted the whole thing and I’m making a fresh Antergos installation with Xfce. If I face these issues again I will report them here.

  • @ssspacez said in Pamac is great, when it works:

    Well… Too late , I formatted the whole thing

    that happens 😛

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • That issue that it keeps saying that there’s another package manager opened happened again even after a fresh install with Antergos Xfce. It was working normal but today I opened tried to search a package, was taking too long, I clicked AUR and this happened:

    0_1515603928589_pamac.png

    Translation: “Waiting for another package manager to leave/close”

    The blue bar goes to left and right, and it keeps like this forever.

    After that I just closed Pamac, tried to open it again and it’s a blank frozen window. I will have to manually kill it.

    0_1515604179858_pamac_frozen.png

  • Did you use a back up program to reinstall your settings and preferences? It’s very likely then that the bug got reinstalled too.

    Thinkpad E570 Intel core i5 (Kaby lake)
    8 GB RAM
    256 GB SSD + 1 TB HDD
    Intel HD Graphics

  • @Bryanpwo I wiped everything at the installation and just installed Antergos, the default first option of the partition step.

    Update: I rebooted and now Pamac repositories are working. But AUR get weird sometimes, it freezes for some time. Sometimes it can’t find packages, but when I try again it can. See what I’m talking about? Sometimes it works sometimes it doesn’t.

  • /var/lib/pacman/db.lck
    

    if this file is present (if pacman is running or some program is using it) the database is locked, and installing is not possible (for security reason)

    If you are sure no other programm is installing something you can safely remove this, and lock will be away…

    sudo rm /var/lib/pacman/db.lck
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad I just tried using pacman to remove a package and it shows the db.lck error:

    erro: falha ao iniciar a transação (não foi possível travar a base de dados)
    erro: não foi possível travar a base de dados: Arquivo existe
    se tiver certeza de que um gerenciador de pacotes não esteja
    em execução, você pode remover /var/lib/pacman/db.lck

    Yes, it’s there:

    pacman]$ ls
    db.lck  local  sync
    

    After removing, pacman works and can remove the package I was trying to remove. So, apparently this error is related to this in someway, but there are no package managers running, that’s weird.

  • yea there was same issues like this before… related to pamac, i do not have this here…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Hi!
    It’s “normal” for pamac taking around 1 minute to load on my pc the first time after login. That’s horrible, but that’s how it is.

    Maybe when you had the same problem you forced to close it and reopened it, resulting in /var/lib/pacman/db.lck error as you mentioned. The solution is indeed simple sudo rm /var/lib/pacman/db.lck and try again.

    The problem could be related also with pamac-tray, if your desktop is launching it at startup (the app that checks for availabe updates) and then at the same time you’re trying to open pamac-manager may also cause that problem.

    So you could do a test:
    disable pamac-updater at startup, restart your machine and see if the error will happen again when you launch pamac-manager.

    I no longer use pamac-updater here, and idon’t experience your issue.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • Sorry, just had dinner, but the topic got the right attention!

    Thinkpad E570 Intel core i5 (Kaby lake)
    8 GB RAM
    256 GB SSD + 1 TB HDD
    Intel HD Graphics

  • @fernandomaroto I removed the pamac-tray and after rebooting it can’t find packages on AUR but succeed to find them on the repositories.

    0_1515611848751_pamac_cant_find.png

    Update: and now, I swear I didn’t do anything, I just opened the Pamac window again by clicking on Pamac dock icon and… Repositories and AUR, and it can find them normally… WHAT? 😕

    0_1515612064988_pamac_aur.png

    I think I will just use pacman and yaourt for now, this thing is giving me headaches.

  • also a little bug is that pamac sometimes forget its settings… you can reanable it inside pamac settings and reload the database…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @ssspacez said in Pamac is great, when it works:

    Update: and now, I swear I didn’t do anything, I just opened the Pamac window again by clicking on Pamac dock icon and… Repositories and AUR, and it can find them normally… WHAT?

    try rebooting again to see if it’s working now for real!

    @joekamprad said

    also a little bug is that pamac sometimes forget its settings

    really? that’s new to me.

    @ssspacez if you want some app to warn you about updates you can check for kalu
    Antergos added it to the repository, but i admit i haven’t test yet.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

Posts 21Views 396
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.