• How to install WIFI epson l 486 printer?


    Hello, I have an all in one printer Epson L486. I tried to install it like a WIFI network printer but I get a message: server error cups server error internal error. The system is up to date. Maybe some package is missing. What should I do to make the printer work as a WIFI network printer.
    Thanks a lot.
    Regards Adam.

  • @MarnyPopis said in How to install WIFI epson l 486 printer?:

    L486

    http://download.ebz.epson.net/dsc/search/01/search/searchModule

    Should run, but needs a driver mayby?

    yaourt -S epson-inkjet-printer-escpr
    

    Do you enable printer/cups support on installation?

    check if services are running:

    systemctl list-unit-files | grep enabled | curl -F [email protected] https://ptpb.pw/?u=1
    

    this will give an url where it pasted the enabled services

  • I installed espon-inkjet-printer-escpr.
    When I add new printer I’ve got this:
    0_1515697278503_Zrzut ekranu z 2018-01-11 19-58-49.png
    0_1515697307499_Zrzut ekranu z 2018-01-11 19-58-58.png
    0_1515697545187_Zrzut ekranu z 2018-01-11 19-59-05.png
    0_1515697617183_Zrzut ekranu z 2018-01-11 19-59-10.png
    0_1515697637425_Zrzut ekranu z 2018-01-11 19-59-16.png
    0_1515697654847_Zrzut ekranu z 2018-01-11 19-59-26.png
    0_1515697675727_Zrzut ekranu z 2018-01-11 19-59-42.png
    0_1515697709693_Zrzut ekranu z 2018-01-11 19-59-51.png
    0_1515697730955_Zrzut ekranu z 2018-01-11 19-59-57.png

  • you will need to put in root as username and the given password to get access…

  • I did it put my username and then gave password. After this I’ve got error.

  • you need root access to configure cups/printer so give root as username and not your normal username!
    password is the same on standard Antergos install…

    0_1515701358942_Bildschirmfoto vom 2018-01-11 21-06-08.png

  • Thanks I’ll do it tommorow.

  • Zapraszamy!

  • systemctl status org.cups.cupsd.service
    systemctl status avahi-daemon.service
    pacman -Qs cups

    and post what this 3 commands gives out at terminal or use autopastebin and give urls it gives out:

    systemctl status org.cups.cupsd.service | curl -F [email protected] https://ptpb.pw/?u=1
    systemctl status avahi-daemon.service | curl -F [email protected] https://ptpb.pw/?u=1
    pacman -Qs cups | curl -F [email protected] https://ptpb.pw/?u=1

  • so cups and avahi is up and running…

    only this Failed to read /etc/avahi/services
    https://bugs.archlinux.org/task/56989

    I ave no clue here…

    but plz. give me the cups log:
    cat /var/log/cups/error_log | curl -F [email protected] https://ptpb.pw/?u=1

    Looks like an issue with adding the printer with installed driver…

  • https://ptpb.pw/iaBv

    I created manually folder etc/avahi/services and I here is out command systemctl status avahi-daemon.service at terminal:
    0_1515845136629_Zrzut ekranu z 2018-01-13 13-01-38.png
    I tried add new printer and still is the same error.
    After created the folder:
    https://ptpb.pw/-jvA

  • if the printer is wireleslan only you will need to get it find automatic, as network printer (avahi is doing this)

    E [09/Jan/2018:08:02:27 +0100] [Client 44] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/printers/Epson%5FL486) from localhost
    E [10/Jan/2018:15:12:51 +0100] EPSON_L486_Series: Unable to connect to EPSON890C6B.local:631: Name or service not known
    E [11/Jan/2018:19:19:21 +0100] [Client 37] Returning HTTP Forbidden for CUPS-Get-Devices (no URI) from localhost
    E [11/Jan/2018:19:19:21 +0100] [CGI] CUPS-Get-Devices request failed with status 401: Forbidden
    E [11/Jan/2018:19:19:44 +0100] [Client 43] Returning HTTP Forbidden for CUPS-Get-Devices (no URI) from localhost
    

    but uri of your printer is localhost and this is not remote, needs to be replaced with the IP of the printer… usualy cups shoud give you one with a ip instead of localhost…

    like this one:
    Device URI example!!! : ipp://192.168.1.43:631/printers/Epson_5FL486

  • may better use socket instead of ipp—

    socket://192.168.1.43:9100/printers/Epson_5FL486
    
  • if you know the ip of the printer you can try also to reach its configuration server over browser:

    http://192.168.1.43
    

    (IP adress i give you is only an example you need to replace with the real one from printer!!!)

  • @MarnyPopis
    Your router should be able to show the IP address of your printer.
    Look at your router’s LAN/WLAN settings.

    What does command

    ping -c 1 EPSON890C6B.local
    

    say?

  • @manuel thanks for joining!

  • @MarnyPopis
    There’s also some help in
    https://wiki.archlinux.org/index.php/CUPS#Network_2

    That page contains a lot of possibly useful links, too…

    @joekamprad Hopefully I could be of some help, though I’m no expert, I don’t even have a wireless printer… ;)

  • Thanks everyone who tried to help me a specialy thanks for joekamprad.
    I used socket://ip printer and it works. I printed one page.
    Thx very much joekamprad.
    Regards Adam.

Posts 21Views 1070
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.