• Mount NTFS drive automatically with user rw permissions


    Hi!

    So I used to have my drives automatically mounted with user permissions. Since a couple of weeks, I’m no longer able to write to these drives and I can’t fix it.

    Here’s what my fstab file looks like:

    /dev/disk/by-uuid/3E185D32185CEA83      /home/fnc/data1        auto    nosuid,nodev,nofail,x-gvfs-show 0       0
    /dev/disk/by-uuid/98D2E85DD2E840DC      /home/fnc/data2        auto    nosuid,nodev,nofail,x-gvfs-show 0       0
    

    I’ve tried changing auto to ntfs-3g and adding uid=1000,gid=100,dmask=027,fmask=137 flags. Also, I’ve tried users flag but nothing changes.

    Am I missing something?

    Thanks!

  • @fnc
    Would you show the output of commands

    ls -ld /home/fnc/data1 /home/fnc/data2
    sudo blkid
    

    In /etc/fstab I’m using ntfs instead of auto or ntfs-3g and it works for me. Maybe you could try to modify your /etc/fstab to

    /dev/disk/by-uuid/3E185D32185CEA83 /home/fnc/data1 ntfs defaults
    

    and similar with data2.

    A tool for sending logs: https://forum.antergos.com/topic/10586/eat-logs
    Install eat: wget -q https://github.com/manuel-192/eat/raw/master/PKGBUILD && makepkg -sic

  • @manuel

    This /dev/disk/by-uuid/3E185D32185CEA83 /home/fnc/data1 ntfs defaults fixed the problem, but I don’t know why it stopped working as it was before.

    Thanks!

  • @fnc
    Great to hear the problem is solved! 🙂
    Maybe the old setting in /etc/fstab was a workaround for older ntfs-3g version or kernel version, difficult to tell.
    I’ve used only ntfs and defaults on such cases always when no extra settings were needed, and it has always worked for me.

    A tool for sending logs: https://forum.antergos.com/topic/10586/eat-logs
    Install eat: wget -q https://github.com/manuel-192/eat/raw/master/PKGBUILD && makepkg -sic

mount22 automatically9 ntfs8 permissions4 Posts 4Views 706
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.