• Login Screen Timeout - Resume From Suspend


    Hello Everyone,

    I had a quick question regarding the login screen after you resume from a suspend or hibernate:

    Question:
    I am using GDM and Gnome Desktop Environment under Antergos. If I resume my computer, and I do not immediately login, I think after 5-10 seconds the computer goes into a black (locked) screen. My question is there a way to adjust the settings of when the computers black screen kicks on, to say a timeout value of 30 seconds?

    I hope I’m being clear with this post. Just looking for the login screen to stay active for another 20-30 seconds before the black ‘screen saver’ kicks on.

    Please let me know if you need any additional information from my end to assist in the troubleshooting of this issue. Thanks!

  • I am not using Gnome, but I guess it is not much different from other desktop environments. Go to settings - power settings or power management. There you should be able to adjust your lock screen settings.

  • @a4orce84 said in Login Screen Timeout - Resume From Suspend:

    GDM and Gnome Desktop Environment under Antergos

    by that mean you need to do remove the settings lightlocker may write to your autostart folder…

    can you take a look ? :

    ls ~/.config/autostart
    

    After this you can use gnome-control-center to adjust as you like:

    1_1514293513655_Bildschirmfoto vom 2017-12-26 14-04-22.png 0_1514293513654_Bildschirmfoto vom 2017-12-26 14-04-04.png

  • Hey @joekamprad and @axioma,

    I think I may have confused both of you on what I am actually asking for. Let me try to clarify the use-case I am actually after:

    What You Both Described:
    You both described how to set a specific time (5 minutes for example) before the “blank screen” screensaver setting kicks in. These are my screenshots from my Antergos install:

    Power:
    https://imgur.com/a/Vh6g4

    Privacy:
    https://imgur.com/a/2qKpO

    This is the default or normal behavior when you walk away from your computer and leave it idle. For me, if I don’t touch my computer after 5 minutes, the “blank screen” screensaver setting kicks in. Also, you can see I have it similarly setup under the Privacy settings section the same way as well. This is what I want, and it IS working correctly.

    What I Am Wanting:
    I am asking about the actual ‘login’ screen time. So, for my use-case, if my computer is sleeping (suspend state), and I open the lid of my laptop to wake the computer, I am presented with the GDM login to resume my session. If I don’t type anything or do anything, the “blank screen” screensaver setting kicks in after 10 seconds. It is this time interval I want to adjust and make it 30 seconds - 1 minute if possible. Again, this is only when I resume a session from a suspended or hibernated state. The default behavior is for the “blank screen” screensaver setting to kick in after roughly 10 seconds.

    Hopefully, this paints a better picture of what I am asking for. If either of you need any additional information to assist in the troubleshooting process, please let me know.

    Thank you again to both of you for your time and help, it is greatly appreciated.

    Thanks,
    Asif

  • Truely another problem…
    As GDM session runs under a user called gdm, it will need to configure this with the rights of this one… May it is possible to run gnome-control-center as the gdm user… I remember doin this once, but long time ago…

  • i find this to change the blnk screen delay under GDM:

    you can change this only under gdm user:

    you need to do this from TTY3 by pressing [Ctrl+Alt+F3] login as root and:

    su - gdm -s /bin/sh
    export $(dbus-launch)
    GSETTINGS_BACKEND=dconf gsettings set org.gnome.desktop.session idle-delay 30
    exit
    

    will put power off to 30 seconds…

  • Hey @joekamprad,

    I followed the commands you gave in your previous reply to the letter (multiple times), but unfortunately my screen delay remained at the 10-15 second (default) interval. You can see me typing your commands in the screenshot below, the only change is I tried it for 60 seconds (instead of 30 seconds as you did):

    Screenshot:
    https://imgur.com/a/BSCKk

    Is there something I am doing incorrectly? As I said, I tried this at least 4-5 times…and after each attempt the default interval for the blank screen does NOT change.

    Thanks again for all of your time and help, it is greatly appreciated.

    Thanks,
    Asif

  • @a4orce84
    Hi friend!
    Did you disable screensaver/powersaver from startup by any chance? Enable again in case you did, then try again (for testing).

  • @a4orce84 looks like 15 is the maximum delay? i can see here also it powers off after 15 seconds…

  • Ah thanks @joekamprad. From your previous reply, I was under the assumption you had successfully increased the delay to 30 seconds.

    So, at this point there is nothing that can be done to increase the delay as far as you know? I’ve also researched and have come to the same conclusion so far.

    Thanks again.

  • @a4orce84 yes delay option looks like working only this way… but may there is another one can handle it…

Posts 11Views 894
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.