• Shutter issue ( ¡¡¡¡¡ Finally shutter works !!!!)


    Hi, a simple question :

    Has anyone managed to install shutter after perl update[b:2nfyf6at] (5.18—>5.20)[/b:2nfyf6at] broke the package ?

    Best regards

    [b:2nfyf6at]Edit:[/b:2nfyf6at] ¡¡¡¡¡ Finally shutter works !!!
    [b:2nfyf6at]
    Step 1:[/b:2nfyf6at]

    Download this PKGBUILD: [https://github.com/alerque/aur/blob/master/shutter/PKGBUILD][0]">[https://github.com/alerque/aur/blob/mas][1] … r/PKGBUILD

    [b:2nfyf6at]Step 2[/b:2nfyf6at]:

    Run the comand[b:2nfyf6at] makepkg -s ( as current user) [/b:2nfyf6at] in the directory on you has saved the file[b:2nfyf6at] PKGBUILD[/b:2nfyf6at].

    …[b:2nfyf6at].there are missing dependencies :
    [/b:2nfyf6at]

      
      
    yaourt libxml-perl --noconfirm  
    yaourt perl-gtk2-imageview --noconfirm  
    yaourt perl-gtk2-unique --noconfirm  
    yaourt perl-proc-simple --noconfirm  
    yaourt perl-proc-processtable --noconfirm  
    yaourt perl-net-dropbox-api --noconfirm  
    yaourt perl-goo-canvas --noconfirm  
    
    

    [b:2nfyf6at]Step 3:[/b:2nfyf6at]

    Again re-run:

      
    makepkg -s   
    
    

    [b:2nfyf6at]Step 4: [/b:2nfyf6at]

    Finally install the package what you has built with the above comands:

    sudo pacman -U shutter-0.91-1-x86\_64.pkg.tar.xz
    

    Best regards…

    [0]: <a href=
    [1]: https://github.com/alerque/aur/blob/mas

  • Hi, a simple question :

    Has anyone managed to install shutter after perl update[b:2nfyf6at] (5.18—>5.20)[/b:2nfyf6at] broke the package ?

    Best regards

    [b:2nfyf6at]Edit:[/b:2nfyf6at] ¡¡¡¡¡ Finally shutter works !!!
    [b:2nfyf6at]
    Step 1:[/b:2nfyf6at]

    Download this PKGBUILD: [https://github.com/alerque/aur/blob/master/shutter/PKGBUILD][0]">[https://github.com/alerque/aur/blob/mas][1] … r/PKGBUILD

    [b:2nfyf6at]Step 2[/b:2nfyf6at]:

    Run the comand[b:2nfyf6at] makepkg -s ( as current user) [/b:2nfyf6at] in the directory on you has saved the file[b:2nfyf6at] PKGBUILD[/b:2nfyf6at].

    …[b:2nfyf6at].there are missing dependencies :
    [/b:2nfyf6at]

      
      
    yaourt libxml-perl --noconfirm  
    yaourt perl-gtk2-imageview --noconfirm  
    yaourt perl-gtk2-unique --noconfirm  
    yaourt perl-proc-simple --noconfirm  
    yaourt perl-proc-processtable --noconfirm  
    yaourt perl-net-dropbox-api --noconfirm  
    yaourt perl-goo-canvas --noconfirm  
    
    

    [b:2nfyf6at]Step 3:[/b:2nfyf6at]

    Again re-run:

      
    makepkg -s   
    
    

    [b:2nfyf6at]Step 4: [/b:2nfyf6at]

    Finally install the package what you has built with the above comands:

    sudo pacman -U shutter-0.91-1-x86\_64.pkg.tar.xz
    

    Best regards…

    [0]: <a href=
    [1]: https://github.com/alerque/aur/blob/mas

  • No, but check this post for alternatives: [http://forum.antergos.com/viewtopic.php?f=28&t=1834][0]">viewtopic.php?f=28&t=1834

    Cheers!

    [0]: <a href=

  • yea! shutter is working!! thanks hector!!

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • Well, I updated both a 32 bit and a 64 bit system, before attempting to re-install Shutter. And in both instances, it failed to install.

    The 32 bit system error was -

    error: target not found: perl-file-copy-recursive
    

    The 64 bit was a bit different -

    ==\> Retrieving sources...  
    -\> Downloading Module-Build-Tiny-0.036.tar.gz...  
    % Total % Received % Xferd Average Speed Time Time Time Current  
    Dload Upload Total Spent Left Speed  
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0  
    100 20464 100 20464 0 0 27569 0 --:--:-- --:--:-- --:--:-- 27569  
    ==\> Validating source files with sha512sums...  
    Module-Build-Tiny-0.036.tar.gz ... Passed  
    ==\> Extracting sources...  
    -\> Extracting Module-Build-Tiny-0.036.tar.gz with bsdtar  
    ==\> Starting build()...  
    Parse::CPAN::Meta version 1.4414 required--this is only version 1.4405 at /usr/share/perl5/core\_perl/CPAN/Meta.pm line 60\.  
    BEGIN failed--compilation aborted at /usr/share/perl5/core\_perl/CPAN/Meta.pm line 60\.  
    Compilation failed in require at lib/Module/Build/Tiny.pm line 8\.  
    BEGIN failed--compilation aborted at lib/Module/Build/Tiny.pm line 8\.  
    Compilation failed in require at Build.PL line 3\.  
    BEGIN failed--compilation aborted at Build.PL line 3\.  
    ==\> ERROR: A failure occurred in build().  
    Aborting...  
    ==\> ERROR: Makepkg was unable to build perl-module-build-tiny.  
    ==\> Restart building perl-module-build-tiny ? [y/N]  
    ==\> -----------------------------------------------  
    ==\>   
    ==\> Restart building perl-yaml-tiny ? [y/N]  
    ==\> ---------------------------------------  
    ==\>   
    ==\> Restart building perl-data-random ? [y/N]  
    ==\> -----------------------------------------  
    ==\>   
    ==\> Restart building perl-net-dropbox-api ? [y/N]  
    ==\> ---------------------------------------------  
    ==\>   
    ==\> Restart building shutter ? [y/N]  
    ==\> --------------------------------  
    ==\>   
    
    

    Meh, Hotshots is working for me. I don’t care for it as much, but it does work. So long Shutter. It has been real. It has been fun. But it has not been real fun.

  • did you install all 7 deps, one at a time? that is what I did.

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • @“maxpro4u”:2fhsdzcb said:

    did you install all 7 deps, one at a time? that is what I did.[/quote:2fhsdzcb]
    Mea culpa. I did not see the original post had been edited, to reflect the new information. The database marking took me to your post as being the most recent addition to this thread, so I completely missed Hector’s edit.

    Exactly how does one go about downloading that PKGBUILD file? I’ve never used GitHub, and I can’t seem to find any download links. I tried copying the data into a file named PKGBUILD, but that was a non-starter.

  • take that PKGBUILD file you made and put it in a new folder. then navigate with the terminal to that new folder and run the command makepkg -s

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • @hector

    Thanks, I worked perfect

    there is an error that you must correct, missing -S in yaourt

    This is correct

    yaourt -S libxml-perl --noconfirm  
    yaourt -S perl-gtk2-imageview --noconfirm  
    yaourt -S perl-gtk2-unique --noconfirm  
    yaourt -S perl-proc-simple --noconfirm  
    yaourt -S perl-proc-processtable --noconfirm  
    yaourt -S perl-net-dropbox-api --noconfirm  
    yaourt -S perl-goo-canvas --noconfirm
    

    Gracias de nuevo

    Antergos (Gnome)

  • ==\> ERROR: A failure occurred in build().  
    Aborting...  
    ==\> ERROR: Makepkg was unable to build perl-module-build-tiny.  
    ==\> Restart building perl-module-build-tiny ? [y/N]  
    ==\> -----------------------------------------------  
    ==\>   
    ==\> Restart building perl-yaml-tiny ? [y/N]  
    ==\> ---------------------------------------  
    ==\>   
    ==\> Restart building perl-data-random ? [y/N]  
    ==\> -----------------------------------------  
    ==\>   
    ==\> Restart building perl-net-dropbox-api ? [y/N]  
    ==\> ---------------------------------------------  
    ==\>   
    
    

    <SIGH>

  • @“Mike”:282qda44 said:

    ==\> ERROR: A failure occurred in build().  
    > Aborting...  
    > ==\> ERROR: Makepkg was unable to build perl-module-build-tiny.  
    > ==\> Restart building perl-module-build-tiny ? [y/N]  
    > ==\> -----------------------------------------------  
    > ==\>   
    > ==\> Restart building perl-yaml-tiny ? [y/N]  
    > ==\> ---------------------------------------  
    > ==\>   
    > ==\> Restart building perl-data-random ? [y/N]  
    > ==\> -----------------------------------------  
    > ==\>   
    > ==\> Restart building perl-net-dropbox-api ? [y/N]  
    > ==\> ---------------------------------------------  
    > ==\>   
    > 
    

    [/quote:282qda44]

    Mike, please delete all files of shutter[/color:282qda44], you has installed shutter from aur:
    i think …

    yaourt -S shutter
    

    [b:282qda44]These files are wrong…[/b:282qda44]
    Once deleted … follow the steps … get off the PKGBUILD from the post…
    Best Regards

  • Hector, you are correct. When I initially installed Shutter, it was through yaourt.

    I removed every Shutter-related file I could find and I still get the same error -

    BEGIN failed--compilation aborted at /usr/share/perl5/core\_perl/CPAN/Meta.pm line 60\.  
    Compilation failed in require at lib/Module/Build/Tiny.pm line 8\.  
    BEGIN failed--compilation aborted at lib/Module/Build/Tiny.pm line 8\.  
    Compilation failed in require at Build.PL line 3\.  
    BEGIN failed--compilation aborted at Build.PL line 3\.  
    ==\> ERROR: A failure occurred in build().  
    Aborting...  
    ==\> ERROR: Makepkg was unable to build perl-module-build-tiny.  
    ==\> Restart building perl-module-build-tiny ? [y/N]  
    ==\> -----------------------------------------------  
    ==\>   
    ==\> Restart building perl-yaml-tiny ? [y/N]  
    ==\> ---------------------------------------  
    ==\>   
    ==\> Restart building perl-data-random ? [y/N]  
    ==\> -----------------------------------------  
    ==\>   
    ==\> WARNING: Dependencies have been installed before the failure  
    checking dependencies...  
      
    Packages (1): perl-json-2.90-1  
      
    Total Removed Size: 0.23 MiB  
      
    :: Do you want to remove these packages? [Y/n] y  
    (1/1) removing perl-json [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    ==\> Restart building perl-net-dropbox-api ? [y/N]  
    ==\> ---------------------------------------------  
    ==\>   
    
    

    Thank Goodness for HotShots, where I believe I will just remain. Shutter has been a thorn in my side since I came to Antergos/Arch, so maybe it is best to just avoid it, and use HotShots. Or to use my Mint machine to run Shutter.

  • @“Yoyo”:2q2a12x6 said:

    I have installed without problems [http://yoyo308.com/2014/06/25/como-instalar-shutter-0-91-desde-aur-y-no-morir-en-el-intento/][0]">[http://yoyo308.com/2014/06/25/como-inst][1] … l-intento/[/quote:2q2a12x6]

    With Cinnamon and your guide works flawlessly, TY a lot

    [Gracias genio]

    [0]: <a href=
    [1]: http://yoyo308.com/2014/06/25/como-inst

    [b:19k5d423]There is always a solution/Siempre hay una solución[/b:19k5d423]

    [b:19k5d423]Arg[/color:19k5d423][color=\#FFFF0…

  • Hector, I just managed to install Shutter on a VM Antergos install, using your method. Apparently I have missed some previously installed packages on my metal install. It is nice to see it working again, even if it is in a VM.

  • Hector, I have to be missing a Shutter dependency, when I’m deleting things. I booted into my Arch install, did a neat (sudo pacman -Rns) removal of Shutter, and then followed your guide. Shutter is running like a top.

    I need to do some more reading to see how to discover all the dependencies for installed packages, to see if I can get things working in the Antergos partition.

Posts 16Views 2059
Log in to reply