• A pain and a mystery (monitor and video problems)


    So I have two issues:
    First: I’m running xfce on a asus chromebox. I installed using the CLI interface and have gotten steam running.

    1. I cannot keep the monitor from shutting down after 10 min. when I’m watching a movie - ie the computer is idle. I’ve fiddled with the power settings in xfce and messed around in the dconf editor, but nothing seems to work, which makes watching Game of Thrones or World Cup rather irritating. I’m currently using gnome-mplayer which leads to another issue

    2. I was getting terrible screen tearing when watching mkvs. After a lot of trial and error I ended up installing vdpau and vaapi. Now mkv’s look great in gnomemplayer using vaapi. I do prefer smplayer though - but since intalling vdpau and vaapi (including mplayer-vaapi) to get gnome’s mplayer to work smplayer video stutters and jerks. I’ve tried all the video drivers, xv/gl/vaapi/vdpau, and nothing seems to work. Any ideas on some things to try. I already removed it, deleted the smplayer config stuff in my ~ directory and reiinstalled.

    On another note Chrome and Chromium are just terrible. They leave all kinds of artifacts on the screen (like the screen isn’t refreshing properly). If I open a new tab there’s a some kind of mish-mash, but when I grab the title bar and move it around, then everything pops like it should.

    Chrome/Chromium problem seems to be fixed. Added a file 20-intel.conf in /etc/X11/xorg.conf.d as follows:

    Section "Device"  
    Identifier "Intel Graphics"  
    Driver "intel"  
    Option "AccelMethod" "uxa"  
    Option "TearFree" "True"  
    EndSection
    

    SNA doesn’t always play well with others.

    Thanks

  • So I have two issues:
    First: I’m running xfce on a asus chromebox. I installed using the CLI interface and have gotten steam running.

    1. I cannot keep the monitor from shutting down after 10 min. when I’m watching a movie - ie the computer is idle. I’ve fiddled with the power settings in xfce and messed around in the dconf editor, but nothing seems to work, which makes watching Game of Thrones or World Cup rather irritating. I’m currently using gnome-mplayer which leads to another issue

    2. I was getting terrible screen tearing when watching mkvs. After a lot of trial and error I ended up installing vdpau and vaapi. Now mkv’s look great in gnomemplayer using vaapi. I do prefer smplayer though - but since intalling vdpau and vaapi (including mplayer-vaapi) to get gnome’s mplayer to work smplayer video stutters and jerks. I’ve tried all the video drivers, xv/gl/vaapi/vdpau, and nothing seems to work. Any ideas on some things to try. I already removed it, deleted the smplayer config stuff in my ~ directory and reiinstalled.

    On another note Chrome and Chromium are just terrible. They leave all kinds of artifacts on the screen (like the screen isn’t refreshing properly). If I open a new tab there’s a some kind of mish-mash, but when I grab the title bar and move it around, then everything pops like it should.

    Chrome/Chromium problem seems to be fixed. Added a file 20-intel.conf in /etc/X11/xorg.conf.d as follows:

    Section "Device"  
    Identifier "Intel Graphics"  
    Driver "intel"  
    Option "AccelMethod" "uxa"  
    Option "TearFree" "True"  
    EndSection
    

    SNA doesn’t always play well with others.

    Thanks

  • Looks like I might have fixed problem 1. There’s a program called xset which helps control DPMS ([url:1pd6mv2g]https://wiki.archlinux.org/index.php/Display_Power_Management_Signaling[/url:1pd6mv2g]). I’ve used the following:

    xset -dpms  
    xset s off
    

    There was a bit of a hiccup at 10 min. on the video I was watching, but it kept playing. Hopefully this won’t happen every 10 min.

    Here is a small script to keep monitors from shutting off. I don’t think XFCE is doing it’s job talking to X about power management.
    Just put the script in /usr/bin, chmod 777 and put in with the other things at start up.

    \#!/bin/bash  
    \# Small script to keep the screen from turning off   
    \# put in /usr/bin and run at startup   
    xset -dpms  
    xset s off  
    xset s noblank
    
Posts 3Views 1168
Log in to reply