• Boot ISO from grub2


    Hi, I’m trying to boot the ISO from grub2 installed on a USB flash I have success with lots of distros but not with antegros
    For example with Manjaro or archbang I’m using:

      
    set isopath=/ISO  
    set drive\_label=MULTIBOOT  
    export isopath  
    export drive\_label  
      
      
    menuentry "Manjaro Cinnamon 0.8.9 x64" {  
    set isofile="$isopath/manjaro-cinnamon-0.8.9-x86\_64.iso"  
    loopback loop $isofile  
    linux (loop)/manjaro/boot/x86\_64/manjaroiso img\_dev=/dev/disk/by-label/$drive\_label img\_loop=$isofile misobasedir=manjaro misolabel=MJRO\_089 nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 locale.LANG=es\_ES.utf8 timezone=Europe/London  
    initrd (loop)/manjaro/boot/x86\_64/manjaro.img  
    }  
      
      
    menuentry "Archbang rc 2014.03.09 i686" {  
    set isofile="$isopath/archbang-rc-2014.03.09-i686.iso"  
    loopback loop $isofile  
    linux (loop)/arch/boot/i686/vmlinuz archisobasedir=arch img\_dev=/dev/disk/by-label/$drive\_label archisolabel=ARCHBANG img\_loop=$isofile quiet  
    initrd (loop)/arch/boot/i686/archiso.img  
    }  
    
    
  • Hi, I’m trying to boot the ISO from grub2 installed on a USB flash I have success with lots of distros but not with antegros
    For example with Manjaro or archbang I’m using:

      
    set isopath=/ISO  
    set drive\_label=MULTIBOOT  
    export isopath  
    export drive\_label  
      
      
    menuentry "Manjaro Cinnamon 0.8.9 x64" {  
    set isofile="$isopath/manjaro-cinnamon-0.8.9-x86\_64.iso"  
    loopback loop $isofile  
    linux (loop)/manjaro/boot/x86\_64/manjaroiso img\_dev=/dev/disk/by-label/$drive\_label img\_loop=$isofile misobasedir=manjaro misolabel=MJRO\_089 nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 locale.LANG=es\_ES.utf8 timezone=Europe/London  
    initrd (loop)/manjaro/boot/x86\_64/manjaro.img  
    }  
      
      
    menuentry "Archbang rc 2014.03.09 i686" {  
    set isofile="$isopath/archbang-rc-2014.03.09-i686.iso"  
    loopback loop $isofile  
    linux (loop)/arch/boot/i686/vmlinuz archisobasedir=arch img\_dev=/dev/disk/by-label/$drive\_label archisolabel=ARCHBANG img\_loop=$isofile quiet  
    initrd (loop)/arch/boot/i686/archiso.img  
    }  
    
    
  • Hi,

    Have you tried setting the iso label like this:[code:2lkhvgbk]archisolabel=ANTERGOS[/code:2lkhvgbk]

    Best Regards,
    Dustin

  • @“lots.0.logs”:1ydsctb0 said:

    Hi,

    Have you tried setting the iso label like this:

      
    >   
    >   
    >   
    > Best Regards,  
    > Dustin[/quote:1ydsctb0]  
    >   
    > I have, right now I have:   
    >   
    > linux (loop)/arch/boot/vmlinuz initrd=(loop)/arch/boot/archiso.img archisobasedir=arch archisolabel=ANTERGOS
    
Posts 4Views 2578
Log in to reply